Jockey doesn't offer fglrx

Bug #262819 reported by garrett.todd on 2008-08-29
114
This bug affects 2 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Critical
Unassigned
jockey (Ubuntu)
High
Martin Pitt
ubuntu-meta (Ubuntu)
Low
Unassigned

Bug Description

Toshiba Satellite m305d-s4831. ATI 3100 card not recognized in Hardware Drivers as a proprietary. Does not even show up. It does show it in terminal lspci. Ubuntu 8.10 Alpha4. Synaptic 0.62.1ubuntu8

Timo Aaltonen (tjaalton) wrote :

That's because the proprietary driver does not support the xserver in intrepid, so there's no point in offering a driver which would result in a broken system.

Mario Limonciello (superm1) wrote :

This is because jockey doesn't depend on fglrx-installer yet. This is intentional because there is no fglrx support yet for 8.10.

Changed in fglrx-installer:
importance: Undecided → Critical
status: New → Triaged
Mario Limonciello (superm1) wrote :

When the fglrx is ready for xorg 1.5, there are three tasks needed here. I'll open up a task against each source package:
1) Add fglrx-modaliases as a dependency for jockey
2) Move fglrx-installer into restricted (it's in multiverse right now)
3) Add xorg-driver-fglrx to the DVD ship seed near where nvidia-glx-* is.

Changed in ubuntu-meta:
importance: Undecided → Low
status: New → Triaged
Changed in jockey:
importance: Undecided → Critical
status: New → Triaged
rjr162 (ronrossman-mobile) wrote :
Download full text (3.7 KiB)

I tried to install the driver right off the ATI website, but ran into two issues so far.

If you run the actual ati*.run file, you'll get:

rjr162@rjr162-laptop:~/Desktop$ sudo ./ati*.run
Created directory fglrx-install.O16780
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.532...............................
==================================================
 ATI Technologies Linux Driver Installer/Packager
==================================================

Error: ./default_policy.sh does not support version
default:v2:i686:lib::none:2.6.27-7-generic; make sure that the version is being
correctly set by --iscurrentdistro

--iscurrentdistro doesn't affect the setup in any fashion, so I did
./ati-driver-installer-8-9-x86.x86_64.run --extract
and played around with the scripts but still no go.

I don't get why people say the xorg version isn't supported... when you extract the file from ATI you clearly see this in the packages:
rjr162@rjr162-laptop:~/Desktop/test/packages$ ls
ATI Debian Fedora Mandriva RedFlag RedHat Slackware SuSE Ubuntu
rjr162@rjr162-laptop:~/Desktop/test/packages$ cd Ubuntu
rjr162@rjr162-laptop:~/Desktop/test/packages/Ubuntu$ ls
ati-packager.sh ChangeLog dists
rjr162@rjr162-laptop:~/Desktop/test/packages/Ubuntu$ cd dists
rjr162@rjr162-laptop:~/Desktop/test/packages/Ubuntu/dists$ ls
7.10 8.04 8.10 gutsy hardy intrepid source
rjr162@rjr162-laptop:~/Desktop/test/packages/Ubuntu/dists$ cd intrepid
rjr162@rjr162-laptop:~/Desktop/test/packages/Ubuntu/dists/intrepid$ ls
10fglrx.in compat fglrx-kernel-source.install.in overrides xorg-driver-fglrx.default xorg-driver-fglrx.links
acpi control fglrx-kernel-source.postinst README.Debian xorg-driver-fglrx-dev.install.in xorg-driver-fglrx.manpages
amdcccle.desktop copyright fglrx-kernel-source.prerm replacements xorg-driver-fglrx-dev.links xorg-driver-fglrx.postinst
amdcccle.kdelnk dkms.conf.in fglrx-modaliases.install rules xorg-driver-fglrx.dirs xorg-driver-fglrx.postrm
changelog.in fglrx-amdcccle.install.in modaliases xorg-driver-fglrx.atieventsd.init xorg-driver-fglrx.install.in xorg-driver-fglrx.preinst
rjr162@rjr162-laptop:~/Desktop/test/packages/Ubuntu/dists/intrepid$ cd ..
rjr162@rjr162-laptop:~/Desktop/test/packages/Ubuntu/dists$ cd 8.10
rjr162@rjr162-laptop:~/Desktop/test/packages/Ubuntu/dists/8.10$ ls
10fglrx.in compat fglrx-kernel-source.install.in overrides xorg-driver-fglrx.default xorg-driver-fglrx.links
acpi control fglrx-kernel-source.postinst README.Debian xorg-driver-fglrx-dev.install.in xorg-driver-fglrx.manpages
amdcccle.desktop copyright fglrx-kernel-source.prerm replacements xorg-driver-fglrx-dev.links xorg-driver-fglrx.postinst
amdcccle.kdelnk dkms.conf.in fglrx-mod...

Read more...

Martin Pitt (pitti) wrote :

For the record, current intrepid jockey explicitly disables fglrx, since it is doomed to fail, and update-manager transitions user to ati on upgrade.

As soon as we get a fixed fglrx driver from AMD and SRU it to intprepid, we should remove the jockey ban of fglrx along with it.

Martin Pitt (pitti) wrote :

fglrx-installer was just fixed, see bug 247376.

Changed in fglrx-installer:
status: Triaged → Fix Released
Martin Pitt (pitti) wrote :

So I can go ahead with adding recommends to the fglrx modaliases and re-enable the handler again.

Changed in jockey:
assignee: nobody → pitti
importance: Critical → High
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.5~beta2-0ubuntu2

---------------
jockey (0.5~beta2-0ubuntu2) intrepid; urgency=low

  * Merge bug fixes from trunk:
    - openprinting.org detected handlers: Add supplier and support contacts to
      long description. (LP: #269454)
    - backend.py, set_enabled(): Report progress signals early when handling
      packages, to avoid delays until package manager sends out the first
      progress. (LP: #279073)
  * data/handlers/fglrx.py: Enable driver again, current version works now.
    Also add "Recommends: fglrx-modaliases", so that detection works in a
    default installation. (LP: #262819)

 -- Martin Pitt <email address hidden> Wed, 15 Oct 2008 00:10:53 +0200

Changed in jockey:
status: In Progress → Fix Released
Martin Pitt (pitti) wrote :

Unfortunately the DVD seed part is more tricky. fglrx-installer is still in multiverse and not in restricted because it build-depends on libstdc++5. gcc-3.3 is not in main any more (and that's a good thing!). So unless we can drop the build dep, it needs to stay in multiverse.

Changed in ubuntu-meta:
status: Triaged → Incomplete
Charlie Kravetz (charlie-tca) wrote :

I am confirming this since it is waiting on the dvd decision to be completed. See comment #9.

Changed in ubuntu-meta:
status: Incomplete → Confirmed
Mario Limonciello (superm1) wrote :

The DVD seed part was resolved this morning and will be visible in DVDs after today.

Changed in ubuntu-meta:
status: Confirmed → Fix Released
Eduardo Cereto (dudus) wrote :

nvidia-common depends on jockey-common. I don't understand why it only recommends fglrx-modaliases if nvidia counterparts is installed by default.

jockey should deppend on fglrx-modaliases

Martin Pitt (pitti) wrote :

Eduardo, nvidia-common has no relation to jockey-common at all. jockey-common merely recommends nvidia-common, just like fglrx-modaliases.

A strict dependency is too much, since it should be possible to install Ubuntu without non-free drivers, and jockey doesn't depend on fglrx/nvidia at all. The latter just provide drivers which jockey can handle.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers