jockey does not suggest fglrx driver in intrepid

Bug #258641 reported by Saivann Carignan on 2008-08-16
This bug report is a duplicate of:  Bug #262819: Jockey doesn't offer fglrx. Edit Remove
2
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Medium
Alberto Milone

Bug Description

I have a laptop with :

01:00.0 VGA compatible controller [0300]: ATI Technologies Inc M22 [Mobility Radeon X300] [1002:5460]

With Hardy, jockey always recommend to install fglrx driver to make that graphic card working, but with intrepid, I only get a empty list and "No proprietary drivers are in use on this system." like a computer which uses a intel graphic card.

Saivann Carignan (oxmosys) wrote :

Oh... this might actually not be a real bug, opensource drivers for this graphic card seems to have improved since Hardy. Direct rendering was already good and now 3D even works very great!

The opensource driver is still blacklisted by compiz so desktop effects cannot be enabled, but the driver itself seems better than fglrx. More stable, no video output problems and good 3D performances.

Saivann Carignan (oxmosys) wrote :

The opensource driver is not blacklisted in compiz anymore, and it works very well, so I'm closing this bug report

Changed in jockey:
status: New → Invalid
Stephen Cradock (s-cradock) wrote :

I am getting the same error (jockey not offering to install fglrx, even though it is installed in synaptic) in Hardy. In this case the default xorg.conf seems to use the basic Mesa driver, not the newer DRI300 ati driver, and performance is abysmal. I have re-enabled the DRI300 open-source version, and performance is improved, but I would like to use fglrx. There seems to be something going on - can we re-open the bug, please, and try to get to the root of this?

I have been spending most of my time in Intrepid, but I did expect that Hardy (AKA LTS) would continue to allow me to choose to use the fglrx driver if I wished........

Saivann Carignan (oxmosys) wrote :

pitti : Can we have your opinion on that jockey bug?

Changed in jockey:
importance: Undecided → Medium
status: Invalid → Confirmed
milestone: none → ubuntu-8.10
Martin Pitt (pitti) wrote :

Ah, this actually needs to be fixed in the fglrx driver's modalias files. The lines need to point to the package name, xorg-driver-fglrx. Currently they do not specify any package name, and since the fglrx module is not available, jockey ignores the driver.

Alberto, do you have time to look at this? If not, I can do it next or next next week, when I'm back home.

Changed in jockey:
assignee: nobody → albertomilone
Alberto Milone (albertomilone) wrote :

Martin: this debdiff should solve the problem.

Mario: can you have a look at it and upload it, please?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer - 2:8.532-0ubuntu3

---------------
fglrx-installer (2:8.532-0ubuntu3) intrepid; urgency=low

  [ Alberto Milone (tseliot) ]
  * debian/modaliases/fglrx_supported:
    - Add "xorg-driver-fglrx" to the strings printed to
      fglrx-modules.alias.override so that Jockey can
      detect the name of the package to install (LP: #258641)

  [ Mario Limonciello ]
  * debian/kernel-source-patches/fglrx_8.9_2.6.27.patch:
    - Update to compile on x86_64 for 2.6.27 (LP: #266956)

 -- Mario Limonciello <email address hidden> Sun, 21 Sep 2008 12:29:18 -0500

Changed in fglrx-installer:
status: Confirmed → Fix Released
Saivann Carignan (oxmosys) wrote :

Even with latest patches, this bug is still not fixed for my laptop that have a ATI mobility radeon X300. However, this bug is a duplicate of bug critical bug so I mark it as such.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers