[fglrx] Black screen on Logoff, System completely unresponsive [EPR#260351]

Bug #241176 reported by Fel on 2008-06-19
6
Affects Status Importance Assigned to Milestone
fglrx
Triaged
High
Unassigned
fglrx-installer (Ubuntu)
Medium
Unassigned

Bug Description

Here is the scenario that in most cases reveals the issue on my desktop, but not in 100% cases. I login (my login is a member of admin group if this matters), do something. Then I switch user and login under some regular user account. Use the desktop for a while. The do logoff. The screen goes black as during a regular logoff but it never shows login prompt. Neither Ctrl+Alt+Backspace, nor Ctrl+Alt+Del work here. The only way out is to reset the machine.
Linux Bee 2.6.24-18-generic #1 SMP Wed May 28 20:27:26 UTC 2008 i686 GNU/Linux

xorg.0.log with driver fglrx: http://launchpadlibrarian.net/17021415/Xorg.0.log

With autodetection enabled and driver "RADEON" used, I can get to the login-screen but receive a black screen after logging in.

xorg.0.log with driver radeon, autodetected: http://launchpadlibrarian.net/17030342/Xorg.0.log

Excerpt from lspci:

01:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV530LE [Radeon X1600/X1650 PRO] [1002:71c6] (prog-if 00 [VGA controller])

Excerpt from dmesg:

[ 47.585077] [fglrx] Reserve Block - 0 offset = 0X7ffb000 length = 0X5000
[ 47.585084] [fglrx] Reserve Block - 1 offset = 0X0 length = 0X1000000
[ 47.585089] [fglrx] Reserve Block - 2 offset = 0Xffff000 length = 0X1000
[ 47.585093] [fglrx] Reserve Block - 3 offset = 0Xffbf000 length = 0X40000
[ 47.650702] [fglrx] interrupt source 20008000 successfully enabled
[ 47.650708] [fglrx] enable ID = 0x00000008
[ 47.650719] [fglrx] Receive enable interrupt message with irqEnableMask: 20008000
[ 47.650799] [fglrx] interrupt source 10000000 successfully enabled
[ 47.650804] [fglrx] enable ID = 0x00000009
[ 47.650810] [fglrx] Receive enable interrupt message with irqEnableMask: 10000000

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Thank you for taking the time to report this bug and helping to make
Ubuntu better. Please attach your X server configuration file
(/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.0.log) to the
bug report as individual uncompressed file attachments using the
"Attachment:" box below. Could you please also try to run without any
/etc/X11/xorg.conf and let Xorg autodetect your display and video card?
Please also attach the /var/log/Xorg.0.log from this attempt. Thanks in
advance.

 status incomplete
 subscribe

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkiu+YMACgkQ06FgkPZwicQg5wCgtJEMB11BhF64u9GKucJEfb7h
/ZAAoOGqicf9iVwRvxdgaZjjqS1rpaN4
=wR6b
-----END PGP SIGNATURE-----

Changed in xorg:
status: New → Incomplete
Fel (fdeluda) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

1. Please include the output of the command "uname -a" in your next
response. It should be one, long line of text which includes the exact
kernel version you're running, as well as the CPU architecture.

2. Please run the command "dmesg > dmesg.log" after a fresh boot and
attach the resulting file "dmesg.log" to this bug report.

3. Please run the command "sudo lspci -vvnn > lspci-vvnn.log" and attach
the resulting file "lspci-vvnn.log" to this bug report.

TIA

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkivGBEACgkQ06FgkPZwicSRZwCgrQn+VxTgObb8FOvuCWy8tRQj
ykcAn3/Ul/SmZXMgV7kNh8c5VNDG1ObW
=UWDy
-----END PGP SIGNATURE-----

Linux Bee 2.6.24-19-generic #1 SMP Fri Jul 11 23:41:49 UTC 2008 i686 GNU/Linux

Fel (fdeluda) wrote :
Fel (fdeluda) wrote :

I've attached the outputs of the commands you mentioned. Hope this helps.

The only thing I did not try - launching Xorg without the config file. Did you mean "Xorg -configure"?

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

> The only thing I did not try - launching Xorg without the config file.
> Did you mean "Xorg -configure"?
>

No, try renaming /etc/X11/xorg.conf to (e.g.) /etc/X11/xorg.conf.backup,
then restart the Xserver (ctrl-alt-backspace). That should provoke
autoconfiguration of X. Then please attach the /var/log/xorg.0.log of
this start. Thank you.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkivSekACgkQ06FgkPZwicQYYQCfce7BpdpEy/vl/LNG7FxgwlUA
iUMAn3oYg652NQY4ZKdw4VvNNLHYf1qg
=JUjA
-----END PGP SIGNATURE-----

Andreas Moog (ampelbein) on 2008-08-23
description: updated

Here is the X log file with the conf renamed. See attached.

There are a few things I would like to mention. When I renamed the xorg.conf and restarted the X I got the login screen and after submitting my login credentials I did not actually get the desktop. I waited for a few minutes until the hard drive stopped the noise and it was clear for me that that's it.

I use proprietary driver for my ATI X 1650 PRO video card. I enabled it to make Compiz work. So if this is the driver that causes such behaviour, maybe it cannot be fixed.

Andreas Moog (ampelbein) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

description: updated
Changed in xorg:
status: Incomplete → Confirmed

Was mis-filed as an -ati bug, when the original reported problem is an fglrx one.

The problems with the FOSS driver described in #9 really should be a separate bug; not enough info provided to determine if that's a known issue or not.

Jay Morgan (morgan-jay) wrote :

Me too. Attached my Xorg.conf file
I have an ATI Radeon X1550 64bit video card. I got it because it was on a list of cards compatible with the fglrx driver. I share the computer with someone, which means someone is logging out constantly, and the computer gets hard-booted at least once a day, often many more times. Can't be too good for it. =(

Bryce Harrington (bryce) wrote :

Good day Fel,

I've just uploaded a new 8.543 version of -fglrx to Intrepid which now should work with xserver 1.5. Would you mind testing this new version and reporting back whether this issue is still present? If it is, it would be helpful if you could (re-)post your Xorg.0.log from running with this version. Thanks ahead of time.

If you don't have Intrepid installed on your system, you can test this by booting an Intrepid LiveCD (available from cdimage.ubuntu.com), using either the -vesa or -ati driver, then update to the latest version of Ubuntu, install fglrx, and then logout and back in. Your /var/log/Xorg.0.log will confirm whether you've loaded FGLRX successfully.

If you find any new issues, please report them as separate bugs. You can use the tool `ubuntu-bug fglrx-installer` which will gather the necessary files and create the launchpad report for you to fill in more easily.

Changed in fglrx-installer:
status: Confirmed → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in fglrx-installer:
status: Incomplete → Invalid
Fel (fdeluda) wrote :

Hi,

Sorry for the long delay in answering your message.

I have just upgraded to Intrepid and managed to reproduce the issue with some differences I would like to mention here:
1. My previous video card died and I get a new one - ASUS EAH3650 which uses ATI RADEON HD 3650 GPU. Here is a string I copied from lspci:
01:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 3600 Series

2. Now the steps to reproduce differ a little. When I do a log off it works as expected. But each time I switch users the screen goes black and the systems turns irresponsible.

Attached you will find my /var/log/Xorg.0.log file. Please let me know if any additional information is needed.

Thanks,
Felix

Felix:

Can you please rerun lspci with the proper arguments? The -vvnn is
important because it provides pci numeric identifiers (xxxx:yyyy) as well as
other hardware in the system to rule out interaction problems.

On Sun, Nov 2, 2008 at 04:13, Fel <email address hidden> wrote:

> Hi,
>
> Sorry for the long delay in answering your message.
>
> I have just upgraded to Intrepid and managed to reproduce the issue with
> some differences I would like to mention here:
> 1. My previous video card died and I get a new one - ASUS EAH3650 which
> uses ATI RADEON HD 3650 GPU. Here is a string I copied from lspci:
> 01:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon HD
> 3600 Series
>
> 2. Now the steps to reproduce differ a little. When I do a log off it
> works as expected. But each time I switch users the screen goes black
> and the systems turns irresponsible.
>
> Attached you will find my /var/log/Xorg.0.log file. Please let me know
> if any additional information is needed.
>
> Thanks,
> Felix
>
>
> ** Attachment added: "Xorg.0.log"
> http://launchpadlibrarian.net/19223985/Xorg.0.log
>
> --
> [fglrx] Black screen on Logoff, System completely unresponsive
> https://bugs.launchpad.net/bugs/241176
> You received this bug notification because you are subscribed to fglrx-
> installer in ubuntu.
>

--
Mario Limonciello
<email address hidden>

Please find "lspci -vvnn" output attached

Bryce Harrington (bryce) on 2008-11-06
Changed in fglrx-installer:
importance: Undecided → Medium
status: Invalid → Confirmed
guyvdb (guyvdb-gmail) wrote :

I seem to have the exact same problem on a fully updated ibex release (fresh install).

Switch user, black screen, nothing happens, no keyboard controls respond.

Mario Limonciello (superm1) wrote :

This bug is good for submitting upstream, has a log, lspci info, and method to reproduce (switch users).

Changed in fglrx-installer:
status: Confirmed → Triaged
Bryce Harrington (bryce) on 2008-11-24
Changed in fglrx:
importance: Undecided → High
status: New → Confirmed
Bryce Harrington (bryce) on 2008-12-09
Changed in fglrx:
status: Confirmed → Triaged
GY Kim (gasbank) wrote :

I have the same problem. Intrepid 64-bit, ATI, EAH3650 and fglrx.
Switch user makes system halt. With fglrx disabled, no problem.
Maybe fglrx has a problem :(

Jay Morgan (morgan-jay) wrote :

Mine hasn't locked up in a month or two now. Looks like something was fixed as regards Hardy with fglrx.

Thanks!

Pekka L J Jalkanen (plj) wrote :

I have this problem with fglrx drivers. However the system is NOT totally unresponsive; nothing will be visible on screen, but one can press ctrl-alt-F1 to switch to a text-based TTY and then reboot by pressing ctrl-alt-del in a controlled fashion.

System works normally after first login as long as the user doesn't log out (I didn't test fast user switching), and disabling Compiz won't affect the problem. Uninstalling fglrx drivers will fix it.

Card info:

administrator@kursk:~$ sudo lspci -vvnn |grep -A 12 ATI
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV610 LE AGP [Radeon HD 2400 PRO AGP] [1002:94c4]
 Subsystem: Hightech Information System Ltd. Device [1787:0028]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
 Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort+ >SERR- <PERR- INTx-
 Latency: 255 (2000ns min), Cache Line Size: 32 bytes
 Interrupt: pin A routed to IRQ 16
 Region 0: Memory at e0000000 (32-bit, prefetchable) [size=256M]
 Region 1: I/O ports at c800 [size=256]
 Region 2: Memory at ff8f0000 (32-bit, non-prefetchable) [size=64K]
 Expansion ROM at ff8c0000 [disabled] [size=128K]
 Capabilities: [50] Power Management version 3
  Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
--
01:00.1 Audio device [0403]: ATI Technologies Inc RV610 audio device [Radeon HD 2400 PRO] [1002:aa10]
 Subsystem: Hightech Information System Ltd. Device [1787:aa10]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 32 (2000ns min), Cache Line Size: 32 bytes
 Interrupt: pin B routed to IRQ 17
 Region 0: Memory at ff8ec000 (32-bit, non-prefetchable) [size=16K]
 Capabilities: [50] Power Management version 3
  Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer - 2:8.600-0ubuntu1

---------------
fglrx-installer (2:8.600-0ubuntu1) jaunty; urgency=low

  * New upstream release. (Closes LP: #313027, #314600)
    - Fixes LP: #253988, #179042, #241176, #284408, #287229, #296497,
      #288620, #289628
  * README.Debian: Update the update procedure a bit

 -- Bryce Harrington <email address hidden> Tue, 17 Mar 2009 15:40:42 -0700

Changed in fglrx-installer:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers