Computer freezes after restarting or resuming an X session when running compiz

Bug #199776 reported by billythegates on 2008-03-08
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
DRI
New
Undecided
Unassigned
fglrx-installer (Ubuntu)
Undecided
Unassigned

Bug Description

System: ThinkPad T42, Ubuntu 8.04 (Hardy Heron) Alpha 6 / ATI Mobility Radeon 9600 chip, FGLRX driver 8.47.3

With the latest version of the fglrx driver, compiz runs perfectly well and the machine is also able to suspend properly. But however, when I try to resume - with compiz previously enabled - I a get a grey and somewhat speckled slim bar on the lower right of the screen - sometimes with some artifacts around the mouse cursor (see screenshot). The mouse can be moved but nothing else will work - compiz desktop will just not awake a second time!

When I previously disable compiz and then set my machine in suspend mode and resume from it, this grey bar shows up as well, but only for a couple of milliseconds and then the desktop appears to start normally. It's the same when I log-off and try to log back on (with compiz enabled) X freezes totally and the only thing I can do is a hard reboot! This happens every time I try to start X for a second time. The freeze occurs while the log-on sound is playing so I also hear a frozen sound (just like "zzzzzzz").

I just found out that it also occurs when I switch from X (with compiz) to a console by pressing CTRL+ALT+F1! If I try to switch back to X (CTRL+ALT+F7), there is the same grey bar and nothing else works.

In the release notes of the fglrx driver there is a line which seems to be related to my issue...
"A black screen may be observed on some hardware when switching to the console or leaving the X window system when a Vesa framebuffer console driver is used. Further details can be found in topic number 737-30687"

Unfortunately I did not find a solution to this problem. I tried to disable vesafb in the kernel options ("vga=normal nofb"), but this did not solve anything.

I can provide you with more information - configuration files and logs - just say what you need and where I can find it!

I just tried to follow the step in https://wiki.ubuntu.com/DebuggingXorg, but when I try to restart X it freezes, and when I pgrep Xorg, I get two process numbers. If I try to attach process No 1, I get the following error message:

This GDB was configured as "i486-linux-gnu"...
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(gdb) attach 5488
Attaching to program: /usr/bin/Xorg, process 5488
warning: process 5488 is a cloned process
/build/buildd/gdb-6.7.1/gdb/linux-nat.c:979: internal-error: linux_nat_attach: Assertion `pid == GET_PID (inferior_ptid) && WIFSTOPPED (status) && WSTOPSIG (status) == SIGSTOP' failed.
A problem internal to GDB has been detected,
further debugging may prove unreliable.

If I try to attach the second process ID, the computer freezes again!

Is there anyone who has the same problems when trying to resume X? I'm just curious if it actually has something to do with the proprietary fglrx drivers or with compiz of with the vesa framebuffer. Did this issue also occur with other video-hardware than ATI's (e.g. NVIDIA)?

billythegates (mfittko) wrote :
description: updated
raanan (raanan-opcat) wrote :

Running on a thinkpad t43p, I have the same problem. X freezes while trying to resume, Using the new 8.3 drivers, on hardy.

billythegates (mfittko) wrote :

Okay, I could now reproduce a freeze without(!) running compiz:
With the most recent kernel (2.6.24-12-generic) and fglrx driver 8.3 (8.47.3) try starting "glxgears", abort it (ctrl+c), switch to console (ctrl+alt+F1), start "glxgears" again - freeze!
This did not occur when using the standard "ati"-driver, so for the moment I will have to switch back to "ati" if I'd want to use 3d stuff without direct rendering :(
Regardless of the fact that the bug related to the fglrx-driver, is there someone out there who has found a good workaround for this problem? Maybe by changing settings in xorg.conf or by using a different framebuffer driver or whatever? Please help me out!

Changed in compiz:
status: New → Invalid
Henri Schumacher (pacha-mama) wrote :

Have the same problem on Hardy and HP Compaq nc6000 with ATI MOBILITY RADEON 9600 graphics controller and fglrx-driver.
I use the ubuntu fglrx-driver from the restricted modules package. (Kernel Ubuntu-version: -17)
Also with the standard generic kernel and with a customized kernel with radeonfb.
Cannot switch back to X with ctrl+alt+F7 and the same problem when wake up from hibernate (TuxOnIce).
I read about a solution by change color depth from 24 to 16 in xorg.conf, but didn't dried yet.

Bryce Harrington (bryce) wrote :

Good day billythegates,

I've just uploaded a new 8.543 version of -fglrx to Intrepid which now should work with xserver 1.5. Would you mind testing this new version and reporting back whether this issue is still present? If it is, it would be helpful if you could (re-)post your Xorg.0.log from running with this version. Thanks ahead of time.

If you don't have Intrepid installed on your system, you can test this by booting an Intrepid LiveCD (available from cdimage.ubuntu.com), using either the -vesa or -ati driver, then update to the latest version of Ubuntu, install fglrx, and then logout and back in. Your /var/log/Xorg.0.log will confirm whether you've loaded FGLRX successfully.

If you find any new issues, please report them as separate bugs. You can use the tool `ubuntu-bug fglrx-installer` which will gather the necessary files and create the launchpad report for you to fill in more easily.

Changed in fglrx-installer:
status: New → Incomplete
Mario Limonciello (superm1) wrote :

Given this is r3xx hardware, it's broke for intrepid.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers