Failed to upgrade fglrx from 14.502 to 15.200 on Trusty.

Bug #1511301 reported by Kai-Heng Feng on 2015-10-29
60
This bug affects 7 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
High
Florin Neacsu
Trusty
High
Alberto Milone
fglrx-installer-updates (Ubuntu)
High
Unassigned
Trusty
High
Alberto Milone

Bug Description

SRU Request:

[Impact]

Upgrading from the upstream fglrx driver packages to the packages in the Ubuntu repository fails because the /etc/ati directory is a real directory instead of being a link (which was common in the Ubuntu packages).

[Test Case]
1. Install the fglrx driver (14.502) in Ubuntu 14.04 generating deb packages from the AMD installer
2. Upgrade the package to the current ubuntu release.
3. Check the apt-get output

Expected results: the fglrx module should be updated correctly.

Actual results:
The update fails as described below.

[Regression Potential]
Low. The change only affects a migration from a specific release.

______________________________________
Note that the fglrx 14.502 package name is fglrx_14.502-0ubuntu1_amd64_UB_14.01.deb, which is from AMD's site, not from Ubuntu repository.

Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for gconf2 (3.2.6-0ubuntu2) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...

(gtk-update-icon-cache-3.0:22930): GdkPixbuf-WARNING **: Cannot open pixbuf loader module file '/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache': No such file or directory

This likely means that your installation is broken.
Try running the command
  gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.
Processing triggers for install-info (5.2.0.dfsg.1-2) ...
Processing triggers for shared-mime-info (1.2-0ubuntu3) ...
Processing triggers for sgml-base (1.26+nmu4ubuntu1) ...
Processing triggers for gnome-icon-theme (3.10.0-0ubuntu2) ...

(gtk-update-icon-cache-3.0:23024): GdkPixbuf-WARNING **: Cannot open pixbuf loader module file '/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache': No such file or directory

This likely means that your installation is broken.
Try running the command
  gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.
Processing triggers for doc-base (0.10.5) ...
Processing 1 changed doc-base file...
Errors were encountered while processing:
 /var/cache/apt/archives/fglrx_2%3a15.200-0ubuntu0.5_amd64.deb
Log ended: 2015-10-22 05:31:11

X-HWE-Bug: Bug #1664810

summary: - Failed to upgrade fglrx from 14.502 to 15.200.
+ Failed to upgrade fglrx from 14.502 to 15.200 on Trusty.
Alberto Milone (albertomilone) wrote :

Quoting the original reporter: this issue happens when using the fglrx packages provided by AMD, where the /etc/ati directory is not a symbolic link, but a real directory.

Modifying debian/fglrx.preinst.in can solve this issue:

diff --git a/fglrx.preinst.in b/fglrx.preinst.in
index 50bfd4a..10f4afb 100644
--- a/fglrx.preinst.in
+++ b/fglrx.preinst.in
@@ -91,7 +91,7 @@ case "$1" in
             echo "Moving ati dir to /etc for the fglrx-core transition"
             cp -RL /etc/ati /etc/ati.dpkg-bak 2>/dev/null || true
             # Remove the link
- rm -f /etc/ati 2>/dev/null
+ rm -rf /etc/ati 2>/dev/null
             # Finally move ati into /etc
             mv /etc/ati.dpkg-bak /etc/ati 2>/dev/null || true

Changed in fglrx-installer (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → High
status: New → Triaged
Changed in fglrx-installer (Ubuntu Trusty):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Alberto Milone (albertomilone)
Changed in fglrx-installer (Ubuntu):
status: Triaged → Invalid
description: updated
Alberto Milone (albertomilone) wrote :

@SRU team: please accept fglrx-installer_15.200-0ubuntu0.6 and fglrx-installer-updates_15.200-0ubuntu0.6 into trusty-proposed.

Mathew Hodson (mhodson) on 2015-11-10
tags: added: third-party-packages trusty

i wanted to try the open source amd driver so i selected it from additional drivers and when i rebooted all was very unhappy and it wont' let me switch back via additional drivers or fix anything in package manager ( E: Internal Error, No file name for fglrx-amdcccle:i386 was what i got when i tried to reinstal)

did sudo apt-get -f, but no joy, said there were missing packages.

tried to read through this bug report but not sure what i should do. everything is all stretched and slooooow now.

i'm amd radeon hd 6250

help!

also, in the above you all say to try, i assume in terminal
gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
is this for me as well?

the only other time i had trouble with additional drivers was when i tried one of the betas (not there anymore) but these were all safe looking ones....i'm only a geekling so i don't have a clue how to fix....

last thing i tried in terminal before i give up tonight sudo apt-get install fglrx fglrx-amdcccle

and this is what happened which looked like what happened when i tried to fix it in package manager

Reading package lists... Done
Building dependency tree
Reading state information... Done
fglrx-amdcccle is already the newest version.
fglrx-amdcccle set to manually installed.
The following packages were automatically installed and are no longer required:
  account-plugin-windows-live libbit-vector-perl libcarp-clan-perl
  libdate-calc-perl libdate-calc-xs-perl libmpdec2 libupstart1
Use 'apt-get autoremove' to remove them.
The following NEW packages will be installed:
  fglrx
0 upgraded, 1 newly installed, 0 to remove and 19 not upgraded.
1 not fully installed or removed.
Need to get 0 B/22.9 MB of archives.
After this operation, 102 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 1320084 files and directories currently installed.)
Preparing to unpack .../fglrx_2%3a15.200-0ubuntu0.5_i386.deb ...
Moving ati dir to /etc for the fglrx-core transition
dpkg: error processing archive /var/cache/apt/archives/fglrx_2%3a15.200-0ubuntu0.5_i386.deb (--unpack):
 subprocess new pre-installation script returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/fglrx_2%3a15.200-0ubuntu0.5_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

i hope posting here for help is the right thing. this page https://help.ubuntu.com/community/BinaryDriverHowto/AMD said to come and report if i had issues with additional drivers, but wasn't sure what i should do from that page so i just tried the above. was afraid to mess things up too bad. when i tried that beta from additional drivers years ago it messed things up so bad i only had black screen and it took five hours to figure out how to fix it from the bootup. couldn't tell you what i did that finally fixed it lol.

thanks in advance for your help. this really sucks...

ok read through this bug report a half a dozen times trying to understand the tech talk and think mine might be different enough to report as it's own bug so i posted here https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/1516888 hope that was the right thing.

Hello Kai-Heng, or anyone else affected,

Accepted fglrx-installer into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/fglrx-installer/2:15.200-0ubuntu0.6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in fglrx-installer (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in fglrx-installer-updates (Ubuntu):
status: New → Invalid
Changed in fglrx-installer-updates (Ubuntu Trusty):
status: New → Fix Committed
Chris J Arges (arges) wrote :

Hello Kai-Heng, or anyone else affected,

Accepted fglrx-installer-updates into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/fglrx-installer-updates/2:15.200-0ubuntu0.6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

hi chris =) i fear the how to for the link re trusty proposed is beyond my geekling skills. it seems written for someone with more terminal knowledge than i have...

i follow step one, click trusty proposed, but the second step has all these options. i'm very confused. and have never created a file before, do i use sudo before? is there a how to for dummies? lol. i can do that! i've done terminal how tos form the forums but they were very 'do exactly this'.

ok in step two, can i do just this? they put it at bottom of that section
"Alternatively, you can use apt-get to install a package from -proposed by using

sudo apt-get install packagename/trusty-proposed

This method uses a higher priority to install packages. "

if so exactly what package should i put in?

and the section re enable apport...that seems optional? if not way beyond me.

Mathew Hodson (mhodson) on 2015-11-18
Changed in fglrx-installer (Ubuntu):
status: Invalid → Fix Released
Changed in fglrx-installer-updates (Ubuntu):
status: Invalid → Fix Released
importance: Undecided → High
Changed in fglrx-installer-updates (Ubuntu Trusty):
importance: Undecided → High
Mathew Hodson (mhodson) wrote :

This looks like it's fixed in Vivid and Wily. They use `rm -Rf /etc/ati`

Mathew Hodson (mhodson) wrote :

Serenity, after you enable trusty-proposed in Software & Updates, if you don't want to use the command line, you can just use Software Updater.

There will be a lot of updates available that you don't need. If you want just the AMD drivers, they should be listed as:

Video driver for the AMD graphics accelerators
Minimal video driver for the AMD graphics accelerators
Catalyst Control Center for the AMD graphics accelerators

You can disable trusty-proposed afterword.

aha, will go try. tried via the method i mentioned above via terminal with fglrx as the package and got this E: Release 'trusty-proposed' for 'fglrx' was not found. updater has decided not to open properly so only title bar is showing. gonna reboot and try what you said.

thanks so much chris for your help. ubuntu is my fav operating system but it's so slow and buggy with this driver issue =(

chris, did what you said and it crashed updater and i got this

THE PACKAGE SYSTEM IS BROKEN
Check if you are using third-party repositories. If so, disable them, because they are a common source of problems.
Furthermore, run the following command in a Terminal: apt-get install -f

had tried that a few times since this problem started and it always fails

i know from package manager that fglrx-amdcccle is broken. should i remove and reinstall that? i have tried to just reinstall it but that keeps failing....was afraid to try remove...

oops, sorry mathew, in my tech haze i didnt' notice it was you not chris that had answered. since doing it through the updater didn't work. should i try again or try something else? everytime i crash with this bug i am letting my ubuntu send crash reports to you all, so i figure that gives you the best info... i'm in my windows partition for ubuntu is pretty unuseable right now. way too slow and oddly stretched. it's making me nauseous lol.

i appreciate all your tech god help. i miss my unbuntu. windows gets on my nerves.

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of fglrx-installer from trusty-proposed was performed and bug 1518242 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and add the tag "bot-stop-nagging" to bug 1518242 (not this bug). Thanks!

tags: added: verification-failed
Kai-Heng Feng (kaihengfeng) wrote :

Hi serenity,

From your bug link, looks like you were upgrading fglrx from 13.350.1-0ubuntu2 to 15.200-0ubuntu0.6, but not exactly "Failed to upgrade fglrx from 14.502 to 15.200" as the bug title described.

Although the symptom looks the same, I think there are some differences between those two situation.

Anyway, can you try to manually remove the old fglrx via `apt-get purge` then installing the new one? I think this method might solve your problem.

Alberto Milone (albertomilone) wrote :

@serenity: the failure shows that you were upgrading to the 15.200-0ubuntu0.5 release, whereas the fix in this bug report is included in 15.200-0ubuntu0.6. I am pretty sure the fix will help you.

I'm removing the verification-failed tag.

tags: removed: verification-failed

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of fglrx-installer from trusty-proposed was performed and bug 1518242 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and add the tag "bot-stop-nagging" to bug 1518242 (not this bug). Thanks!

tags: added: verification-failed

hi kai and alberto,

alberto, am i right in thinking it sounds like there is a new fix and i should try and the software updater method matthew described to see if it will sort itself. when i tried it last it just crashed.

kai, and if that doesn't work then you're saying that it's safe to just purge the fglrx. that won't break it worse? (can it get worse lol) is it sudo apt-get purge fglrx? then sudo apt-get fglrx installer? is there a dash between fglrx-installer? i know such things can be important.

thanks guys. indeed i do think my issue is a bit different from what little my geekling understanding allows me, but also looks like some of the ways of fixing it might be similar. i did post a separate bug when i realized that in case that allowed the unbuntu gods to help sort it.

haven't been back in ubuntu in a few days. been updating/upgrading my windows partition so i have a functional operating system, even if it's not my beloved ubuntu. will wait to try out the fix till later. am geekling tech brained out right now after windows 10 upgrade. i think it might have eaten a teenie tiny bit of my soul =P

Kai-Heng Feng (kaihengfeng) wrote :

Hi Serenity,

First, be sure the APT is updated:
$ sudo apt-get update

Then you can remove old fglrx by `apt-get purge`:
$ sudo apt-get purge fglrx fglrx-core fglrx-amdcccle

Finally, reinstall them:
$ sudo apt-get install fglrx fglrx-core fglrx-amdcccle

And supposedly, this should fix your upgrading problem.

Alberto Milone (albertomilone) wrote :

One minor correction:

sudo apt-get --purge remove <your packages here>

tags: added: bot-stop-nagging
removed: trusty verification-failed
Mathew Hodson (mhodson) wrote :

You needed to add the tag "bot-stop-nagging" to bug 1518242 (not this bug).

tags: removed: bot-stop-nagging

tried the purge fglrx via alberto and kai's instructions but got this error

"There was a problem initializing Catalyst Control Center Linux edition. It could be caused by the following.

No AMD graphics driver is installed, or the AMD driver is not functioning properly.
Please install the AMD driver appropriate for you AMD hardware, or configure using aticonfig."

not sure what to do...

checked in updates and it says i do have the proprietory amd driver... gonna restart and see if that sorts the madness lol.

looks like purge flgrx reinstall did the trick. screen finally looks and behaves normally. HAPPY DANCES

however sound is still completely gone. that's what sent me in the first place to try the open source driver that crashed everything .. did search through ask ubuntu and found people with different machines all having similar problems with system wide sound issue and no solutions so far. my sound works fine in my windows partition so it's not a hardware thing. is sound a fglrx thing? is this yet a different bug?

thanks everyone for your help and all the ubuntu gods for software creation and sorting bugs and such.

Kai-Heng Feng (kaihengfeng) wrote :

Hi serenity,

Seems like you are using HDMI, so that's an HDMI audio output issue.

Did you have HDMI audio when using open source driver?

hi kai,

um, no clue if i am using hdmi...i dont' think i am... you mean like the cord? ya my geekingness is showing lol.

force reloaded alsa in terminal after a few different pages suggested it, sound came back for 15 mins then vanished again. did a remove and reinstall like was suggested for my flgrx problem and sound seems back for now.

BUT i messed up when i did updates before that (they suggested apt-get updates) and still had trusty proposed selected in updater and i'm now missing things in the gui that i dont' know how to get back, like most icons in the settings panel, and the speaker icon on the top bar. ugh. google offered no suggestions on how to get back to the not trusty proposed unbuntu i had...

toyed with upgrading to 15, but then that's not a stable version and i think i'm not tech savvy enough for that.

i wish 14 would stop hating on me already lol (headdesk)

Kai-Heng Feng (kaihengfeng) wrote :

Hi serenity,

So it's a different issue.

I think you should file a new bug for the HDMI issue, though I think no one but AMD has the capability to solve the issue.

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of fglrx-installer from trusty-proposed was performed and bug 1520286 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and add the tag "bot-stop-nagging" to bug 1520286 (not this bug). Thanks!

tags: added: verification-failed
tags: added: bot-stop-nagging
removed: verification-failed
tags: added: verification-failed
Mathew Hodson (mhodson) wrote :

You need to add the tag "bot-stop-nagging" to bug 1520286 (not this bug).

tags: removed: bot-stop-nagging verification-failed
Mathew Hodson (mhodson) on 2015-11-28
tags: added: trusty

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of fglrx-installer-updates from trusty-proposed was performed and bug 1539865 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and add the tag "bot-stop-nagging" to bug 1539865 (not this bug). Thanks!

tags: added: verification-failed
Alberto Milone (albertomilone) wrote :

Verification didn't fail in LP: #1539865

It seems to me that the error came from 2:15.200-0ubuntu0.5 but was reported as coming from 2:15.200-0ubuntu0.6, since it was (probably) all part of the same upgrade:

2016-01-30 18:25:56 configure fglrx-updates:amd64 2:15.200-0ubuntu0.5 <none>
2016-01-30 18:25:56 status half-configured fglrx-updates:amd64 2:15.200-0ubuntu0.5
...
2016-01-30 18:35:24 upgrade fglrx-updates-core:amd64 2:15.200-0ubuntu0.5 2:15.200-0ubuntu0.6

Now, if we finally approved the update, we would stop having all these duplicates and false positives.

tags: removed: verification-failed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer - 2:15.200-0ubuntu0.6

---------------
fglrx-installer (2:15.200-0ubuntu0.6) trusty-proposed; urgency=medium

  * debian/fglrx.preinst.in:
    - Remove /etc/ati in the migration from the non -core packages
      even when the directory is not a symlink (LP: #1511301).
      Thanks to Kai-Heng Feng for the patch.

 -- Alberto Milone <email address hidden> Mon, 09 Nov 2015 13:17:02 +0100

Changed in fglrx-installer (Ubuntu Trusty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer-updates - 2:15.200-0ubuntu0.6

---------------
fglrx-installer-updates (2:15.200-0ubuntu0.6) trusty-proposed; urgency=medium

  * debian/fglrx.preinst.in:
    - Remove /etc/ati in the migration from the non -core packages
      even when the directory is not a symlink (LP: #1511301).
      Thanks to Kai-Heng Feng for the patch.

 -- Alberto Milone <email address hidden> Mon, 09 Nov 2015 13:22:58 +0100

Changed in fglrx-installer-updates (Ubuntu Trusty):
status: Fix Committed → Fix Released
Alberto Milone (albertomilone) wrote :

Reopening, as the problem can still be reproduced.

description: updated
Changed in fglrx-installer (Ubuntu Trusty):
status: Fix Released → In Progress
Changed in fglrx-installer-updates (Ubuntu Trusty):
status: Fix Released → In Progress
assignee: nobody → Alberto Milone (albertomilone)

Hello Kai-Heng, or anyone else affected,

Accepted fglrx-installer into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/fglrx-installer/2:15.201-0ubuntu0.14.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in fglrx-installer (Ubuntu Trusty):
status: In Progress → Fix Committed
Changed in fglrx-installer-updates (Ubuntu Trusty):
status: In Progress → Fix Committed
Timo Aaltonen (tjaalton) wrote :

Hello Kai-Heng, or anyone else affected,

Accepted fglrx-installer-updates into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/fglrx-installer-updates/2:15.201-0ubuntu0.14.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Jamie Chang (jamie315) wrote :

Failed to upgrade fglrx to 2:15.201-0ubuntu0.14.04.2
Please check full log as attached.

dependency problems:
update-initramfs: deferring update (trigger activated)
dpkg: dependency problems prevent configuration of fglrx:
 fglrx depends on xorg-video-abi-11 | xorg-video-abi-12 | xorg-video-abi-13 | xorg-video-abi-14 | xorg-video-abi-15 | xorg-video-abi-18 | xorg-video-abi-19; however:
  Package xorg-video-abi-11 is not installed.
  Package xorg-video-abi-12 is not installed.
  Package xorg-video-abi-13 is not installed.
  Package xorg-video-abi-14 is not installed.
  Package xorg-video-abi-15 is not installed.
  Package xserver-xorg-core which provides xorg-video-abi-15 is not configured yet.^M
  Package xorg-video-abi-18 is not installed.
  Package xorg-video-abi-19 is not installed.
 fglrx depends on xserver-xorg-core; however:
  Package xserver-xorg-core is not configured yet.

-----------------------------
Selective upgrading from -proposed
$ cat /etc/apt/preferences.d/proposed-updates
Package: *
Pin: release a=trusty-proposed
Pin-Priority: 400

Package: fglrx
Pin: release a=trusty-proposed
Pin-Priority: 900

Package: fglrx-core
Pin: release a=trusty-proposed
Pin-Priority: 900

Package: fglrx-amdcccle
Pin: release a=trusty-proposed
Pin-Priority: 900

Error message:
Setting up libgl1-mesa-glx:amd64 (10.1.3-0ubuntu0.6) ...^M
update-alternatives: warning: forcing reinstallation of alternative /usr/lib/fglrx/ld.so.conf because link group x86_64-linux-gnu_gl_conf is broken^M
...
update-alternatives: error: unable to remove '/etc/ati': Is a directory^M
dpkg: error processing package libgl1-mesa-glx:amd64 (--configure):^M
 subprocess installed post-installation script returned error exit status 2^M

tags: added: verification-failed
removed: verification-needed

Thanks for the prompt reply, Jamie!!  I have been a Windows user since version 1 they reply you sent me might as well be in Urdu, unfortunately.  Besides I am a total beginner here.  Is there something in the contents that I should do, or will the Canonical people eventually write some code in order to overcome this ¨fault¨ ?  Sorry if I appear helpless.........but I am when it comes to Ubuntu, that is why I am trying to give Windows away for ever!!
Keep well, Nicolas Sampson.

    On Friday, 24 February 2017, 19:05, Jamie Chang <email address hidden> wrote:

 Failed to upgrade fglrx to 2:15.201-0ubuntu0.14.04.2
Please check full log as attached.

dependency problems:
update-initramfs: deferring update (trigger activated)
dpkg: dependency problems prevent configuration of fglrx:
 fglrx depends on xorg-video-abi-11 | xorg-video-abi-12 | xorg-video-abi-13 | xorg-video-abi-14 | xorg-video-abi-15 | xorg-video-abi-18 | xorg-video-abi-19; however:
  Package xorg-video-abi-11 is not installed.
  Package xorg-video-abi-12 is not installed.
  Package xorg-video-abi-13 is not installed.
  Package xorg-video-abi-14 is not installed.
  Package xorg-video-abi-15 is not installed.
  Package xserver-xorg-core which provides xorg-video-abi-15 is not configured yet.^M
  Package xorg-video-abi-18 is not installed.
  Package xorg-video-abi-19 is not installed.
 fglrx depends on xserver-xorg-core; however:
  Package xserver-xorg-core is not configured yet.

-----------------------------
Selective upgrading from -proposed
$ cat /etc/apt/preferences.d/proposed-updates
Package: *
Pin: release a=trusty-proposed
Pin-Priority: 400

Package: fglrx
Pin: release a=trusty-proposed
Pin-Priority: 900

Package: fglrx-core
Pin: release a=trusty-proposed
Pin-Priority: 900

Package: fglrx-amdcccle
Pin: release a=trusty-proposed
Pin-Priority: 900

Error message:
Setting up libgl1-mesa-glx:amd64 (10.1.3-0ubuntu0.6) ...^M
update-alternatives: warning: forcing reinstallation of alternative /usr/lib/fglrx/ld.so.conf because link group x86_64-linux-gnu_gl_conf is broken^M
...
update-alternatives: error: unable to remove '/etc/ati': Is a directory^M
dpkg: error processing package libgl1-mesa-glx:amd64 (--configure):^M
 subprocess installed post-installation script returned error exit status 2^M

** Attachment added: "log_0222-1.tar"
  https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/1511301/+attachment/4825756/+files/log_0222-1.tar

** Tags removed: verification-needed
** Tags added: verification-failed

--
You received this bug notification because you are subscribed to a
duplicate bug report (1539865).
https://bugs.launchpad.net/bugs/1511301

Title:
  Failed to upgrade fglrx from 14.502 to 15.200 on Trusty.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/1511301/+subscriptions

Greetings!  Thank you for the prompt reply and request to run some code for testing.  I am a total beginner and am trying to get away from Windows, so I really don´t know what to do in Ubuntu.  Is there  a way to access a blow-by-blow instruction as to what and how I should do?
Keep well, Nicolas Sampson.

    On Wednesday, 22 February 2017, 20:01, Timo Aaltonen <email address hidden> wrote:

 Hello Kai-Heng, or anyone else affected,

Accepted fglrx-installer-updates into trusty-proposed. The package will
build now and be available at https://launchpad.net/ubuntu/+source
/fglrx-installer-updates/2:15.201-0ubuntu0.14.04.2 in a few hours, and
then in the -proposed repository.

Please help us by testing this new package.  See
https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to
enable and use -proposed.  Your feedback will aid us getting this update
out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug,
mentioning the version of the package you tested, and change the tag
from verification-needed to verification-done. If it does not fix the
bug for you, please add a comment stating that, and change the tag to
verification-failed.  In either case, details of your testing will help
us make a better decision.

Further information regarding the verification process can be found at
https://wiki.ubuntu.com/QATeam/PerformingSRUVerification .  Thank you in
advance!

--
You received this bug notification because you are subscribed to a
duplicate bug report (1539865).
https://bugs.launchpad.net/bugs/1511301

Title:
  Failed to upgrade fglrx from 14.502 to 15.200 on Trusty.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/1511301/+subscriptions

Hello Kai-Heng, or anyone else affected,

Accepted fglrx-installer into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/fglrx-installer/2:15.201-0ubuntu0.14.04.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-failed
tags: added: verification-needed
Timo Aaltonen (tjaalton) wrote :

Hello Kai-Heng, or anyone else affected,

Accepted fglrx-installer-updates into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/fglrx-installer-updates/2:15.201-0ubuntu0.14.04.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

candicehuang (candice) wrote :

We have verified this issue by using trusty-proposed way.
But it also pops up two options for choose, then we choose "Replace" button, it stucked again...

Unit: Gladiator 2
Image: stella-datong140729-trusty-amd64-20141230-1
Original Kernel version is 3.13.0-34-generic

Please refer attached picture for your reference, thanks.

candicehuang (candice) on 2017-03-06
tags: added: verification-failed
removed: verification-needed
tags: added: verification-needed
removed: verification-failed
Alberto Milone (albertomilone) wrote :

That is not a failure. It is the expected behaviour from dpkg and from apt. Users gets to either keep their own settings or to replace them with the default ones from the new fglrx-core package (as the conf files were previously provided by fglrx).

If you want to skip the question, and keep the old files, you can try upgrading using the following command:

export DEBIAN_FRONTEND=noninteractive ; apt-get dist-upgrade -y -o Dpkg::Options::="--force-confdef" -o Dpkg::Options::="--force-confold" --force-yes

candicehuang (candice) wrote :

We have followed #45 comment to verify this bug, it can upgrade successfully with kernel from 3.13.0-34 to 3.13.0-111, thanks.

candicehuang (candice) wrote :

And, we see the status installed fglrx:amd64 2:15.201-0ubuntu0.14.04.3, new fglrx driver is installed, thanks.

Kristin Chuang (hyac109) wrote :

Note that software update results in comment #46 & #47 are done via the command line (in other words, they are the result of the suggestion in comment #45.)

When a user simply updates via GUI software updater, he/she will still meet the hang issue mentioned in comment #44.

Timo Aaltonen (tjaalton) wrote :

Hello Kai-Heng, or anyone else affected,

Accepted fglrx-installer into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/fglrx-installer/2:15.201.1-0ubuntu0.14.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Timo Aaltonen (tjaalton) wrote :

Hello Kai-Heng, or anyone else affected,

Accepted fglrx-installer-updates into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/fglrx-installer-updates/2:15.201.1-0ubuntu0.14.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

candicehuang (candice) wrote :

I have verified this issue on new fix,
it also pops up two options for choose, after click "Keep" or "Replace" button, it stucked again...

Unit: Gladiator 2
Image: stella-datong140729-trusty-amd64-20141230-1
Original Kernel version is 3.13.0-34-generic

Please refer attached picture for your reference, thanks.

Alberto Milone (albertomilone) wrote :

I have used exactly the same files from the fglrx release in 14.04.0, and I can't reproduce the problem here.

What version of fglrx did you have installed before testing the package in -proposed?

ethan.hsieh (ethan.hsieh) wrote :

@Alberto
fglrx 2:14.101-0ubuntu1

Alberto Milone (albertomilone) wrote :

that is not the same version that is available in 14.04.0

Alberto Milone (albertomilone) wrote :

Does fglrx from the following PPA solve the problem?
https://launchpad.net/~albertomilone/+archive/ubuntu/1511301

candicehuang (candice) wrote :

I have followed #55 comment to verify this bug, it can update successfully.

Unit: Gladiator 2
Image: stella-datong140729-trusty-amd64-20141230-1
Original Kernel version: 3.13.0-34-generic

New Kernel version: 3.13.0-112-generic
New fglrx installed: 2:15.201.1-0ubuntu0.14.04.2~ppa

Timo Aaltonen (tjaalton) wrote :

Hello Kai-Heng, or anyone else affected,

Accepted fglrx-installer into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/fglrx-installer/2:15.201.2-0ubuntu0.14.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Timo Aaltonen (tjaalton) wrote :

Hello Kai-Heng, or anyone else affected,

Accepted fglrx-installer-updates into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/fglrx-installer-updates/2:15.201.2-0ubuntu0.14.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

candicehuang (candice) wrote :

I have followed #58 comment to verify this bug, it can update successfully.

Unit: Gladiator 2
Image: stella-datong140729-trusty-amd64-20141230-1
Original Kernel version: 3.13.0-34-generic

New Kernel version: 3.13.0-113-generic
New fglrx installed: 2:15.201.2-0ubuntu0.14.04.1

candicehuang (candice) on 2017-03-16
tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for fglrx-installer has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer-updates - 2:15.201.2-0ubuntu0.14.04.1

---------------
fglrx-installer-updates (2:15.201.2-0ubuntu0.14.04.1) trusty-proposed; urgency=medium

  * Avoid triggering any prompts for /etc (LP: #1511301).
  * Revert the previous change to etc/ati in the sources.

fglrx-installer-updates (2:15.201.1-0ubuntu0.14.04.1) trusty-proposed; urgency=medium

  * Bump the release replacing etc/ati so that we don't trigger a bug in
    software updater (LP: #1511301).

fglrx-installer-updates (2:15.201-0ubuntu0.14.04.3) trusty-proposed; urgency=medium

  * debian/control.in,
    debian/fglrx-core.postinst.in,
    debian/fglrx.preinst.in,
    debian/fglrx.postinst.in,
    debian/fglrx.dirs.in,
    debian/rules:
    - Make sure that fglrx pre-depends on fglrx-core.
    - Back up and restore the files that the old fglrx
      removes when upgrading (LP: #1511301).

fglrx-installer-updates (2:15.201-0ubuntu0.14.04.2) trusty-proposed; urgency=medium

  * debian/fglrx-updates.{pre|post}inst.in:
    - Make sure to also migrate the real ati configuration dir, not
      only the symlinks, or the upgrade will fail (LP: #1511301).

 -- Alberto Milone <email address hidden> Wed, 15 Mar 2017 12:48:50 +0100

Changed in fglrx-installer-updates (Ubuntu Trusty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer - 2:15.201.2-0ubuntu0.14.04.1

---------------
fglrx-installer (2:15.201.2-0ubuntu0.14.04.1) trusty-proposed; urgency=medium

  * Avoid triggering any prompts for /etc (LP: #1511301).
  * Revert the previous change to etc/ati in the sources.

fglrx-installer (2:15.201.1-0ubuntu0.14.04.1) trusty-proposed; urgency=medium

  * Bump the release replacing etc/ati so that we don't trigger a bug in
    software updater (LP: #1511301).

fglrx-installer (2:15.201-0ubuntu0.14.04.3) trusty-proposed; urgency=medium

  * debian/control.in,
    debian/fglrx-core.postinst.in,
    debian/fglrx.preinst.in,
    debian/fglrx.postinst.in,
    debian/fglrx.dirs.in,
    debian/rules:
    - Make sure that fglrx pre-depends on fglrx-core.
    - Back up and restore the files that the old fglrx
      removes when upgrading (LP: #1511301).

fglrx-installer (2:15.201-0ubuntu0.14.04.2) trusty-proposed; urgency=medium

  * debian/fglrx.{pre|post}inst.in:
    - Make sure to also migrate the real ati configuration dir, not
      only the symlinks, or the upgrade will fail (LP: #1511301).

 -- Alberto Milone <email address hidden> Tue, 14 Mar 2017 11:38:19 +0100

Changed in fglrx-installer (Ubuntu Trusty):
status: Fix Committed → Fix Released
Changed in fglrx-installer (Ubuntu):
assignee: Alberto Milone (albertomilone) → Florin Neacsu (florinelll)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers