Xorg crashed with SIGABRT in OsAbort()

Bug #1499596 reported by Biji on 2015-09-25
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned

Bug Description

Testing Ubuntu gnome 15.10 beta2:
after installing Additional Drivers for AMD GPU,
booting show kernel panic, but can still login to X, some apps like gnome-terminal wont run

ProblemType: Crash
DistroRelease: Ubuntu 15.10
Package: xserver-xorg-core 2:1.17.2-1ubuntu7
ProcVersionSignature: Ubuntu 4.2.0-10.12-generic 4.2.0
Uname: Linux 4.2.0-10-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.18.1-0ubuntu1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
CurrentDesktop: GNOME
Date: Fri Sep 25 11:08:01 2015
DistUpgraded: Fresh install
DistroCodename: wily
DistroVariant: ubuntu
DkmsStatus: fglrx-updates-core, 15.201, 4.2.0-10-generic, x86_64: installed
ExecutablePath: /usr/bin/Xorg
GraphicsCard:
 Intel Corporation Broadwell-U Integrated Graphics [8086:1616] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:5021]
   Subsystem: Lenovo Device [17aa:5021]
InstallationDate: Installed on 2015-09-24 (0 days ago)
InstallationMedia: Ubuntu-GNOME 15.10 "Wily Werewolf" - Alpha amd64 (20150922.1)
MachineType: LENOVO 20DCA02WIA
ProcCmdline: /usr/bin/X vt2 -displayfd 3 -auth /run/user/1000/gdm/Xauthority -nolisten tcp -background none -noreset -keeptty -verbose 3
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-10-generic.efi.signed root=/dev/mapper/Onyx-UbuntuBeta ro intremap=no_x2apic_optout quiet splash vt.handoff=7
Signal: 6
SourcePackage: fglrx-installer
StacktraceTop:
 OsAbort ()
 FatalError ()
 ?? ()
 xf86CloseConsole ()
 ddxGiveUp ()
Title: Xorg crashed with SIGABRT in OsAbort()
UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 07/15/2015
dmi.bios.vendor: LENOVO
dmi.bios.version: J5ET46WW (1.17 )
dmi.board.asset.tag: Not Available
dmi.board.name: 20DCA02WIA
dmi.board.vendor: LENOVO
dmi.board.version: Not Defined
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: None
dmi.modalias: dmi:bvnLENOVO:bvrJ5ET46WW(1.17):bd07/15/2015:svnLENOVO:pn20DCA02WIA:pvrThinkPadE450:rvnLENOVO:rn20DCA02WIA:rvrNotDefined:cvnLENOVO:ct10:cvrNone:
dmi.product.name: 20DCA02WIA
dmi.product.version: ThinkPad E450
dmi.sys.vendor: LENOVO
version.compiz: compiz N/A
version.fglrx-installer: fglrx-installer N/A
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.64-1
version.libgl1-mesa-dri: libgl1-mesa-dri 11.0.0-1ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.0.0-1ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.17.2-1ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.2-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.5.0+git20150819-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20150808-0ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu3
xserver.bootTime: Fri Sep 25 11:09:34 2015
xserver.configfile: default
xserver.errors: open /dev/dri/card0: No such file or directory
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 1530
 vendor BOE
xserver.version: 2:1.17.2-1ubuntu7

Biji (biji) wrote :

Thank you for taking the time to report this crash and helping to make this software better. This particular crash has already been reported and is a duplicate of bug #1237904, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

information type: Private → Public
tags: removed: need-amd64-retrace
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers