FGLRX incompatible with gcc 5

Bug #1493888 reported by Allen Webb on 2015-09-09
This bug affects 209 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Alberto Milone
fglrx-installer (Ubuntu)
High
Alberto Milone
Wily
High
Alberto Milone
fglrx-installer-updates (Ubuntu)
High
Alberto Milone
Wily
High
Alberto Milone

Bug Description

SRU Request:

[Impact]

The fglrx driver is not compatible with gcc 5.x. This causes the kernel module to crash on initialisation. As a result, users will boot into a black screen, as X will fail (except on Intel+AMD hybrid systems, where intel is used).

[Test Case]
1. Either install (or upgrade to) Ubuntu 15.10 and fglrx
2. Reboot
3. Check the display, and the output of the "dmesg | grep fglrx" command (to see the actual crash)

Expected results: the system should be able to start X correctly.

Actual results:
The kernel module fails and X doesn't start.

[Regression Potential]
Low. Forcing fglrx to use gcc 4.9 is only a temporary workaround, and will be replaced with the proper fix once AMD makes it available.

__________________________________________________________________________

With a R9 280 and FGLRX on ubuntu 15.10 the graphics lock up. I am able to SSH into the machine. I booted the older kernel (4.1.0-3-generic) and it works with FGLRX. After purging FGLRX and using xserver-xorg-video-radeon I am able to get the graphics working, but even it has issues with my display port (The DVI ports are working correctly).

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: fglrx (not installed)
ProcVersionSignature: Ubuntu 4.2.0-7.7-generic 4.2.0
Uname: Linux 4.2.0-7-generic x86_64
ApportVersion: 2.18-0ubuntu9
Architecture: amd64
Date: Wed Sep 9 09:29:54 2015
EcryptfsInUse: Yes
InstallationDate: Installed on 2011-01-07 (1705 days ago)
InstallationMedia: Kubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcEnviron:
 LANGUAGE=
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: fglrx-installer
UpgradeStatus: Upgraded to wily on 2015-08-18 (21 days ago)

Allen Webb (vertago1-s) wrote :
Allen Webb (vertago1-s) wrote :

It looks like this has been reported upstream: http://ati.cchtml.com/show_bug.cgi?id=1189

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fglrx-installer (Ubuntu):
status: New → Confirmed
Sascha Biermanns (skbierm) wrote :

Same with the AMD Radeon 6600M and 6700M Series, even with the newest 4.2-10 version.

Sascha Biermanns (skbierm) wrote :

Workaround at the moment: Still booting up with the 4.1.0-3 kernel version.

Guy Baconniere (lordbaco) wrote :

Same problem on iMac15,1 with Radeon R9 M295X Mac Edition
and 4.2.0-7-generic (wily / 15.10)

Two partial workarounds:

- downgrade to 4.1.0-3-generic and install fglrx-updates
  but bluetooth will not work --broken with this kernel*
  http://www.spinics.net/lists/linux-bluetooth/msg64098.html

- use 4.2.0-7-generic but remove fglrx-updates (fglrx-amdcccle etc.)
  bluetooth will work but no radeon hardware acceleration (No Steam, etc.)

In my case I need to choose between bluetooth devies and 3d graphics (radeaon)

Changed in fglrx-installer (Ubuntu):
importance: Undecided → High
mark (markrmiller) wrote :

I don't have the older kernel available as a workaround and doesn't seem so easy to rollback otherwise. This going to be fixed before the release?

mark (markrmiller) wrote :

I got it working. Grabbed the 3 deb files I needed for 4.1 from http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.1-unstable/.

M Oberhauser (zomtir) wrote :

fglrx falls back to xserver-xorg-video-ati when fglrx is installed, because the fglrx module can't be loaded on boot. If you force booting with fglrx by removing the x-org mesa packages, it freezes on boot.

My card is a Radeon R270X ITX on Ubuntu 15.10.

Confirmed not working on Ubuntu 15.10 64bit with my AMD R9 390 on kernel 4.2.0-16.

Both fglrx and fglrx-updates will return a black screen of death upon reboot after installation. The only way to revive the system is to do a fresh install.

This will cause many people to break their systems when they choose to upgrade their systems to 15.10 with an AMD card and attempt to install Catalyst.

I'm going to try the Kernel 4.1 workaround now, see if it works or not.

Just tried using Kernel 4.1.0-040100 and then attempted to install both fglrx and fglrx-updates. Both installed, and upon reboot there is a working desktop, but it's not the Catalyst driver that's running.

It's defaulting back to stock Mesa 11.0.2, even though Additional Drivers states that the fglrx driver is in use.

I do not know if this would be useful, but this is my dmesg file currently:
http://paste.ubuntu.com/12795659/

Since this will just give black screen after upgrade on affected systems I think this issue need to be highlighted in release notes, so people who could be affected by this bug switch to open driver or postpone upgrade to Wily until AMD release new fglrx.

Changed in fglrx-installer (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Paolo Rotolo (paolorotolo) wrote :

Hey guys,
any ETA on this?

I'm on Ubuntu 15.10 since August and I can only use open source drivers with my AMD GPU.
Let me know if you need additional info.

Zeioth (zeioth) wrote :

I've fixed it downgrading the kernel as described in phoronix. Using "sudo apt-get purge linux-image-yourversionhere" and sudo "apt-get purge fglrx", then reinstalling the drivers again with "apt-get install fglrx" and "aticonfig --initial".

Zeioth (zeioth) wrote :

By the way I tried kernel 4.1 and I had problems entering to recovery mode > resume. Just stick with 3.19 meanwhile.

Changed in ubuntu-release-notes:
status: New → Confirmed
Alberto Milone (albertomilone) wrote :

@Paolo: not yet. We are going to fix this ASAP.

I have added an entry in the release notes for now.

Sorry for the inconvenience.

Changed in ubuntu-release-notes:
assignee: nobody → Alberto Milone (albertomilone)
status: Confirmed → Fix Released
xpris (xpris) wrote :

Very strange. I use Ubuntu 15.04 and I install kernel 4.2.0 from ubuntu ppa kernel team and use kolasa patch https://github.com/kolasa/fglrx-core-15.201
and kernel and fglrx driver works fine.

Also in my second system I use Mageia 6 Cauldron (unstable) and have (from system repo) kernel 4.2 and new fglrx and works fine.
So why this fix can be backported to Ubuntu 15.10?

Serge (sspapilin) wrote :

I have AMD A4 APU. Boot freezes at splash screen with Ubuntu logo.

The open source drivers lead to black screen, just like it was in 15.04 and may be even earlier. So it's an illusion that the open source drivers are viable workaround for everyone.

Daniel Svetlik (dsvetlik) wrote :

I have a PITCAIRN PRO 7850 and boot freezes at splash screen. Could not access other ttys. Got in with laptop that upgraded fine with ssh and was able to get default monitor and display settings only, but cannot succesfully get open source drivers or fglrx working fully.

This affects me and my card as well. I have an ATI R9 200x and cannot use fglrx with kernel 4.2.

Đorđe (djole94hns) wrote :

MSI Radeon R9 270 here, not working on kernel 4.2

Any news on the fix?

On 22-10-15 17:44:52, xpris wrote:
> Very strange. I use Ubuntu 15.04 and I install kernel 4.2.0 from ubuntu ppa kernel team and use kolasa patch https://github.com/kolasa/fglrx-core-15.201
> and kernel and fglrx driver works fine.

Maybe there is something that we are missing in our patches (Kolasa
seems to have included some of our patches). It's hard to tell from the
build log. I'll look into this.

Kolasa patches from GitHub don't work anymore on Ubuntu 15.10: https://github.com/kolasa/fglrx-core-15.201/issues/2

Is there a PPA to test latest patched drivers on Wily?

prashantm (prashant-mirjankar) wrote :

Affects me too on Amd A4-5000 freezes at splash screen

Luca Ciavatta (cialu) wrote :

Same here, on a Radeon HD5450.

xpris (xpris) wrote :

So, look like some is wrong in Ubuntu 15.10, because in Ubuntu 15.04 kolasa patch working fine with kernel 4.2.0.

I try now install new fglrx and kernel 4.2 on Mageia 5 (stable but kernel from Cauldron) and kolasa patch don't want work. I must use this command before installation:
sudo cp /usr/include/linux/version.h /lib/modules/`uname -r`/build/include/linux/
Now installation is complete and all good.

So, Ubuntu 15.04 works with kolasa patch, Mageia 6 Cauldron works with driver from repository and Mageia 5 work if we use kolasa patch + one command line.

This command is from Fedora, see here: https://bluehatrecord.wordpress.com/2015/09/17/installing-the-proprietary-amd-catalyst-15-9-fglrx-15-201-driver-on-fedora-22-with-linux-kernel-4-1-6/

EricDHH (ericdhh) wrote :

Radeon r9-270, only console since upgrade

[ 9.106329] [<ffffffff817ef9f2>] ? entry_SYSCALL_64_fastpath+0x16/0x75
[ 9.106331] Code: df 00 00 00 48 89 54 24 08 89 4c 24 04 ff e6 0f 29 7b f1 0f 29 73 e1 0f 29 6b d1 0f 29 63 c1 0f 29 5b b1 0f 29 53 a1 0f 29 4b 91 <0f> 29 43 81 e8 76 96 fc ff 48 89 c7 e8 5e ae fd ff 44 89 e1 c1
[ 9.106357] RIP [<ffffffffc025d251>] firegl_trace+0x61/0x1e0 [fglrx]
[ 9.106415] RSP <ffff8800cd1a3a78>
[ 9.106438] ---[ end trace eae68d146e85ec62 ]---

Serge (sspapilin) wrote :

One of duplicate bugs contains a patch forcing compilation with gcc 4.9:
https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/1501276/comments/3
The patch is confirmed to be working in a further comment.

Vertago1 (vertago1) wrote :

The patch in #29 worked for me.

Dimitrij Krasovsky (kdi) wrote :

Affects me on AMD A10-7870K.

Temporary using the open source driver, which works, but causes me to halt all OpenGL development and gaming (Steam).

dualboot (guycarre) wrote :

Hello

 Same issue with Wily embedded kernel 4.2 and AMD graphic card 7850.
My solution was to uninstall kernel 4.2.

 Hope a solution will be found soon.

Regards,

Josef Andersson (northar) wrote :

Same here of course. Thanks to all involved in reporting, and fixing--- Rant:How is it possible that 15.10 goes to release with a bug like this, affecting so many users (yes, the ubuntu releases should be tested on nvidia and amd moderna cards before release). Yes, I do love Ubuntu, and Yes I know it should be AMD releasing their source and specs, but still -- shouldnẗ this be a release blocker.

Ian (superian) wrote :

Yes - in the nicest possible way, HTF was this allowed to survive unfixed at release and WTF isn't this documented in the release notes for the Ubuntu-MATE flavour for one?

Just how bad does a bug have to be to block a release?

L-Train (so1dieroffortune) wrote :

It's puzzling that Ubuntu continues to release software that make the PC unusable for A LARGE subset of users. Several months ago, while using Ubuntu 15.04, a new kernel version was released that made it impossible to log in and it affected every single user with AMD video card that used binary drivers. And now this bug again appears to affect every single user with an AMD card/ binary drivers combo. I remember hearing Shuttleworth describing Cannonical testing environment and how everything is automated and how they put a lot of effort to perfect it, blah blah blah. But how can this be when Ubuntu routinely releases software that deterministically renders computer 100% unusable for everyone with an AMD video card? It just doesn't make any sense. How are these kinds of bugs not release show stoppers?

Aizuddin Zali (aizuddin-linux) wrote :

my application wont display correctly with radeon driver due to needs of fglrx API. Hope this can be fixed soon.

R270X

none of my installed kernels worked:

4.2.0-16
3.19.0-31
3.16.0-34

purge fglrx has resolved issue for now

@northar: The general view seems to be that open source drivers must work, but not necessarily the closed source, except for LTS releases.

Personally I think the closed-source graphics card drivers are important enough that they should be fixed before release; it seems that every second release has problems for me.

On the positive side, the open source graphics stacks are catching up, and both AMD/NVidia seem to be paying more attention to their drivers, so perhaps these problems will diminish over time.

Richard Ayotte (rich-ayotte) wrote :

@so1dieroffortune Blame AMD, it's their closed source drivers that don't work. AMD does not support kernels greater than 3.19 as shown in their 15.9 release notes here http://support.amd.com/en-us/download/desktop?os=Linux+x86. The 4.0 kernel was released on April 12th, 2015 which is plenty of time for AMD to update their drivers. There's not way that AMD needs more than 6 months to make their drivers compatible with the 4.0 kernels. In fact, I would estimate that one of their engineers could make the compatibility fixes in less than week.

Sergey Kislyakov (defman21) wrote :

Compiling the fglrx-installer with gcc 4.9 fixed this problem, but it's a workaround and not the fix. (I guess).
You can get the patch here: https://launchpadlibrarian.net/219738583/fglrx-installer-15.201_force-gcc_4.9.patch
Don't forget to freeze the fglrx-* packages after installing the fixed debs or Ubuntu could update your drivers and replace them with the broken drivers.

Changed in fglrx-installer (Ubuntu):
status: Confirmed → In Progress
Changed in fglrx-installer (Ubuntu Wily):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Alberto Milone (albertomilone)
summary: - FGLRX incompatible with kernel 4.2
+ FGLRX incompatible with gcc 5
Changed in fglrx-installer (Ubuntu):
status: In Progress → Fix Released
description: updated
Timo Aaltonen (tjaalton) on 2015-10-27
Changed in fglrx-installer (Ubuntu Wily):
status: In Progress → Fix Committed
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Changed in fglrx-installer (Ubuntu Wily):
status: Fix Committed → Fix Released
Changed in fglrx-installer (Ubuntu Wily):
status: Fix Released → In Progress
status: In Progress → Fix Committed
Timo Aaltonen (tjaalton) on 2015-10-28
tags: removed: verification-done
tags: added: verification-needed
Allen Webb (vertago1-s) on 2015-10-28
tags: added: verification-done
removed: verification-needed
Changed in fglrx-installer (Ubuntu Wily):
status: Fix Committed → Fix Released
assignee: Alberto Milone (albertomilone) → Gaurav Sharma (gauravsati19)
Changed in fglrx-installer (Ubuntu Wily):
assignee: Gaurav Sharma (gauravsati19) → nobody
Changed in fglrx-installer-updates (Ubuntu):
status: New → Fix Released
Changed in fglrx-installer-updates (Ubuntu Wily):
status: New → Fix Committed
importance: Undecided → High
Changed in fglrx-installer-updates (Ubuntu):
importance: Undecided → High
Changed in fglrx-installer (Ubuntu Wily):
status: Fix Released → Fix Committed
Changed in fglrx-installer (Ubuntu Wily):
assignee: nobody → Alberto Milone (albertomilone)
Changed in fglrx-installer-updates (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in fglrx-installer-updates (Ubuntu Wily):
assignee: nobody → Alberto Milone (albertomilone)
173 comments hidden view all 253 comments
QIII (qiii) wrote :

AMD's fglrx does not support the HD 4200 in that version of Ubuntu. The last Ubuntu release supported by the AMD proprietary driver was 12.04.1.

Adapters prior to the HD 5000 series are not supported. This bug is not related to your issue.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer-updates - 2:15.201-0ubuntu2~15.10.2

---------------
fglrx-installer-updates (2:15.201-0ubuntu2~15.10.2) wily-proposed; urgency=medium

  * debian/rules:
    - Blacklist the amdgpu driver, so that fglrx can be loaded
      on the systems where the GPU is supported by amdgpu (LP: #1510573).

fglrx-installer-updates (2:15.201-0ubuntu2~15.10.1) wily-proposed; urgency=medium

  * debian/control.in,
    debian/dkms.conf.in,
    dkms/patches/force-gcc-to-4.9-instead-of-5.x.patch:
    - Add a dependency on gcc-4.9, and force fglrx to use gcc-4.9.
      This prevents fglrx from dying on initialisation (LP: #1493888).
      Credit for finding out the actual problem and for suggesting a
      workaround goes to David Burrows.
      Note: this is only a workaround, and it will be dropped as soon
      as a proper fix from upstream is available.

 -- Alberto Milone <email address hidden> Wed, 28 Oct 2015 13:21:21 +0100

Changed in fglrx-installer-updates (Ubuntu Wily):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for fglrx-installer-updates has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer - 2:15.201-0ubuntu2~15.10.2

---------------
fglrx-installer (2:15.201-0ubuntu2~15.10.2) wily-proposed; urgency=medium

  * debian/rules:
    - Blacklist the amdgpu driver, so that fglrx can be loaded
      on the systems where the GPU is supported by amdgpu (LP: #1510573).

fglrx-installer (2:15.201-0ubuntu2~15.10.1) wily-proposed; urgency=medium

  * debian/control.in,
    debian/dkms.conf.in,
    dkms/patches/force-gcc-to-4.9-instead-of-5.x.patch:
    - Add a dependency on gcc-4.9, and force fglrx to use gcc-4.9.
      This prevents fglrx from dying on initialisation (LP: #1493888).
      Credit for finding out the actual problem and for suggesting a
      workaround goes to David Burrows.
      Note: this is only a workaround, and it will be dropped as soon
      as a proper fix from upstream is available.

 -- Alberto Milone <email address hidden> Wed, 28 Oct 2015 13:19:25 +0100

Changed in fglrx-installer (Ubuntu Wily):
status: Fix Committed → Fix Released
affects: fglrx → ubuntu-translations
no longer affects: ubuntu-translations
Matheus (matheus-boni-vicari) wrote :

After the fix release, in order for the drivers to work properly do I still need to blacklist amdgpu or run the 'amdconfig --adapter=all --initial'? Cheers

I'm still have the same problems - after performing apt-get update and upgrade, installing fglrx-updates, fglrx-updates-core, fglrx-amdcccle-updates, lightdm, xorg and ubuntu-desktop, and then running amdconfig, I am greeted by a black screen upon restart (several restarts do not fix the problem). Purging fglrx*, lightdm and xorg return me to a command line interface.

Even if this problem is thus isolated to be separate to the problem in this thread, I am afraid I have hit a brick wall in troubleshooting this - does anyone have any advice on how I can track down the bug (and hopefully the solution!)?

@ SRU-Team comment #216 removed verification needed Nov.18.Nov2015

This package has to be seen in conjunction with bug #1510573 and vice versa

This package here is still in proposed-pocket as per TODAY and does not appear in

http://people.canonical.com/~ubuntu-archive/pending-sru#wily.html

https://launchpad.net/ubuntu/wily/+queue?queue_state=3&queue_text=fglrx

Pls. investigate and report to QC

I've installed fglrx-updates driver and still can't get loaded UI.
So, get back to open drivers.

Iulian (iulian-macare) wrote :

I just installed fglrx-updates ( 2:15.201-0ubuntu2~15.10.2) on Ubuntu 15.10 and Radeon HD 7730M

So, is there any solution?
I've tried to install various versions of drivers and kernels.
Neither fglrx nor fglrx-updates doesn't work with 4.1.x kernel and 4.2.x.

I'm having the same problems. I need the proprietary driver because the open source driver does not implement the computational part. Is there any timeframe for this bug fix?

@ Arnkell (logpip)

Timeline? see -> (https://wiki.ubuntu.com/StableReleaseUpdates) -> 3.6 Procedure

Allen Webb (vertago1-s) wrote :

I have been following another bug related to creating USB boot drives and it seems like they are having issues with gcc 5.0 because of a section alignment issue. I don't know whether or not that would effect compiling the wrapper for fglrx, but I figured I would bring it up incase it is linked to the root cause of the incompatibility with gcc. I know the boot issue with syslinux is different than the boot issue with fglrx, but if there is an issue created by a bug or change in gcc 5 it might give some light on other issues. See: https://bugs.launchpad.net/ubuntu/+source/syslinux/+bug/1507002/comments/6

Mikael Thurberg (mthurberg) wrote :

Just wanted to report that it has been working fine except one thing when I have been using the driver from the proposed..

Think I found a bug there, in amdccle where you can change your settings, I tried to enable so it updates the refreshrate of the screen so it is without tearing.. I tickled that box and I think I also did play around with changing the settings for the bit-depth on 8bit to automatically or vice versa.. then it asked for me to reboot but I did not do that, then I changed if it was the "without tearing" setting again and then the screen just did hang and stopped responding.. it have happend twice but I dont remember exactly how and in what order I did change that, but it was with the enable/disable tearing and bitdepth I changed and did not restart imedeately but did change the settings again somehow back and forth.. then that resultet in a hiccup of the system..

Otherwise the propsed driver have been working fine for me on a older slow computer with an amd hd6450 card.

If I disable the proposed and install the regular amd-updates, is that the same driver as it was in the proposed?

Thanks to you who have been working on this, it has been a pure relief to have been able to get the graphics working for me, thanks!

Allen Webb (vertago1-s) wrote :

@Mikael This probably isn't the right place to report something like that unless it doesn't happen when you use the same driver version without the gcc 5.0 fix. I am not sure where the best place is to report bugs in the proprietary driver it self but a quick google let me to: http://www.amdsurveys.com/se.ashx?s=5A1E27D23A3DE979

For users that still get a blackscreen on startup, try disable the bootsplash screen. That fixed it for me. Boot into recovery, remount your disk to be able to write to it. Remove 'splash' from the command line in /etc/default/grub and do an update-grub. After the next reboot, you should be able to see the login screen with the propertery driver.

Derf Skren (awron) wrote :

So is this actually fixed now? My only way to find out is to risk having to reinstall the whole OS.

Thijs van Dijk (ametheus) wrote :

First of all, yes, this has been fixed in Wily; thanks, everyone!

Secondly, if it still somehow doesn't work for you, you can easily (for some value of "easy") revert by booting into a recovery shell in GRUB and simply executing `apt-get remove fglrx fglrx-updates`. See the wiki page "Recovery Mode" on the ubuntu wiki for more details:
https://wiki.ubuntu.com/RecoveryMode

Derf Skren (awron) wrote :

Thanks Thijs!

Derf Skren (awron) wrote :

Confirmed fixed for my Acer Travelmate 7750G with Radeon HD 6650M

Anybody tried this with an AMD A10 PRO-7350B R6?

2015-12-02 12:21 GMT+01:00 Derf Skren <email address hidden>:

> Confirmed fixed for my Acer Travelmate 7750G with Radeon HD 6650M
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1493888
>
> Title:
> FGLRX incompatible with gcc 5
>
> Status in Release Notes for Ubuntu:
> Fix Released
> Status in fglrx-installer package in Ubuntu:
> Fix Released
> Status in fglrx-installer-updates package in Ubuntu:
> Fix Released
> Status in fglrx-installer source package in Wily:
> Fix Released
> Status in fglrx-installer-updates source package in Wily:
> Fix Released
>
> Bug description:
> SRU Request:
>
> [Impact]
>
> The fglrx driver is not compatible with gcc 5.x. This causes the
> kernel module to crash on initialisation. As a result, users will boot
> into a black screen, as X will fail (except on Intel+AMD hybrid
> systems, where intel is used).
>
> [Test Case]
> 1. Either install (or upgrade to) Ubuntu 15.10 and fglrx
> 2. Reboot
> 3. Check the display, and the output of the "dmesg | grep fglrx" command
> (to see the actual crash)
>
> Expected results: the system should be able to start X correctly.
>
> Actual results:
> The kernel module fails and X doesn't start.
>
> [Regression Potential]
> Low. Forcing fglrx to use gcc 4.9 is only a temporary workaround, and
> will be replaced with the proper fix once AMD makes it available.
>
>
>
> __________________________________________________________________________
>
> With a R9 280 and FGLRX on ubuntu 15.10 the graphics lock up. I am
> able to SSH into the machine. I booted the older kernel
> (4.1.0-3-generic) and it works with FGLRX. After purging FGLRX and
> using xserver-xorg-video-radeon I am able to get the graphics working,
> but even it has issues with my display port (The DVI ports are working
> correctly).
>
> ProblemType: Bug
> DistroRelease: Ubuntu 15.10
> Package: fglrx (not installed)
> ProcVersionSignature: Ubuntu 4.2.0-7.7-generic 4.2.0
> Uname: Linux 4.2.0-7-generic x86_64
> ApportVersion: 2.18-0ubuntu9
> Architecture: amd64
> Date: Wed Sep 9 09:29:54 2015
> EcryptfsInUse: Yes
> InstallationDate: Installed on 2011-01-07 (1705 days ago)
> InstallationMedia: Kubuntu 10.10 "Maverick Meerkat" - Release amd64
> (20101007)
> ProcEnviron:
> LANGUAGE=
> TERM=xterm
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: fglrx-installer
> UpgradeStatus: Upgraded to wily on 2015-08-18 (21 days ago)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu-release-notes/+bug/1493888/+subscriptions
>

Andy Bauer (knnniggett) wrote :

In my case, Ubuntu created a trifecta of video driver show-stoppers, which prevented me from having a stable desktop while using a Radeon R9 380 and dual 1080p monitors. Each of the three drivers: fglrx, radeon, and amdgpu all had unique issues, and yes I'm aware that the issue with fglrx was in the release notes. I'm leaving out further details, because this post is about a solution that worked for me.

1) completely remove fglrx from your system
2) roll back to the 3.19 kernel used in the previous release of Ubuntu. Temporarily add the Vivid repo, add install the 3.19 kernel, boot off the 3.19 kernel, remove all other kernels from your system.
3) Modify the symlink /usr/bin/gcc to point to /usr/bin/gcc-4.9 instead of gcc-5
4) reinstall fglrx then reboot

I did this based on the previous comments in this bug report.

I've been running in this configuration a couple of weeks now with no issues. It's possible these changes could cause problems with something else expecting a newer kernel or gcc-5, but I have yet to experience any issues.

I plan to leave my system in this configuration until the next release of Ubuntu, next April.

mookey41 (redguy41) wrote :

My problem is with hybrid Intel/ATI graphics. WHen I try to use fglrx (installed on additional drivers, or command line) the booting reverts to Intel. ATI does not work.

Ubuntu 15.10. I'm using Lenovo z51-70 with ATI R9 R8900HD and Intel graphics.

Any suggestions?
Cheeers,

Gaj

Matheus (matheus-boni-vicari) wrote :

@mookey41:

I have the same issue. After a few weeks of working fglrx drivers and all, I tried to switch to Intel VGA and then back to AMD and the fglrx drivers are not working anymore.

Stephan (cpjack) wrote :

Where is the fix? To roll back to Kernel 3.19 is not a fix, it is a downgrade of a whole OS!

Fgrlx makes trouble for years now. Even AMD stated that the catalyst suite is only working til 3.19 Kernel Version.

mookey41 (redguy41) wrote :

So if I enable willy proposed repository and do an update, do I just tick the AMD fglrx driver from the Additional Drivers tab, or do I need to install it through the command line? I have tried the former, and it doesn't work.
Using ubuntu 15.10 on a Lenovo AMD/Intel hybrid. AMD R9, HD8900.
The graphics works, but lags.

Thanks.

Oscar Parada (oparada1988) wrote :

Alright you guys, I don't know if im being stupid. Im using the Gnome version of Ubuntu, I select the propose updates, update the syste, install fglrs-updates and I see the gcc 4.9 will be installed... great, installed runs everything good. reboot, see splash screen.... then blank screen. am I doing something wrong? using an A8-6410. thanks

I'm still having the same problem - booting to blank screen unless I purge fglrx*, lightdm and xorg to get to a command line interface. If I only try removing fglrx*, I get a window telling me that I have to set-up my graphics card, etc., but I can't progress beyond that. I've edited /etc/default/grub to try and remove the splash screen, and commented out the only line that seemed appropriate:
#GRUB_CMDLINE_LINUX_DEFAULT="drm.debug=0xe plymouth.debug"
However, this lets me see that the system tries loading lightdm, but then falls down - at most, I get a single character cursor at the top left of the screen. All available updates are applied.

An abbreviated syslog is attached, but I'm afraid I don't know how to use this to track down the problem further.

Allen Webb (vertago1-s) wrote :

@philip-gemmell-r what version of fglrx-updates did you install? (the package version) I don't think the fix is actually released in the main repositories. They are still showing (2:15.201-0ubuntu1)

If you want to get the fixed version you need to enable wily-proposed long enough to install fglrx-updates. Then you can disable wiley-proposed. For instructions see prior posts.

I've been installing from the main repositories, but had previously tried using the wily-proposed instances without success. However, I've tried again, using the following steps (based on reply #123):
1) Checked /etc/apt/sources.list, and it already includes the line "deb http://gb.archive.com/ubuntu wily-proposed restricted main multiverse universe"
2) Checked /etc/apt/preferences.d/proposed-updates, it exists and contains:
Package: *
Pin: release a=wily-proposed
Pin-Priority: 400
3) Run 'sudo apt-get update
4) Run 'sudo apt-get instal --instal-suggests fglrx-updates/wily-proposed fglrx-updates-core/wily-proposed fglrx-amdcccle-updates/wily-proposed lightdm xorg ubuntu-desktop'

However, following these steps, I am told "Release 'wily-proposed' for 'flgrx-<name>' was not found", where <name> is the remaining extension for the 3 packages. Have I managed to add the wrong repositories somehow?

Mikael Thurberg (mthurberg) wrote :

@Allen Web

Sorry for the late reply. Yes you might be right about that!
Did not think about that! Excuse me.

Thanks for the link!

1 comments hidden view all 253 comments

I finally managed to solve my problem - it turns out to have been far simpler than expected: http://askubuntu.com/questions/692577/ubuntu-15-10-boot-hangs-when-starting-lightdm/692627#692627

John Schroeder (jschroed) wrote :

Thanks Philip. The link to Ubuntu 15.10 boot hangs when starting lightdm helped me too. I had my system set to auto login to my user account but I could not log out or disable the auto login without having lightdm hang on startup. Now I can logout again!

According to that link, in the Ubuntu 15.10 release notes, they said to uninstall fglrx before upgrading to 15.10. That would have avoided the problem lightdm hanging.

I still have an issue where Ctrl-Alt-F1 to F6 do not work for me when fglrx is installed but that is probably a separate issue.

Victor Colta (colta-vicu) wrote :

Affects me too

no longer affects: fglrx
Kaziev Nadir (kurah) wrote :

AMD Radeon R9 380 4G
Affects me too

Andrew Green (andyg54321) wrote :

I hit this today when upgrading from 15.04 to 15.10 on Dell with hybrid graphics. It booted into safe graphics mode, offering a list of graphic operations to try. I didn't touch that and instead ssh'd into the system.

There I looked at /etc/apt/sources.list and saw that wiley-updates was represented.

Next I ran:
  $ sudo apt-get update

Which failed with:
  E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

So I played along:
  $ sudo dpkg --configure -a

This ran well and stopped to prompt me to replace or keep some ATI related files. I opted for replace in every case by answering "Y".

It installed a bunch of stuff and I saw it compile the fglrx module. After it completed I rebooted with:
  $ sudo shutdown -r now

It rebooted and graphics worked again. glxgears seems happy.

HTH

I had this initially on my Toshiba back in October. I am hesitant to attempt an upgrade again, but 15.04 is no longer supported, so I'm between a rock and a hard place. Will the `do-release-upgrade` still have this issue, or is it safe to proceed and expect it to work normally?

mtrsky (mtrsky) wrote :

I had this problem upgrading from 15.04 to 15.10 with a Radeon 7570 card. Andrew Green's solution above worked for me!

aamadis (aamadis) wrote :

I downloaded the debs from #48 but it seems they're only for 64-bit architecture. Any debs for 32-bit users?

Displaying first 40 and last 40 comments. View all 253 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.