package fglrx 2:15.200-0ubuntu0.1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 2

Bug #1443766 reported by Oliver Bienert on 2015-04-14
112
This bug affects 24 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned

Bug Description

oliver@oliver-R540:~$ sudo apt-get install -f
[sudo] password for oliver:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  fglrx-core
The following NEW packages will be installed:
  fglrx-core
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
Need to get 0 B/37.3 MB of archives.
After this operation, 152 MB of additional disk space will be used.
Do you want to continue? [Y/n]
(Reading database ... 376166 files and directories currently installed.)
Preparing to unpack .../fglrx-core_2%3a15.200-0ubuntu0.1_i386.deb ...
Unpacking fglrx-core (2:15.200-0ubuntu0.1) ...
Setting up fglrx-core (2:15.200-0ubuntu0.1) ...
update-alternatives: using /usr/lib/fglrx-core/ld.so.conf to provide /etc/ld.so.conf.d/i386-linux-gnu_GFXCORE.conf (i386-linux-gnu_gfxcore_conf) in auto mode
Loading new fglrx-core-15.200 DKMS files...
First Installation: checking all kernels...
Building only for 3.16.0-34-generic
Building for architecture i686
Building initial module for 3.16.0-34-generic
Done.

fglrx:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.16.0-34-generic/updates/dkms/

depmod....

DKMS: install completed.
update-initramfs: deferring update (trigger activated)
Setting up fglrx (2:15.200-0ubuntu0.1) ...
update-alternatives: warning: forcing reinstallation of alternative /usr/lib/i386-linux-gnu/mesa/ld.so.conf because link group i386-linux-gnu_gl_conf is broken
update-alternatives: error: unable to remove '/etc/ati': Is a directory
dpkg: error processing package fglrx (--configure):
 subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of fglrx-amdcccle:
 fglrx-amdcccle depends on fglrx; however:
  Package fglrx is not configured yet.

dpkg: error processing package fglrx-amdcccle (--configure):
 dependency problems - leaving unconfigured
Processing triggers for initramfs-tools (0.103ubuntu4.2) ...
No apport report written because the error message indicates its a followup error from a previous failure.
                          update-initramfs: Generating /boot/initrd.img-3.16.0-34-generic
Processing triggers for libc-bin (2.19-0ubuntu6.6) ...
Errors were encountered while processing:
 fglrx
 fglrx-amdcccle
E: Sub-process /usr/bin/dpkg returned an error code (1)

ProblemType: Package
DistroRelease: Ubuntu 14.04
Package: fglrx 2:15.200-0ubuntu0.1
ProcVersionSignature: Ubuntu 3.16.0-34.45~14.04.1-generic 3.16.7-ckt8
Uname: Linux 3.16.0-34-generic i686
ApportVersion: 2.14.1-0ubuntu3.8
AptOrdering:
 fglrx-core: Install
 fglrx-core: Configure
 fglrx: Configure
 fglrx-amdcccle: Configure
Architecture: i386
Date: Tue Apr 14 07:44:21 2015
DuplicateSignature: package:fglrx:2:15.200-0ubuntu0.1:subprocess installed post-installation script returned error exit status 2
ErrorMessage: subprocess installed post-installation script returned error exit status 2
InstallationDate: Installed on 2011-03-01 (1504 days ago)
InstallationMedia: Kubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
SourcePackage: fglrx-installer
Title: package fglrx 2:15.200-0ubuntu0.1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 2
UpgradeStatus: Upgraded to trusty on 2014-06-04 (313 days ago)

Oliver Bienert (oliver-bienert) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fglrx-installer (Ubuntu):
status: New → Confirmed

I got this problem the first time I tried to upgrade to 15.200-0ubuntu0.1, but running

apt-get install -f

then worked OK. However, after rebooting, X came up in super low resolution. Checking the Xorg log file I found that it was reporting /etc/ati/amdpcsdb.default was missing.

I tried uninstalling the drivers and reinstalling them. Again, everything installed OK, but the same error occurred.

Checking /etc/ati I found it was empty.

I ran locate to see if there was an amdpcsdb.default file on the system, and found it in /usr/lib/fglrx/etc/ati

I removed the /etc/ati directory and did

sudo ln -s /usr/lib/fglrx/etc/ati /etc

After rebooting, everything worked OK.

I run:

sudo apt-get remove --purge fglrx*

then reinstall

sudo apt-get install fglrx

and work again.

NOTE: i previusly installed version 14.500 manualy

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers