Comment 40 for bug 1424491

QIII (qiii) wrote :

14.04.1, 12.04.4, 14.10 and 15.04 (development) all work. You could use 14.04(<.2) or 12.04(<.5) until this is sorted out and then upgrade.

Just don't install the Hardware Enablement Stack for now.

It's not skin off of anyone's nose if you decide to go back to Windows.