Cannot install nonfree drivers due to dependency problem

Bug #1390032 reported by Redmar on 2014-11-06
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
High
Unassigned

Bug Description

I cannot install non-free drivers for my video card due to a problem with dependencies. I try installing drivers via software & updates -> Additional drivers.

For fglrx
$software-properties-gtk
Warning: install transaction not completed successfully: Transaction failed: Pakketafhankelijkheden kunnen niet opgelost worden
 The following packages have unmet dependencies:

fglrx: Depends: libqtcore4 (>= 4:4.8.4) but 4:4.8.6+git49-gbc62005+dfsg-1ubuntu1 is to be installed
       Depends: xorg-video-abi-18 but it is a virtual package

For fglrx-updates
$ software-properties-gtk
Warning: install transaction not completed successfully: Transaction failed: Pakketafhankelijkheden kunnen niet opgelost worden
 The following packages have unmet dependencies:

fglrx-updates: Depends: libqtcore4 (>= 4:4.8.4) but 4:4.8.6+git49-gbc62005+dfsg-1ubuntu1 is to be installed
               Depends: xorg-video-abi-18 but it is a virtual package

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: fglrx (not installed)
ProcVersionSignature: Ubuntu 3.16.0-24.32-generic 3.16.4
Uname: Linux 3.16.0-24-generic x86_64
ApportVersion: 2.14.7-0ubuntu8
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Nov 6 11:55:07 2014
DistUpgraded: 2014-10-27 11:47:39,708 DEBUG enabling apt cron job
DistroCodename: utopic
DistroVariant: ubuntu
InstallationDate: Installed on 2014-08-07 (90 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
MachineType: Acer Aspire M5500
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.16.0-24-generic root=UUID=812cd0cf-4edb-4f64-88bc-d16bb53612ab ro quiet splash vt.handoff=7
SourcePackage: fglrx-installer
UpgradeStatus: Upgraded to utopic on 2014-10-27 (10 days ago)
dmi.bios.date: 06/18/2007
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: R01-B0
dmi.board.name: FG965M
dmi.board.vendor: Acer
dmi.chassis.type: 3
dmi.chassis.vendor: Acer
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvrR01-B0:bd06/18/2007:svnAcer:pnAspireM5500:pvrR01-B0:rvnAcer:rnFG965M:rvr:cvnAcer:ct3:cvr:
dmi.product.name: Aspire M5500
dmi.product.version: R01-B0
dmi.sys.vendor: Acer
version.compiz: compiz 1:0.9.12+14.10.20140918-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.56-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.3.0-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.3.0-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.16.0-1ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.0-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.4.0-2ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.914-1~exp1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu2
xserver.bootTime: Thu Nov 6 11:11:17 2014
xserver.configfile: default
xserver.devices:
 input Power Button KEYBOARD, id 6
 input Power Button KEYBOARD, id 7
 input Logitech USB Receiver MOUSE, id 8
 input Logitech USB Receiver KEYBOARD, id 9
 input AT Translated Set 2 keyboard KEYBOARD, id 10
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.16.0-1ubuntu1
xserver.video_driver: radeon

Redmar (redmar) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fglrx-installer (Ubuntu):
status: New → Confirmed
Paulus (pavel-bogatyrev) on 2014-11-06
description: updated
Changed in fglrx-installer (Ubuntu):
importance: Undecided → High
Alberto Costa (otreblatsoc) wrote :

I have the same issue. I cannot install fglrx due to dependency problem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers