fglrx 2:9.010-0ubuntu3: fglrx kernel module failed to build

Bug #1198514 reported by Paul Huygen on 2013-07-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned

Bug Description

When I tried to install the driver for Radeon 3000 according to <http://askubuntu.com/questions/62808/ati-incompatible-with-gnome-shell> I got this error.

ProblemType: Package
DistroRelease: Ubuntu 13.04
Package: fglrx 2:8.970-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-26.38-generic 3.8.13.2
Uname: Linux 3.8.0-26-generic x86_64
ApportVersion: 2.9.2-0ubuntu8.1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
DKMSBuildLog:
 DKMS make.log for fglrx-8.970 for kernel 3.8.0-26-generic (x86_64)
 za jul 6 21:18:07 CEST 2013
 AMD kernel module generator version 2.1
 kernel includes at /lib/modules/3.8.0-26-generic/build/include not found or incomplete
 file: /lib/modules/3.8.0-26-generic/build/include/linux/version.h
DKMSKernelVersion: 3.8.0-26-generic
Date: Sat Jul 6 21:18:11 2013
DistUpgraded: 2013-05-08 12:02:59,829 DEBUG enabling apt cron job
DistroCodename: raring
DistroVariant: ubuntu
DuplicateSignature:
 DKMS make.log for fglrx-8.970 for kernel 3.8.0-26-generic (x86_64)
 AMD kernel module generator version 2.1
 kernel includes at /lib/modules/3.8.0-26-generic/build/include not found or incomplete
 file: /lib/modules/3.8.0-26-generic/build/include/linux/version.h
GraphicsCard:
 Advanced Micro Devices, Inc. [AMD/ATI] RS780L [Radeon 3000] [1002:9616] (prog-if 00 [VGA controller])
   Subsystem: Gigabyte Technology Co., Ltd Device [1458:d000]
InstallationDate: Installed on 2013-02-02 (154 days ago)
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120823.1)
MachineType: Gigabyte Technology Co., Ltd. GA-78LMT-S2P
MarkForUpload: True
PackageVersion: 2:9.010-0ubuntu3
ProcKernelCmdLine: root=UUID=da16fe22-84f4-4d46-afaa-37adaee37e22 ro quiet splash
SourcePackage: fglrx-installer
Title: fglrx 2:9.010-0ubuntu3: fglrx kernel module failed to build
UnitySupportTest:
 Error: command ['/usr/lib/nux/unity_support_test', '-p', '-f'] failed with exit code 1: X Error of failed request: BadRequest (invalid request code or no such operation)
   Major opcode of failed request: 153 (GLX)
   Minor opcode of failed request: 19 (X_GLXQueryServerString)
   Serial number of failed request: 22
   Current serial number in output stream: 22
UpgradeStatus: Upgraded to raring on 2013-05-08 (59 days ago)
dmi.bios.date: 03/20/2012
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F2
dmi.board.name: GA-78LMT-S2P
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF2:bd03/20/2012:svnGigabyteTechnologyCo.,Ltd.:pnGA-78LMT-S2P:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-78LMT-S2P:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: GA-78LMT-S2P
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
make.log:
 DKMS make.log for fglrx-8.970 for kernel 3.8.0-26-generic (x86_64)
 za jul 6 21:18:07 CEST 2013
 AMD kernel module generator version 2.1
 kernel includes at /lib/modules/3.8.0-26-generic/build/include not found or incomplete
 file: /lib/modules/3.8.0-26-generic/build/include/linux/version.h
version.compiz: compiz 1:0.9.9~daily13.04.18.1~13.04-0ubuntu1
version.ia32-libs: ia32-libs 20090808ubuntu36
version.libdrm2: libdrm2 2.4.43-0ubuntu1.1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.1.3-0ubuntu0.3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.1.3-0ubuntu0.3
version.xserver-xorg-core: xserver-xorg-core 2:1.13.3-0ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2b2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.1.0-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.6-0ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.7-0ubuntu1
xserver.bootTime: Sat Jul 6 20:46:17 2013
xserver.configfile: /etc/X11/xorg.conf
xserver.devices:
 input Power Button KEYBOARD, id 6
 input Power Button KEYBOARD, id 7
 input AT Translated Set 2 keyboard KEYBOARD, id 8
 input ImPS/2 Generic Wheel Mouse MOUSE, id 9
xserver.errors:
 No supported AMD display adapters were found
 open /dev/dri/card0: No such file or directory
 open /dev/fb0: No such file or directory
 Screen 0 deleted because of no matching config section.
 GLX error: Can not get required symbols.
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.13.3-0ubuntu6

Paul Huygen (paul-huygen) wrote :
Daniel van Vugt (vanvugt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 859101, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers