fglrx and fglrx-updates not working (Ubuntu 13.04)

Bug #1173967 reported by ju on 2013-04-28
48
This bug affects 8 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned

Bug Description

I made a fresh install of Ubuntu 13.04, then to solve the overheating problem with open source drivers, tried to install the proprietary ati drivers from the update manager.
Both not worked, leaving the system with only the wallpaper and the mouse pointer.

Same story with the ati installer (catalyst 13.4). I tried both, generating packages for Ubuntu and using the .run installer itself. Always wallpaper and pointer.

It seems that no installation of ati drivers is possible on Ubuntu 13.04.

I have a Radeon HD 6770M / Intel system.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1173967/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → fglrx-installer (Ubuntu)
tags: added: raring
dougleduck (palmer-jody) wrote :

Same problem found on Dell Vostro 3550 with Radeon 6660M graphics card on 13.04 32 bit.

RThinker (yegor-rog) wrote :

Same with Radeon HD 5650 on Acer 5740G.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fglrx-installer (Ubuntu):
status: New → Confirmed

Broken fglrx AMD 13.4 drivers

AMD driver install pretends to work nothing works except screen and pointer

13.04 with 3.8.0-19-generic AMD HD6970

ajw107 (alex-wood-bcs) wrote :

Exactly the same with me, I'm trying multiple work arounds, but I can't figure out the root cause. Ubuntu 13.04 x64 ACER 8943G with ATI Radeon HD 5650 graphics.

Carlos Renê (slipttees) wrote :

Here to, Always wallpaper and pointer.

Ubuntu 13.04 i386 - VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV620/M82 [Mobility Radeon HD 3450/3470]

Dainius (dainiui-g) wrote :

Here to, always wallpaper and pointer.

Dell Vostro 3550, Ubuntu 13.04 x64, Radeon HD 6630M/Intel

higltypig (higltypig-e) wrote :

I had this happen.

What was going on for me was the unity plugin was crashing. i went to terminal and installed CCSM and re-enabled it there.

This was using the binary from the AMD website however, fglrx-updates is working fine for me.

Rik Doclo (rik-doclo-s) wrote :

Same problem here.
Xserver-xorg-video-intel is definitly the troublemaker for me.
In discrete mode i can do whatever I want and even install the latet version of xserver-xorg-video-intel.
Switching to high performance graphics kills the install (message about only low graphics mode available).
Degrading the xserver-xorg-video-intel gets ubuntu back in the run.
Naturally the system wants to re-install latest driver. I can't seem to fix that by using the lock driver functionality in synaptic like some blogs suggest. So when the system breaks again after an update i do have to demote the driver version.
Now i have kicked out some ppa's out of my list and it seems to be pretty stable.
Conclusion: The amd and intel combination is probably the cause for this malfunction

hkais (r-2) wrote :

hello all,

I have the same issue.
I am running a AMD/ATI RV620/M82 mobility
lspci | grep VGA
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV620/M82 [Mobility Radeon HD 3450/3470]

As I could find out AMD has stopped the support of the chip so the new drivers wouldn't support the "old" card. Damn, the notebook is a litte more older than 3 years. Have I to switch my hardware every time a driver gets unavailable? I hate it really, the crap with the proprietary drivers... I do not play, do not use 3D but I need a fast desktop for work.

Okay enough of my pain.
Here the supported chips
http://support.amd.com/us/kbarticles/Pages/amdcatalyst13-4linreleasenotes.aspx

You could try to downgrade your drivers AND your x-server with the ppa
https://launchpad.net/~makson96/+archive/fglrx

and here a duplicate entry
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1184339

hope it helps

sami (sami-os) wrote :

Having the same issue here, had to to install another window manager to get ubuntu working since unity needs 3d acceleration. Also tried re-installing the flgrx but at the reboot I only have the shell running and kinda got it to work back like it was before the re-install I guess this has something to do with x-server and the amd driver.

julian wang (zeratul-j) wrote :

Same issue with HP envy6 1016TX. My VGA chip is Radeon HD 7670M.
I tried the both ati official driver "amd-driver-installer-catalyst-13-4-x86.x86-64.run" and fglrx in apt source, only wallpaper and pointer seems working.
The same driver on quantal works perfect.

julian wang (zeratul-j) wrote :

By the way, there's intel / ati 2 VGA cards on my laptop, that might be the problem.

ImorePH@gmail.com (imoreph) wrote :

My laptop has dual ati 5650 and intel. In bios I swith into discrete graphic (5650). It successfuly installed with fglrx-updates but not with fglrx. But it seems has many problems, my desktop sometimes appear glitches like projected bars. And with 13.04, it cannot be installed with ati catalyst 12.10 from website while in precise it can be installed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers