vlc crashed with SIGSEGV in XQueryExtension()

Bug #1109880 reported by -JojoMan- on 2013-01-30
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Medium
Unassigned

Bug Description

just trying to load a video and it crashed.

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: vlc-nox 2.0.5-1
ProcVersionSignature: Ubuntu 3.8.0-2.6-generic 3.8.0-rc4
Uname: Linux 3.8.0-2-generic i686
NonfreeKernelModules: fglrx
ApportVersion: 2.8-0ubuntu2
Architecture: i386
CrashCounter: 1
Date: Tue Jan 29 19:12:28 2013
Disassembly: => 0x0: Cannot access memory at address 0x0
ExecutablePath: /usr/bin/vlc
InstallationDate: Installed on 2011-04-23 (647 days ago)
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110413)
MarkForUpload: True
ProcCmdline: /usr/bin/vlc video.mkv
SegvAnalysis:
 Segfault happened at: 0x0: Cannot access memory at address 0x0
 PC (0x00000000) not located in a known VMA region (needed executable region)!
 Stack memory exhausted (SP below stack segment)
SegvReason: executing NULL VMA
Signal: 11
SourcePackage: vlc
StacktraceTop:
 ?? ()
 XQueryExtension () from /usr/lib/i386-linux-gnu/libX11.so.6
 amdPcsOpenX11 () from /usr/lib/fglrx/libatiuki.so.1
 ?? () from /usr/lib/fglrx/libatiadlxx.so
 ADL_Main_Control_Refresh () from /usr/lib/fglrx/libatiadlxx.so
Title: vlc crashed with SIGSEGV in XQueryExtension()
UpgradeStatus: Upgraded to raring on 2013-01-08 (21 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

-JojoMan- (jojoman02) wrote :

StacktraceTop:
 ?? ()
 XQueryExtension (dpy=0xb5258950, name=0xa86d3368 "ATIFGLEXTENSION", major_opcode=0xafa676a8, first_event=0xafa676a8, first_error=0xafa676a8) at ../../src/QuExt.c:43
 amdPcsOpenX11 () from /tmp/apport_sandbox_Ub0sx5/usr/lib/fglrx/libatiuki.so.1
 ADL_Main_Control_Refresh_X () from /tmp/apport_sandbox_Ub0sx5/usr/lib/fglrx/libatiadlxx.so
 ADL_Main_Control_Refresh () from /tmp/apport_sandbox_Ub0sx5/usr/lib/fglrx/libatiadlxx.so

Changed in vlc (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Benjamin Drung (bdrung) on 2013-03-30
description: updated
information type: Private → Public
affects: vlc (Ubuntu) → fglrx-installer (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers