[Toshiba L850D-11Z] Backlight keys don't work with fglrx-installer

Bug #1074960 reported by bruno pennec on 2012-11-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned

Bug Description

Backlight keys work (I get the slider on screen) , but there is no change on brightness.

Other tests :
   - kernel 3.6.5 (ppa) gives same result than kernel 3.5.0-17 (default 12.10 configuration)
   - when Backlight is set to a new value(on the slider), a sleep and a wake up set the correct value on screen brightness

   - L850D-11Z is a dual GPU (AMD A8), so I take a look at acpi tree :
            - there is 2 directory acpi_vga0 and acpi_vga1 for the 2 radeon GPU
            - /sys/class/backlight/acpi_vgaX/actual_brightness had the right value (in the 2 directory)
            - changing /sys/class/backlight/acpi_vgaX/brightness change actual_brightness but had no effect on screen too

From the log :
On dmesg, i have this 2 errors, but they don't seem to be related to backlight variable _BCL :
[ 30.212195] ACPI Error: Method parse/execution failed [\_SB_.PCI0.VGA_.AF03] (Node ffff8801a665c000), AE_AML_INFINITE_LOOP (20120711/psparse-536)
[ 30.212214] ACPI Error: Method parse/execution failed [\_SB_.PCI0.VGA_.ATIF] (Node ffff8801a665ad98), AE_AML_INFINITE_LOOP (20120711/psparse-536)

I do the standard reports on acpi, and get the following result :

In result.log :
PASSED: Test 88, Method _BCL returned a sane package of 10 integers.
PASSED: Test 88, \_SB_.PCI0.PB3_.VGA_.LCD_._BCL correctly acquired and released locks 5 times.

Test 89 of 94: Check _BCM (Set Brightness Level).
ACPICA Exception AE_AML_PACKAGE_LIMIT during execution of method BLMP
FAILED [CRITICAL] AEAMLPackgeLimit: Test 89, Detected error 'Package limit' when evaluating
'\_SB_.PCI0.VGA_.LCD_._BCM'.
PASSED: Test 89, \_SB_.PCI0.VGA_.LCD_._BCM correctly acquired and released locks 7 times.
ACPICA Exception AE_AML_PACKAGE_LIMIT during execution of method BLMP
FAILED [CRITICAL] AEAMLPackgeLimit: Test 89, Detected error 'Package limit' when evaluating
'\_SB_.PCI0.PB2_.VGA_.LCD_._BCM'.
PASSED: Test 89, \_SB_.PCI0.PB2_.VGA_.LCD_._BCM correctly acquired and released locks 7 times.
ACPICA Exception AE_AML_PACKAGE_LIMIT during execution of method BLMP
FAILED [CRITICAL] AEAMLPackgeLimit: Test 89, Detected error 'Package limit' when evaluating
'\_SB_.PCI0.PB3_.VGA_.LCD_._BCM'.
PASSED: Test 89, \_SB_.PCI0.PB3_.VGA_.LCD_._BCM correctly acquired and released locks 7 times.

So i join DSDT.dsl to this report. I would add result.log if it is needed.

WORKAROUND: Use the open source radeon driver.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: linux-image-3.5.0-17-generic 3.5.0-17.28
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.6.1-0ubuntu6
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: bpennec 2051 F.... pulseaudio
 /dev/snd/controlC0: bpennec 2051 F.... pulseaudio
Date: Sun Nov 4 20:14:31 2012
HibernationDevice: RESUME=UUID=4de0f688-762d-4c47-92ca-902baa5062a1
InstallationDate: Installed on 2012-11-02 (2 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MachineType: TOSHIBA SATELLITE L850D-11Z
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-17-generic root=UUID=43b5124e-2519-4e84-affb-124b98be7670 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-17-generic N/A
 linux-backports-modules-3.5.0-17-generic N/A
 linux-firmware 1.95
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/31/2012
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: 1.20
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Pumori
dmi.board.vendor: AMD
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: OEM Chassis Manufacturer
dmi.chassis.version: OEM Chassis Version
dmi.modalias: dmi:bvnInsydeCorp.:bvr1.20:bd07/31/2012:svnTOSHIBA:pnSATELLITEL850D-11Z:pvrPSKECE-01G009FR:rvnAMD:rnPumori:rvrBaseBoardVersion:cvnOEMChassisManufacturer:ct10:cvrOEMChassisVersion:
dmi.product.name: SATELLITE L850D-11Z
dmi.product.version: PSKECE-01G009FR
dmi.sys.vendor: TOSHIBA

bruno pennec (bruno-pennec) wrote :
Brad Figg (brad-figg) on 2012-11-04
Changed in linux (Ubuntu):
status: New → Confirmed
summary: - Backlight keys don't work on Toshiba L850D-11Z
+ [Toshiba L850D-11Z] Backlight keys don't work

bruno pennec, thank you for reporting this and helping make Ubuntu better.

What key combination specifically toggles the brightness?

As well, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the kernel in the mainline kernels archive directory daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.7-rc4-raring

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the following tags:
kernel-unable-to-test-upstream
kernel-unable-to-test-upstream-VERSION-NUMBER

Please let us know your results. Thank you for your understanding.

Helpful bug reporting tips:
https://help.ubuntu.com/community/ReportingBugs

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
tags: added: kernel-unable-to-test-upstream kernel-unable-to-test-upstream-v3.7-rc4-raring
bruno pennec (bruno-pennec) wrote :

I can't test on kernel 3.7-rc4-raring because dkms build fail on fglrx,
so i can't be in ubuntu mainstream configuration to test the bug.

If i revert to open source radeon driver, backlight setting works again on any of the 3 kernels 3.5.0-17, 3.6.5 or 3.7-rc4.
(The backlight was working with fglrx driver on ubuntu 12.04)

tags: added: kernel-unable-to-test-upstream-v3.7-rc4
removed: kernel-unable-to-test-upstream-v3.7-rc4-raring
description: updated
summary: - [Toshiba L850D-11Z] Backlight keys don't work
+ [Toshiba L850D-11Z] Backlight keys don't work with fglrx-installer

Added task for fglrx-installer due to correlation of it being installed with the backlight not working, and it being uninstalled with it working again.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

bruno pennec, could you please confirm this issue exists with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ . If the issue remains, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

tags: added: bios-outdated-6.10
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
bruno pennec (bruno-pennec) wrote :

With last upgrade to Ubuntu 14.10, (kernel 3.16.0-23-generic + fglrx 14.2),
this bug is now solved with acpi_osi=Linux on linux boot command line.

So, I would propose to close the bug.

bruno pennec, typically bugs are considered fixed when no WORKAROUNDs are required to have the desired functionality. However, if this works for you, and you would not like anyone to continue to investigate the issue as it is in 14.10, please feel free to mark this Status Invalid at the top of the bug report.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers