package fglrx (not installed) failed to install/upgrade: subprocess installed post-removal script returned error exit status 1

Bug #1071036 reported by Tushar on 2012-10-24
104
This bug affects 15 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned

Bug Description

After upgrading from 12.04 to 12.10 Unity stopped woking, no lauch bar, dash nothing, could not move, resize windows, resolution was bad.
Searched on google, followed below steps
sudo sh /usr/share/ati/fglrx-uninstall.sh
sudo apt-get remove --purge fglrx fglRx_* fglrx-amdcccle* fglrx-dev* xorg-driver-fglrx
sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon
sudo apt-get install xserver-xorg-video-ati
sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
sudo reboot

Unity woks now, looks much better but got this error now

ProblemType: Package
DistroRelease: Ubuntu 12.10
Package: fglrx (not installed)
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic i686
.tmp.unity.support.test.0:

ApportVersion: 2.6.1-0ubuntu3
AptOrdering:
 fglrx: Purge
 fglrx-amdcccle-updates: Purge
 fglrx-updates: Purge
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
Date: Wed Oct 24 22:21:08 2012
DistUpgraded: 2012-10-21 13:40:53,485 DEBUG enabling apt cron job
DistroCodename: quantal
DistroVariant: ubuntu
DkmsStatus:
 virtualbox, 4.1.18, 3.2.0-32-generic, i686: installed
 virtualbox, 4.1.18, 3.5.0-17-generic, i686: installed
DuplicateSignature:
 Purging configuration files for fglrx ...
 update-initramfs: deferring update (trigger activated)
 update-rc.d: /etc/init.d/atieventsd exists during rc.d purge (use -f to force)
 dpkg: error processing fglrx (--purge):
  subprocess installed post-removal script returned error exit status 1
ErrorMessage: subprocess installed post-removal script returned error exit status 1
GraphicsCard:
 Advanced Micro Devices [AMD] nee ATI RV620 [Mobility Radeon HD 3400 Series] [1002:95c4] (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:3600]
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
MachineType: Hewlett-Packard HP Pavilion dv5 Notebook PC
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-17-generic root=UUID=1474bfa1-a555-46ed-8334-19701b9ab05b ro quiet splash vt.handoff=7
SourcePackage: fglrx-installer
Title: package fglrx (not installed) failed to install/upgrade: subprocess installed post-removal script returned error exit status 1
UpgradeStatus: Upgraded to quantal on 2012-10-21 (3 days ago)
dmi.bios.date: 08/19/2009
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.37
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 3600
dmi.board.vendor: Quanta
dmi.board.version: 98.36
dmi.chassis.type: 10
dmi.chassis.vendor: Quanta
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.37:bd08/19/2009:svnHewlett-Packard:pnHPPaviliondv5NotebookPC:pvrRev1:rvnQuanta:rn3600:rvr98.36:cvnQuanta:ct10:cvrN/A:
dmi.product.name: HP Pavilion dv5 Notebook PC
dmi.product.version: Rev 1
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.8.4-0ubuntu3
version.libdrm2: libdrm2 2.4.39-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.13.0-0ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.99.99~git20120913.8637f772-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.9-0ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.2-0ubuntu3

Tushar (mailtotushark) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fglrx-installer (Ubuntu):
status: New → Confirmed

Looks like bug 949641. The following commands should fix you:

sudo /usr/sbin/update-rc.d -f atieventsd remove
sudo dpkg --purge fglrx fglrx-amdccle

To post a comment you must log in.