gnome-control-center crashed with signal 5 in _XReply()

Bug #1058946 reported by Sijo
182
This bug affects 20 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Medium
Unassigned
gnome-control-center (Ubuntu)
High
Unassigned

Bug Description

after upgrading from 12.04 to 12.10, I could not see any panel. But I can see the desktop items.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: gnome-control-center 1:3.4.2-0ubuntu16
ProcVersionSignature: Ubuntu 3.5.0-16.25-generic 3.5.4
Uname: Linux 3.5.0-16-generic x86_64
ApportVersion: 2.5.3-0ubuntu1
Architecture: amd64
Date: Sun Sep 30 14:09:33 2012
ExecutablePath: /usr/bin/gnome-control-center
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120823.1)
ProcCmdline: gnome-control-center
ProcEnviron:
 SHELL=/bin/bash
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
Signal: 5
SourcePackage: gnome-control-center
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 _XReply () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 ?? () from /usr/lib/fglrx/libGL.so.1
 ?? () from /usr/lib/fglrx/libGL.so.1
 glXQueryVersion () from /usr/lib/fglrx/libGL.so.1
Title: gnome-control-center crashed with signal 5 in _XReply()
UpgradeStatus: Upgraded to quantal on 2012-09-28 (2 days ago)
UserGroups:

usr_lib_gnome-control-center:
 activity-log-manager-control-center 0.9.4-0ubuntu4
 deja-dup 24.0-0ubuntu1
 gnome-control-center-signon 0.0.18-0ubuntu1
 indicator-datetime 12.10.1-0ubuntu1

Revision history for this message
Sijo (sijokjos) wrote :
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 ?? () from /tmp/tmpB7TclW/usr/lib/fglrx/libGL.so.1
 ?? () from /tmp/tmpB7TclW/usr/lib/fglrx/libGL.so.1
 glXQueryVersion () from /tmp/tmpB7TclW/usr/lib/fglrx/libGL.so.1
 _cogl_winsys_renderer_connect (renderer=0x7f01b949e290, error=0x7fff589239c8) at ./winsys/cogl-winsys-glx.c:344
 cogl_renderer_connect (renderer=0x7f01b949e290, error=error@entry=0x7fff58923a18) at ./cogl-renderer.c:365

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : StacktraceSource.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Revision history for this message
Sebastien Bacher (seb128) wrote :

StacktraceTop:
 ?? () from /tmp/tmpB7TclW/usr/lib/fglrx/libGL.so.1

-> that's an issue with the amd's fglrx drivers, reassigning

visibility: private → public
affects: gnome-control-center (Ubuntu) → fglrx-installer (Ubuntu)
Changed in gnome-control-center (Ubuntu):
importance: Undecided → High
status: New → In Progress
tags: added: bugpattern-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.4.2-0ubuntu19

---------------
gnome-control-center (1:3.4.2-0ubuntu19) quantal; urgency=low

  * debian/patches/clutter_init.patch:
    - dropped, don't use clutter for quantal, it was added because
      ubuntu-online-accounts experimented with animation but they stopped,
      not using clutter will workaround GL drivers issues (lp: #1058946)
 -- Sebastien Bacher <email address hidden> Tue, 09 Oct 2012 17:03:35 +0200

Changed in gnome-control-center (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.