fglrx-updates-core 2:15.201-0ubuntu0.14.04.1: fglrx-updates-core kernel module failed to build [-fstack-protector-strong not supported by compiler]

Bug #1578958 reported by Campbell Boyd on 2016-05-06
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned
fglrx-installer-updates (Ubuntu)
Undecided
Unassigned

Bug Description

Downloaded http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.6-rc6-wily/ to confimr bug. On installing errors came up:

Error! Bad return status for module build on kernel: 4.6.0-040600rc6-generic (x86_64)
Consult /var/lib/dkms/fglrx-updates-core/15.201/build/make.log for more information.
Error! Bad return status for module build on kernel: 4.6.0-040600rc6-generic (x86_64)
Consult /var/lib/dkms/vboxhost/5.0.14/build/make.log for more information.

DKMS make.log for fglrx-updates-core-15.201 for kernel 4.6.0-040600rc6-generic (x86_64)
Fri May 6 09:11:51 BST 2016
/usr/sbin/dkms: line 73: cd: /var/lib/dkms/fglrx/15.201/build: No such file or directory
AMD kernel module generator version 2.1
doing Makefile based build for kernel 2.6.x and higher
rm -rf *.c *.h *.o *.ko *.a .??* *.symvers
make -C /lib/modules/4.6.0-040600rc6-generic/build SUBDIRS=/var/lib/dkms/fglrx-updates-core/15.201/build/2.6.x modules
make[1]: Entering directory `/usr/src/linux-headers-4.6.0-040600rc6-generic'
Makefile:667: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler
  CC [M] /var/lib/dkms/fglrx-updates-core/15.201/build/2.6.x/firegl_public.o
gcc: error: unrecognized command line option ‘-fstack-protector-strong’
make[2]: *** [/var/lib/dkms/fglrx-updates-core/15.201/build/2.6.x/firegl_public.o] Error 1
make[1]: *** [_module_/var/lib/dkms/fglrx-updates-core/15.201/build/2.6.x] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-4.6.0-040600rc6-generic'
make: *** [kmod_build] Error 2
build failed with return value 2

DKMS make.log for vboxhost-5.0.14 for kernel 4.6.0-040600rc6-generic (x86_64)
Fri May 6 09:11:51 BST 2016
make: Entering directory `/usr/src/linux-headers-4.6.0-040600rc6-generic'
Makefile:667: Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler
  LD /var/lib/dkms/vboxhost/5.0.14/build/built-in.o
  LD /var/lib/dkms/vboxhost/5.0.14/build/vboxdrv/built-in.o
  CC [M] /var/lib/dkms/vboxhost/5.0.14/build/vboxdrv/linux/SUPDrv-linux.o
gcc: error: unrecognized command line option ‘-fstack-protector-strong’
make[2]: *** [/var/lib/dkms/vboxhost/5.0.14/build/vboxdrv/linux/SUPDrv-linux.o] Error 1
make[1]: *** [/var/lib/dkms/vboxhost/5.0.14/build/vboxdrv] Error 2
make: *** [_module_/var/lib/dkms/vboxhost/5.0.14/build] Error 2
make: Leaving directory `/usr/src/linux-headers-4.6.0-040600rc6-generic'

ProblemType: Package
DistroRelease: Ubuntu 14.04
Package: fglrx-updates-core 2:15.201-0ubuntu0.14.04.1
ProcVersionSignature: Ubuntu 3.13.0-45.74-generic 3.13.11-ckt13
Uname: Linux 3.13.0-45-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.14.1-0ubuntu3.19
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
DKMSKernelVersion: 4.6.0-040600rc6-generic
Date: Fri May 6 09:11:47 2016
DistUpgraded: Fresh install
DistroCodename: trusty
DistroVariant: ubuntu
DkmsStatus:
 fglrx-updates-core, 15.201, 3.13.0-45-generic, x86_64: installed
 vboxhost, 5.0.14, 3.13.0-45-generic, x86_64: installed
DuplicateSignature: dkms:fglrx-updates-core:2:15.201-0ubuntu0.14.04.1:gcc: error: unrecognized command line option ‘-fstack-protector-strong’
GraphicsCard:
 Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [8086:0412] (rev 06) (prog-if 00 [VGA controller])
   Subsystem: Gigabyte Technology Co., Ltd Device [1458:d000]
InstallationDate: Installed on 2014-09-17 (597 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
MachineType: NOVATECH LTD PERSONAL COMPUTER
PackageVersion: 2:15.201-0ubuntu0.14.04.1
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-45-generic root=UUID=fc6ea265-b75c-458a-b5d2-2950ebad0828 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 dpkg 1.17.5ubuntu5.6
 apt 1.0.1ubuntu2.13
SourcePackage: fglrx-installer-updates
Title: fglrx-updates-core 2:15.201-0ubuntu0.14.04.1: fglrx-updates-core kernel module failed to build
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/11/2015
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: F6
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: H81M-DS2V
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: To be filled by O.E.M.
dmi.chassis.asset.tag: xxxxxxx-xxx
dmi.chassis.type: 3
dmi.chassis.vendor: NOVATECH LTD
dmi.chassis.version: V1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrF6:bd08/11/2015:svnNOVATECHLTD:pnPERSONALCOMPUTER:pvrV1.0:rvnGigabyteTechnologyCo.,Ltd.:rnH81M-DS2V:rvrTobefilledbyO.E.M.:cvnNOVATECHLTD:ct3:cvrV1.0:
dmi.product.name: PERSONAL COMPUTER
dmi.product.version: V1.0
dmi.sys.vendor: NOVATECH LTD
modified.conffile..etc.ati.atiapfxx: [deleted]
modified.conffile..etc.ati.authatieventsd.sh: [deleted]
modified.conffile..etc.ati.logo.mask.xbm.example: [deleted]
modified.conffile..etc.ati.logo.xbm.example: [deleted]
modified.conffile..etc.ati.signature: [deleted]
version.compiz: compiz 1:0.9.11.3+14.04.20150313-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.64-1~ubuntu14.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.3-0ubuntu0.6
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.1.3-0ubuntu0.6
version.xserver-xorg-core: xserver-xorg-core 2:1.15.1-0ubuntu2.7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu3.1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910-0ubuntu1.6
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Fri May 6 06:48:57 2016
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 41059
 vendor DEL
xserver.version: 2:1.15.1-0ubuntu2.7

tags: removed: need-duplicate-check
summary: fglrx-updates-core 2:15.201-0ubuntu0.14.04.1: fglrx-updates-core kernel
- module failed to build
+ module failed to build [-fstack-protector-strong not supported by
+ compiler]
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fglrx-installer-updates (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

See also bug 1509870

Changed in fglrx-installer (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers