package fglrx-updates-core 2:15.200-0ubuntu0.1 failed to install/upgrade: trying to overwrite '/etc/acpi/fglrx-powermode.sh', which is also in package fglrx-updates 2:13.350.1-0ubuntu2

Bug #1443016 reported by Andreas Vermehren
64
This bug affects 12 people
Affects Status Importance Assigned to Milestone
fglrx-installer-updates (Ubuntu)
High
Alberto Milone
Trusty
Undecided
Unassigned

Bug Description

While installing

ProblemType: Package
DistroRelease: Ubuntu 14.04
Package: fglrx-updates-core 2:15.200-0ubuntu0.1
ProcVersionSignature: Ubuntu 3.13.0-49.81-generic 3.13.11-ckt17
Uname: Linux 3.13.0-49-generic x86_64
NonfreeKernelModules: fglrx
.tmp.unity.support.test.1:

ApportVersion: 2.14.1-0ubuntu3.8
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Sat Apr 11 08:28:21 2015
DistUpgraded: 2014-04-03 19:18:37,545 DEBUG enabling apt cron job
DistroCodename: trusty
DistroVariant: ubuntu
DkmsStatus: fglrx-updates-core, 15.200, 3.13.0-49-generic, x86_64: installed
DpkgTerminalLog:
 Preparing to unpack .../fglrx-updates-core_2%3a15.200-0ubuntu0.1_amd64.deb ...
 Unpacking fglrx-updates-core (2:15.200-0ubuntu0.1) ...
 dpkg: error processing archive /var/cache/apt/archives/fglrx-updates-core_2%3a15.200-0ubuntu0.1_amd64.deb (--unpack):
  trying to overwrite '/etc/acpi/fglrx-powermode.sh', which is also in package fglrx-updates 2:13.350.1-0ubuntu2
DuplicateSignature: package:fglrx-updates-core:2:15.200-0ubuntu0.1:trying to overwrite '/etc/acpi/fglrx-powermode.sh', which is also in package fglrx-updates 2:13.350.1-0ubuntu2
ErrorMessage: trying to overwrite '/etc/acpi/fglrx-powermode.sh', which is also in package fglrx-updates 2:13.350.1-0ubuntu2
GraphicsCard:
 Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde PRO [Radeon HD 7750 / R7 250E] [1002:683f] (prog-if 00 [VGA controller])
   Subsystem: PC Partner Limited / Sapphire Technology Device [174b:e213]
InstallationDate: Installed on 2012-05-13 (1063 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MachineType: To be filled by O.E.M. To be filled by O.E.M.
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-49-generic root=UUID=8d140bde-7d49-4578-954a-48023f906c94 ro quiet splash vt.handoff=7
Renderer: Software
SourcePackage: fglrx-installer-updates
Title: package fglrx-updates-core 2:15.200-0ubuntu0.1 failed to install/upgrade: trying to overwrite '/etc/acpi/fglrx-powermode.sh', which is also in package fglrx-updates 2:13.350.1-0ubuntu2
UpgradeStatus: Upgraded to trusty on 2014-04-03 (373 days ago)
dmi.bios.date: 03/12/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1102
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: M5A97
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1102:bd03/12/2012:svnTobefilledbyO.E.M.:pnTobefilledbyO.E.M.:pvrTobefilledbyO.E.M.:rvnASUSTeKCOMPUTERINC.:rnM5A97:rvrRev1.xx:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To be filled by O.E.M.
dmi.product.version: To be filled by O.E.M.
dmi.sys.vendor: To be filled by O.E.M.
modified.conffile..etc.OpenCL.vendors.amdocl64.icd: [deleted]
version.compiz: compiz 1:0.9.11.3+14.04.20150313-0ubuntu1
version.fglrx-installer: fglrx-installer N/A
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.56-1~ubuntu2
version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.3-0ubuntu0.4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.1.3-0ubuntu0.4
version.xserver-xorg-core: xserver-xorg-core 2:1.15.1-0ubuntu2.7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu3.1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910-0ubuntu1.4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Sun Apr 12 08:29:08 2015
xserver.configfile: default
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.15.1-0ubuntu2.7

Revision history for this message
Andreas Vermehren (one-9-archmage) wrote :
tags: removed: need-duplicate-check
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fglrx-installer-updates (Ubuntu):
status: New → Confirmed
Changed in fglrx-installer-updates (Ubuntu):
importance: Undecided → High
assignee: nobody → Alberto Milone (albertomilone)
Changed in fglrx-installer-updates (Ubuntu):
status: Confirmed → In Progress
Revision history for this message
Alberto Milone (albertomilone) wrote :

I've just uploaded a fix in trusty-proposed. Hopefully it will be approved soon.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer-updates - 2:15.200-0ubuntu4

---------------
fglrx-installer-updates (2:15.200-0ubuntu4) vivid; urgency=medium

  * debian/control.in:
    - Allow the -core package to overwrite files that belong to
      fglrx. This prevents errors caused by the split into fglrx
      and fglrx-core when dist-upgrading (LP: #1443016).
 -- Alberto Milone <email address hidden> Thu, 16 Apr 2015 12:12:35 +0200

Changed in fglrx-installer-updates (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Chris J Arges (arges) wrote : Please test proposed package

Hello Andreas, or anyone else affected,

Accepted fglrx-installer into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/fglrx-installer/2:15.200-0ubuntu0.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Changed in fglrx-installer-updates (Ubuntu Trusty):
status: New → Fix Committed
Revision history for this message
Chris J Arges (arges) wrote :

Hello Andreas, or anyone else affected,

Accepted fglrx-installer-updates into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/fglrx-installer-updates/2:15.200-0ubuntu0.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Revision history for this message
Alberto Milone (albertomilone) wrote :

I can no longer reproduce the problem with either fglrx or with fglrx-updates 2:15.200-0ubuntu0.3 in -proposed.

tags: added: verification-done
removed: verification-needed
Revision history for this message
Timo Aaltonen (tjaalton) wrote : Update Released

The verification of the Stable Release Update for fglrx-installer has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer-updates - 2:15.200-0ubuntu0.3

---------------
fglrx-installer-updates (2:15.200-0ubuntu0.3) trusty-proposed; urgency=medium

  * debian/fglrx.preinst.in, debian/fglrx.postinst.in:
    - Work around regression when upgrading from releases that do
      not have the -core package. For some reason, the
      update-alternatives command would remove newly installed
      files when previous versions of the same files belonged to
      the previous alternative (LP: #1443016, LP: #1129409).

fglrx-installer-updates (2:15.200-0ubuntu0.2) trusty-proposed; urgency=medium

  * debian/control.in:
    - Allow the -core package to overwrite files that belong to
      fglrx. This prevents errors caused by the split into fglrx
      and fglrx-core (LP: #1443016, LP: #1129409).

fglrx-installer-updates (2:15.200-0ubuntu0.1) trusty-proposed; urgency=medium

  * New upstream release:
    - Add support for X ABI 19.
  * debian/control.in, debian/com.ubuntu.amdcccle.pkexec.policy,
    debian/rules, debian/fglrx-updates.dirs.in,
    debian/fglrx-updates.install.in,
    debian/fglrx-updates.links.in,
    debian/fglrx-updates.postinst.in,
    debian/fglrx-updates.postrm.in,
    debian/fglrx-updates.preinst.in,
    debian/fglrx-updates.prerm.in,
    debian/fglrx-updates.grub-gfxpayload.in,
    debian/overrides/fglrx-updates.in,
    debian/overrides/fglrx-updates-core.in,
    debian/overrides/fglrx-updates-dev.in,
    debian/fglrx-amdcccle-updates.dirs.in,
    debian/fglrx-amdcccle-updates.install.in,
    debian/fglrx-updates-core.dirs.in,
    debian/fglrx-updates-core.links.in,
    debian/fglrx-updates-core.postinst.in,
    debian/fglrx-updates-core.postrm.in,
    debian/fglrx-updates-core.preinst.in,
    debian/fglrx-updates-core.prerm.in,
    debian/fglrx-updates-core.postrm.in:
    - Drop conflicts/provides/replaces libopencl1 and provide
      opencl-icd (LP: #1129409).
    - Make amdcccle depend on polkit-1.
    - Use pkexec for amdcccle when running Unity.
    - Split the minimal driver into the -core package.
    - Depend on the "file" package.
  * debian/fglrx-updates-dev.links.in:
    - Add links for libOpenCL libGL.so, libAMDXvBA, libXvBAW.
  * debian/substvars:
    - Add support for X ABI 18 and 19.
  * debian/patches/series, amdxdg-su-add-support-for-pkexec.patch:
    - Leave the patch disabled for future reference and easier
      backporting.
  * debian/patches/call-amdcccle-with-full-path.diff:
    - Pass amdxdg the full path.
  * debian/dkms.conf.in,
    debian/dkms/patches/buildfix_kernel_3.15.patch,
    debian/dkms/patches/buildfix_kernel_3.17.patch,
    debian/dkms/patches/buildfix_kernel_3.19.patch:
    - Add support for Linux 3.15-3.19.
    - Leave the patches disabled for future reference and easier
      backporting.
    - Correct a typo that caused an incorrect dkms.conf to be
      generated from the template.
  * debian/71-fglrx.rules:
    - Tag the device for logind.

 -- Alberto Milone <email address hidden> Tue, 28 Apr 2015 17:13:24 +0200

Changed in fglrx-installer-updates (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.