LCD panel sometimes says "No signal" and is blank, the driver thinks it is active

Bug #1362326 reported by Václav Šmilauer on 2014-08-27
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
fglrx-installer-updates (Ubuntu)
Undecided
Unassigned

Bug Description

I have 3 LCD panels attached via straight DisplayPort cables (no daisy chaining, no DVI-DP converters and so on) to the FirePro V7900, which has 4 DisplayPort sockets.

One of the panels will often not come up when screens are DPMS-suspended (xset dpms force off, or by the screensaver). The panel will then say "No signal", but the card still thinks it is enabled and working (as verified in AMDCCCLE). It is sometimes possible make it work again by cycling a few times "xset dpms force off" and then pressing a key to turn screens on. It is always the same panel which has troubles, but it is port-bound (I tried exchaning the screens physically; it is the port numbered "3" in amdcccle, the other two being 1 and 2), not screen-bound. Sometimes the screen also just flickers, showing what it should only intermittently.

Restarting X fixes the issue (but terminates the session) most the time.

The open-source driver does not suffer from this issue at all.

The fglrx driver has had this issue since as long as I remember (2 or 3 years).

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: fglrx-updates 2:13.350.1-0ubuntu2
ProcVersionSignature: Ubuntu 3.13.0-30.55-generic 3.13.11.2
Uname: Linux 3.13.0-30-generic x86_64
NonfreeKernelModules: fglrx
.tmp.unity.support.test.0:

ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,compiztoolbox,resize,move,place,snap,gnomecompat,mousepoll,session,regex,wall,imgpng,grid,vpswitch,animation,expo,ezoom,workarounds,unitymtgrabhandles,fade,scale,unityshell]
CompositorRunning: None
CurrentDesktop: LXDE
Date: Wed Aug 27 22:42:24 2014
DistUpgraded: 2012-03-12 13:59:22,955 DEBUG icon theme changed, re-reading
DistroCodename: trusty
DistroVariant: ubuntu
GraphicsCard:
 Advanced Micro Devices, Inc. [AMD/ATI] Cayman PRO GL [FirePro V7900] [1002:6704] (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:2b0c]
MachineType: System manufacturer System Product Name
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-30-generic root=UUID=3cc5f6b9-69d1-4bb6-a9d0-93d506786ed9 ro nosplash radeon.dpm=1 nosplash radeon.dpm=1
SourcePackage: fglrx-installer-updates
UpgradeStatus: Upgraded to trusty on 2012-03-12 (898 days ago)
dmi.bios.date: 10/03/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0604
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: P9X79 DELUXE
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0604:bd10/03/2011:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP9X79DELUXE:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.11.1+14.04.20140701-0ubuntu1
version.fglrx-installer: fglrx-installer N/A
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.52-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.3-0ubuntu0.1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.1.3-0ubuntu0.1
version.xserver-xorg-core: xserver-xorg-core 2:1.15.1-0ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu3.1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A
xserver.bootTime: Wed Aug 27 22:39:56 2014
xserver.configfile: /etc/X11/xorg.conf
xserver.errors:
 AIGLX error: failed to open /usr/X11R6/lib64/modules/dri/fglrx_dri.so, error[/usr/X11R6/lib64/modules/dri/fglrx_dri.so: cannot open shared object file: No such file or directory]
 AIGLX error: failed to open /usr/lib64/dri/fglrx_dri.so, error[/usr/lib64/dri/fglrx_dri.so: cannot open shared object file: No such file or directory]
 AIGLX error: failed to open /usr/X11R6/lib/modules/dri/fglrx_dri.so, error[/usr/X11R6/lib/modules/dri/fglrx_dri.so: cannot open shared object file: No such file or directory]
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.15.1-0ubuntu2
xserver.video_driver: fglrx

Václav Šmilauer (eudoxos) wrote :
To post a comment you must log in.