fglrx-updates 2:13.350.1-0ubuntu2: fglrx-updates kernel module failed to build on 3.15 [/usr/sbin/dkms: line 73: cd: /var/lib/dkms/fglrx/13.350.1/build: No such file or directory]

Bug #1311838 reported by Neil Hearn on 2014-04-23
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
fglrx-installer-updates (Ubuntu)
Undecided
Unassigned

Bug Description

I was building linux kernel 3.15.0-rc2k8-highspeed-00036-gc089b22.
fglrx-updates crashed with:
-----------------------------------------------
run-parts: executing /etc/kernel/postinst.d/dkms 3.15.0-rc2k8-highspeed-00036-gc089b22 /boot/vmlinuz-3.15.0-rc2k8-highspeed-00036-gc089b22
Error! Bad return status for module build on kernel: 3.15.0-rc2k8-highspeed-00036-gc089b22 (x86_64)
Consult /var/lib/dkms/fglrx-updates/13.350.1/build/make.log for more information.
-----------------------------------------------

I am building AMD K8 optimized, 1000mhz clock for low latency.

Kernel appeared to build correctly - though I am yet to test. Will test and add additional data.

ProblemType: Package
DistroRelease: Ubuntu 14.04
Package: fglrx-updates 2:13.350.1-0ubuntu2
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
NonfreeKernelModules: fglrx
.tmp.unity.support.test.0:

ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
DKMSKernelVersion: 3.15.0-rc2k8-highspeed-00036-gc089b22
Date: Wed Apr 23 20:06:29 2014
DistUpgraded: 2014-04-18 21:35:33,730 DEBUG enabling apt cron job
DistroCodename: trusty
DistroVariant: ubuntu
DkmsStatus:
 fglrx-updates, 13.350.1, 3.12.8.Custom.1000Hz, x86_64: installed
 fglrx-updates, 13.350.1, 3.13.0-24-generic, x86_64: installed
 vboxhost, 4.3.10, 3.13.0-24-generic, x86_64: installed
 vboxhost, 4.3.10, 3.15.0-rc2k8-highspeed-00036-gc089b22, x86_64: built
GraphicsCard:
 Advanced Micro Devices, Inc. [AMD/ATI] Caicos [Radeon HD 6450/7450/8450 / R5 230 OEM] [1002:6779] (prog-if 00 [VGA controller])
   Subsystem: PC Partner Limited / Sapphire Technology Radeon HD 6450 1 GB DDR3 [174b:e164]
InstallationDate: Installed on 2013-07-29 (267 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MachineType: Gigabyte Technology Co., Ltd. GA-970A-UD3
PackageVersion: 2:13.350.1-0ubuntu2
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-24-generic root=UUID=6e2f8b71-26d6-4351-9172-98df64a44577 ro quiet splash nomodeset video=uvesafb:mode_option=1280x800x32,mtrr=3,scroll=ywrap vt.handoff=7
SourcePackage: fglrx-installer-updates
Title: fglrx-updates 2:13.350.1-0ubuntu2: fglrx-updates kernel module failed to build
UpgradeStatus: Upgraded to trusty on 2014-04-18 (4 days ago)
dmi.bios.date: 10/22/2012
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F7
dmi.board.name: GA-970A-UD3
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF7:bd10/22/2012:svnGigabyteTechnologyCo.,Ltd.:pnGA-970A-UD3:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-970A-UD3:rvr:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: GA-970A-UD3
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
version.compiz: compiz 1:0.9.11+14.04.20140409-0ubuntu1
version.fglrx-installer: fglrx-installer N/A
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.52-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.0-4ubuntu5
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.1.0-4ubuntu5
version.xserver-xorg-core: xserver-xorg-core 2:1.15.1-0ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu3
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Wed Apr 23 09:21:07 2014
xserver.configfile: default
xserver.devices:
 input Power Button KEYBOARD, id 6
 input Power Button KEYBOARD, id 7
 input Dell Dell USB Keyboard KEYBOARD, id 8
 input SIGMACHIP Usb Mouse MOUSE, id 9
xserver.errors:
 open /dev/dri/card0: No such file or directory
 AIGLX error: failed to open /usr/X11R6/lib64/modules/dri/fglrx_dri.so, error[/usr/X11R6/lib64/modules/dri/fglrx_dri.so: cannot open shared object file: No such file or directory]
 AIGLX error: failed to open /usr/lib64/dri/fglrx_dri.so, error[/usr/lib64/dri/fglrx_dri.so: cannot open shared object file: No such file or directory]
 AIGLX error: failed to open /usr/X11R6/lib/modules/dri/fglrx_dri.so, error[/usr/X11R6/lib/modules/dri/fglrx_dri.so: cannot open shared object file: No such file or directory]
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.15.1-0ubuntu2
xserver.video_driver: fglrx

Neil Hearn (nhearn) wrote :
summary: fglrx-updates 2:13.350.1-0ubuntu2: fglrx-updates kernel module failed to
- build on 3.15
+ build on 3.15 [/usr/sbin/dkms: line 73: cd:
+ /var/lib/dkms/fglrx/13.350.1/build: No such file or directory]
Neil Hearn (nhearn) wrote :

Upon reboot into new kernel:
lightdm login manager starts and all appears ok - no errors at all.
Then, once I input my password and click Log in > - nothing.
It takes me to the Unity desktop with nothing on it. No launcher bar, no background image not bar at the top.

It appears that FGLRX failed to build into the kernel and this causes my graphics card not to initialize the unity desktop.

Neil Hearn (nhearn) wrote :

Same error when trying to build on 3.14.1 stable branch.

Neil Hearn (nhearn) wrote :

Just built 3.13.11 successfully and a previous failed attempt with same error.

Easy fix: ran
#sudo apt-get -f install

This removed fglrx-updates and installed fglrx

A simple:
#sudo service lightdm restart
and everything came up perfectly.

I will now retry with 3.14.1

Neil Hearn (nhearn) wrote :

Just built 3.14.1.
Same error occured.

Traced it down to the dkms module of fglrx.
in /var/lib/dkms/fglrx/13.350.1/build/
I ran the make.sh script manually. As it was 'currently' in 3.11 kernel - it did not apply the patch 'buildfix_kernel_3.14.patch' as the patch looks to see if the 'current' kernel is >= 3.14. well it isn't, it's 3.11. thus no patch, thus failed build dkms module and no unity desktop......
I booted into 3.14.1 kernel Runlevel 3.
ran the same make.sh - it worked perfectly.
Then ran sudo dkms autoinstall.
then a quick sudo reboot - and all is well. fully functioning 3.14.1 kernel WITH unity Desktop.

In summary:
Boot to required kernek - Runlevel 3 (or no desktop login)
#cd /var/lib/dkms/fglrx/13.350.1/build/
#sudo ./make.sh
#sudo dkms autoinstall
#sudo reboot

I will next try this on 3.15.0rc2
But now....
sleep.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fglrx-installer-updates (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers