fglrx causes segmentation fault on boot

Bug #1267650 reported by a2r on 2014-01-10
48
This bug affects 8 people
Affects Status Importance Assigned to Milestone
fglrx
Unknown
Unknown
fglrx-installer-updates (Ubuntu)
Critical
Unassigned
Nominated for Trusty by Alberto Salvia Novella

Bug Description

With fglrx-updates installed Ubuntu 14.04 freezes while the bootscreen (shiny ubuntu logo). Can't get into TTY and have to turn the computer off with the powerbutton.

I'm on Ubuntu 14.04 freshly updated.
Graphics card is a Mobility Radeon 5650.

a2r (a2r) wrote :
a2r (a2r) on 2014-01-10
description: updated
papukaija (papukaija) on 2014-01-15
tags: added: trusty
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fglrx-installer-updates (Ubuntu):
status: New → Confirmed
Lukáš Chmela (lukaschmela) wrote :

I can confirm this behavior since fglrx 12.11 if I am right. The only exception was fglrx-updates package from Ubuntu 13.04 repository which I am using now (the fglrx package from the same repository causes system freeze like all the other versions do).

Relevant (unsolved) threads are probably:
http://ati.cchtml.com/show_bug.cgi?id=831
http://ubuntuforums.org/showthread.php?t=2200018

I have Acer Aspire 8943G notebook with AMD Mobility Radeon HD 5850 (Intel IGPU disabled in BIOS).

It renders the system temporarily or permanently unusable.

Changed in fglrx-installer-updates (Ubuntu):
importance: Undecided → Critical
Ge-org Brohammer (george97477) wrote :

Still causing my system to freeze at boot if I install this package.

Lukáš Chmela (lukaschmela) wrote :

Ge-org Brohammer have you also tried the new AMD Catalyst 14.6 beta from official AMD's webpage?

Ge-org Brohammer (george97477) wrote :

No, do I require any special installation instructions?

Lukáš Chmela (lukaschmela) wrote :

The installation is just about running:
chmod +x amd*
./amd* --buildpkg Ubuntu/trusty
sudo dpkg -i *.deb

But you would need to install some build dependencies (exact steps should be here: http://wiki.cchtml.com/index.php/Ubuntu_Trusty_Installation_Guide#Before_you_start). Anyway, I tested all the official AMD versions except the recently released 14.6 beta. None of them fixed the problem so I highly doubt this one will make any difference.

G (smiler2505) wrote :

Can confirm bug still exists in 14.6 on Ubuntu Trusty (clean install).

I've monitored this for a while and tried to find solutions but there is nothing I can find to help resolve it. Personally I have an Acer 8943G with HD 5850 gfx. From what I have seen/people posted, what is common to the bug is this (please post if you don't have this setup!):

Acer laptop
AMD Mobility HD 5*** chip

Acer do something 'special' with the graphics chips on their laptops, it was a pain setting up video on a hackintosh on my last two, and I think this is related to the issue we have, which requires AMD to come up with some workaround unfortunately. Posting my xorg.log too to confirm it is this problem with 'failed to open a CMMQS connection'.

G (smiler2505) wrote :

Would encourage people to fill out the response here to make AMD aware of the issue: http://www.amdsurveys.com/se.ashx?s=5A1E27D23CFE9B36

This is the thread on the unofficial bug reporting forum which AMD supposedly monitor, but the bug is still outstanding 1 year on, and I am keen to help resolve it, although it may require a couple of Acer systems to view and compare the issues.

Maciej (tofiszczak) wrote :

I have exacly the same problem... Freeze on Ubuntu logo after installing and reboot.
Installation with files from AMD website.

Got:
Asrock AM1H-ITX
Kabini Athlon 5350 with Radeon R3/HD 8400

Ubuntu 14.04 all updated
Catalyst 14.12 Omega (1 version earlier was affected too)

It is a nightmare...
Don't know what to do. This problem stops me from all the fun with 'non-server' part of my rig.
Help...

Richard Lam (dick-lam-1) wrote :

Hello everyone.

I have the exact same error too on my Acer 8950G with an AMD Radeon HD 6850M. Everything installs without any errors and when I reboot, Ubuntu logs a segmentation fault. I'm willing to help resolve this if possible too, since my laptop has two hard drives.

mb74 (mrb74) wrote :

I've exactly the same problem. Ubuntu 14.04 all updated. Tried fglrx, fglrx-updates an Catalyst 14.12 Omega from AMD homepage. All versions segfault on boot. Only the open source driver runs fine out of the box. But playing highend games with the open source driver is not possible. Performance too low :-(

My hardware: Lenovo G500 Core i5 and Radeon HD 8670A/8670M/8750M.
Please help!

Changed in fglrx-installer-updates (Ubuntu):
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.