Ubuntu

package fglrx-updates (not installed) failed to install/upgrade: subprocess installed post-removal script returned error exit status 1

Reported by Andrew Wasson on 2013-04-27
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
fglrx-installer-updates (Ubuntu)
Undecided
Unassigned

Bug Description

Updated Ubuntu to 13.04 and GUI doesn't really work anymore. My machine has ATI Radeon 3100 Graphics on AMD Athlon 64 X2

Have tried to downgrade graphics to fglrx-legacy but does not work.

ProblemType: Package
DistroRelease: Ubuntu 13.04
Package: fglrx-updates (not installed)
ProcVersionSignature: Ubuntu 3.8.0-19.29-generic 3.8.8
Uname: Linux 3.8.0-19-generic i686
NonfreeKernelModules: fglrx
.tmp.unity.support.test.0:

ApportVersion: 2.9.2-0ubuntu8
AptOrdering: fglrx-updates: Purge
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Fri Apr 26 11:33:58 2013
DistUpgraded: 2013-04-26 10:48:47,408 DEBUG enabling apt cron job
DistroCodename: raring
DistroVariant: ubuntu
DkmsStatus:
 fglrx, 8.97.100.7, 3.8.0-19-generic, i686: installed
 fglrx-legacy, 8.97.100.7, 3.8.0-19-generic, i686: installed (WARNING! Diff between built and installed module!)
DuplicateSignature:
 Purging configuration files for fglrx-updates ...
 update-initramfs: deferring update (trigger activated)
 update-rc.d: /etc/init.d/atieventsd exists during rc.d purge (use -f to force)
 dpkg: error processing fglrx-updates (--purge):
  subprocess installed post-removal script returned error exit status 1
ErrorMessage: subprocess installed post-removal script returned error exit status 1
GraphicsCard:
 Advanced Micro Devices [AMD] nee ATI RS780MC [Mobility Radeon HD 3100] [1002:9613] (prog-if 00 [VGA controller])
   Subsystem: Toshiba America Info Systems Device [1179:ff6a]
InstallationDate: Installed on 2012-05-12 (349 days ago)
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
JockeyStatus: kmod:fglrx - ATI Fire GL (Proprietary, Enabled, In use)
MachineType: TOSHIBA Satellite L300D
MarkForUpload: True
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-19-generic root=UUID=5491c378-470c-4194-b4b4-03f76b1aa14d ro quiet splash vt.handoff=7
SourcePackage: fglrx-installer-updates
Title: package fglrx-updates (not installed) failed to install/upgrade: subprocess installed post-removal script returned error exit status 1
UpgradeStatus: Upgraded to raring on 2013-04-26 (0 days ago)
dmi.bios.date: 11/24/2008
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: 1.40
dmi.board.asset.tag: No Asset Tag
dmi.board.name: Portable PC
dmi.board.vendor: TOSHIBA
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: AMD
dmi.chassis.version: None
dmi.modalias: dmi:bvnInsydeCorp.:bvr1.40:bd11/24/2008:svnTOSHIBA:pnSatelliteL300D:pvrPSLC8C-043019:rvnTOSHIBA:rnPortablePC:rvrBaseBoardVersion:cvnAMD:ct10:cvrNone:
dmi.product.name: Satellite L300D
dmi.product.version: PSLC8C-043019
dmi.sys.vendor: TOSHIBA
version.compiz: compiz 1:0.9.9~daily13.04.18.1~13.04-0ubuntu1
version.fglrx-installer: fglrx-installer N/A
version.libdrm2: libdrm2 2.4.43-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.1.1-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.1.1-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 3:1.12.4+git20121105-makson1~raring5
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 2:2.7.3+git20120928~quantal2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 2:7.1.0-makson1~raring2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 3:2.21.4-makson1~raring1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 2:1.0.6-makson1~raring1
xserver.bootTime: Fri Apr 26 17:13:05 2013
xserver.configfile: /etc/X11/xorg.conf
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 3:1.12.4+git20121105-makson1~raring5
xserver.video_driver: fglrx

Andrew Wasson (awasson) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fglrx-installer-updates (Ubuntu):
status: New → Confirmed
Luis Alvarado (luisalvarado) wrote :

I am having the same issue. In this case I have the following hardware:

Toshiba Satellite L505D-S5965

CPU - AMd Athlon Dual Core Ql-65

Ati Radeon HD 3100.

I also tried the PPA that downgraded X Server to install the fglrx-legacy package. No luck there.

I will update this with the corresponding apport collect information.

I have the same problem.
Toshiba Satellite M305-S4828
AMD / ATI RS780MC [Mobility Radeon HD 3100]
fglrx 13.1 intalled does not work
fglrx-legacy idem.

Cesar Mayo (cesarmayo77) wrote :

I am having the same issue. In this case I have the following hardware:

Toshiba Satellite L505D-S5965

CPU - AMd Athlon Dual Core Ql-65

Ati Radeon HD 3100.

I also tried the PPA that downgraded X Server to install the fglrx-legacy package. No luck there.

I will update this with the corresponding apport collect information.

To post a comment you must log in.