no unity displayed with fglrx-updates driver (multi GPU system)

Bug #1077422 reported by benste on 2012-11-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
fglrx-installer-updates (Ubuntu)
Undecided
Unassigned

Bug Description

booting into the system doesn't show unity - the fglrx-updates driver is probably not loaded successfully.

benste@benste-VPCSB3C5E:~$ fglrxinfo
X Error of failed request: BadRequest (invalid request code or no such operation)
  Major opcode of failed request: 154 (GLX)
  Minor opcode of failed request: 19 (X_GLXQueryServerString)
  Serial number of failed request: 12
  Current serial number in output stream: 12

AMDCCCLE shows that the driver is either not loaded or installed

lspci has got:
00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI Caicos [Radeon HD 6400M/7400M Series] [1002:6760] (prog-if 00 [VGA controller])

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: fglrx-updates 2:9.000-0ubuntu3
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
ApportVersion: 2.6.1-0ubuntu3
Architecture: amd64
Date: Sat Nov 10 18:58:37 2012
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: fglrx-installer-updates
UpgradeStatus: No upgrade log present (probably fresh install)

benste (benste) wrote :
benste (benste) wrote :
benste (benste) wrote :

btw. running sudo aticonfig --adapter=all --initial
results in a low graphics mode boot

Nick Kloski (nick-xrvasaslqcgx) wrote :

Since you have a hybrid Intel/AMD system, this bug is probably a duplicate of: https://bugs.launchpad.net/ubuntu/+source/fglrx-installer-updates/+bug/813809

benste (benste) wrote :

misteriously it's all working in the meantime

check
http://askubuntu.com/questions/205112/ubuntu-12-10-amd-intel-hybrid-graphics-not-working

and fix intel driver

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers