Add support for AMD Kaveri graphics chipsets

Bug #1272311 reported by Alberto Milone on 2014-01-24
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
fglrx-installer-experimental-13 (Ubuntu)
High
Alberto Milone
Precise
High
Alberto Milone
fglrx-pxpress (Ubuntu)
High
Alberto Milone
Precise
High
Alberto Milone
jockey (Ubuntu)
High
Alberto Milone
Precise
High
Alberto Milone

Bug Description

SRU request:

Please accept the following packages in precise-proposed.

fglrx-pxpress
jockey
fglrx-installer-experimental-13

[Rationale]
This is the result of the HWE effort to enable AMD Kaveri GPUs, and systems with more than one AMD GPU. This will become more common now that AMD APUs can be combined with AMD GPUs.

[Impact]
Without this work, AMD Kaveri GPUs won't work properly and users won't be able to make use of all the AMD GPUs in their system.

[Test Case]
After installing the update, users should be able to boot the system as usual, with no regressions of any kind.

* Systems with a single AMD card: there won't be any change except that Kaveri GPUs will be detected and will work properly.

* Systems with two or more AMD GPUs: fglrx-pxpress will try to enable all the available AMD GPUs and will also detect and reconfigure X when users remove one of the cards.

[Regression Potential]
Low. fglrx-installer-experimental-13 is not automatically installed, and fglrx-pxpress is installed only when dealing with a multi GPU system. Furthermore the change in Jockey is minimal, and only extends what we mean by hybrid graphics, so as to make sure that fglrx-pxpress is installed also when dealing with systems with multiple AMD GPUs.

tags: added: hwe
Changed in fglrx-installer-experimental-13 (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Alberto Milone (albertomilone)
Changed in fglrx-pxpress (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Alberto Milone (albertomilone)
Changed in jockey (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Alberto Milone (albertomilone)
Changed in jockey (Ubuntu Precise):
milestone: none → ubuntu-12.04.4
Changed in fglrx-pxpress (Ubuntu Precise):
milestone: none → ubuntu-12.04.4
Changed in fglrx-installer-experimental-13 (Ubuntu Precise):
milestone: none → ubuntu-12.04.4
Changed in jockey (Ubuntu Precise):
status: New → In Progress
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → High
Changed in fglrx-pxpress (Ubuntu Precise):
importance: Undecided → High
status: New → In Progress
assignee: nobody → Alberto Milone (albertomilone)
Changed in jockey (Ubuntu):
status: In Progress → Invalid
Changed in fglrx-installer-experimental-13 (Ubuntu Precise):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Alberto Milone (albertomilone)
Changed in fglrx-installer-experimental-13 (Ubuntu):
status: In Progress → Invalid
summary: - Add support for Kaveri chipsets
+ Add support for AMD Kaveri graphics chipsets
description: updated

Hello Alberto, or anyone else affected,

Accepted jockey into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/jockey/0.9.7-0ubuntu7.13 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in jockey (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Colin Watson (cjwatson) wrote :

Hello Alberto, or anyone else affected,

Accepted fglrx-installer-experimental-13 into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/fglrx-installer-experimental-13/2:13.300-0ubuntu0.0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in fglrx-installer-experimental-13 (Ubuntu Precise):
status: In Progress → Fix Committed
Colin Watson (cjwatson) wrote :

Hello Alberto, or anyone else affected,

Accepted fglrx-pxpress into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/fglrx-pxpress/0.6~hybrid0.0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in fglrx-pxpress (Ubuntu Precise):
status: In Progress → Fix Committed
Alberto Milone (albertomilone) wrote :

fglrx-experimental-13 builds and works correctly here:

:~$ dkms status
fglrx-experimental-13, 13.300, 3.11.0-15-generic, x86_64: installed

The driver is also correctly detected:

:~$ jockey-text --list
xorg:fglrx_experimental_13 - ATI/AMD proprietary FGLRX graphics driver (**experimental** beta) (Proprietary, Enabled, Not in use)

Note: it's marked as "Not in use" only because of a long standing bug in jockey which is definitely not a regression. It doesn't affect the functioning of the driver in any way.

fglrx-pxpress works correctly. I've tested the updates with one GPU, and with two GPUs. All the available GPUs are enabled on boot.

:~$ apt-cache policy fglrx-experimental-13
fglrx-experimental-13:
  Installed: 2:13.300-0ubuntu0.0.1
  Candidate: 2:13.300-0ubuntu0.0.1
  Version table:
 *** 2:13.300-0ubuntu0.0.1 0
        400 http://archive.ubuntu.com/ubuntu/ precise-proposed/restricted amd64 Packages
        100 /var/lib/dpkg/status
     2:13.101-0ubuntu0.0.2 0
        500 http://archive.ubuntu.com/ubuntu/ precise-updates/restricted amd64 Packages

:~$ apt-cache policy fglrx-pxpress
fglrx-pxpress:
  Installed: 0.6~hybrid0.0.1
  Candidate: 0.6~hybrid0.0.1
  Version table:
 *** 0.6~hybrid0.0.1 0
        400 http://archive.ubuntu.com/ubuntu/ precise-proposed/universe amd64 Packages
        100 /var/lib/dpkg/status
     0.3~hybrid0.0.1 0
        500 http://archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer-experimental-13 - 2:13.300-0ubuntu0.0.1

---------------
fglrx-installer-experimental-13 (2:13.300-0ubuntu0.0.1) precise-proposed; urgency=low

  * New upstream release (LP: #1272311):
    - Added support for the following products:
      AMD A10-7850K Desktop APU with AMD Radeon R7 Series graphics
      AMD A10-7700K Desktop APU with AMD Radeon R5 Series graphics
  * debian/fglrx.postinst.in:
    Select the discrete card on first installation on intel+amd.
  * debian/dkms.conf.in,
    debian/dkms/patches/buildfix_kernel_3.12.patch,
    debian/dkms/patches/buildfix_kernel_3.13.patch:
    - Add support for Linux 3.11-3.13 (LP: #1262238).
    - Drop replace_old_procfs_calls.patch.
  * debian/fglrx-experimental-13.dirs.in:
    - Add /usr/share/applications
  * debian/substvars:
    - Add support for X ABI 14 and xserver-xorg-core-lts-saucy.
 -- Alberto Milone <email address hidden> Fri, 24 Jan 2014 16:30:19 +0100

Changed in fglrx-installer-experimental-13 (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for fglrx-installer-experimental-13 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-pxpress - 0.6~hybrid0.0.1

---------------
fglrx-pxpress (0.6~hybrid0.0.1) precise-proposed; urgency=low

  * debian/control:
    - Build only for i386 and amd64.
  * debian/amd-config.conf:
    - Add upstart job to deal with configuration changes.
    - Add support for AMD+AMD configurations (LP: #1272311).
  * debian/postinst.in:
    - Deal with hexadecimal numbers properly.
    - Do not change anything if detection fails. It is
      possible to override laptop detection by creating an
      empty file in /etc/force-pxpress.
  * debian/postrm.in:
    - Remove /etc/last_boot_gfx on package removal.
 -- Alberto Milone <email address hidden> Fri, 24 Jan 2014 17:22:42 +0100

Changed in fglrx-pxpress (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.9.7-0ubuntu7.13

---------------
jockey (0.9.7-0ubuntu7.13) precise-proposed; urgency=low

  * jockey/xorg_driver.py, tests/hybridgraphics.py:
    - Add support for systems with two or more AMD GPUs.
      This is very useful now that AMD's APUs have been
      released (LP: #1272311).
    - Adjust the tests so that they no longer fail when
      dealing with systems with multiple AMD GPUs (now
      dealt with by the fglrx-pxpress package).

jockey (0.9.7-0ubuntu7.12) precise-proposed; urgency=low

  * data/handlers/nvidia.py:
    - Add support for nvidia-331 and nvidia-331-updates
      (LP: #1259237).
 -- Alberto Milone <email address hidden> Fri, 24 Jan 2014 17:09:25 +0100

Changed in jockey (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-pxpress - 0.6

---------------
fglrx-pxpress (0.6) trusty; urgency=low

  * debian/control:
    - Build only for i386 and amd64.
  * debian/amd-config.conf:
    - Add upstart job to deal with configuration changes.
    - Add support for AMD+AMD configurations (LP: #1272311).
  * debian/postinst.in:
    - Deal with hexadecimal numbers properly.
  * debian/postrm.in:
    - Remove /etc/last_boot_gfx on package removal.
 -- Alberto Milone <email address hidden> Fri, 24 Jan 2014 13:49:36 +0100

Changed in fglrx-pxpress (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers