Ubuntu

fftw3 version 3.2.2-1 failed to build on armel

Reported by Ricardo Salveti on 2011-09-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro GCC
Undecided
Unassigned
fftw3 (Ubuntu)
High
Canonical ARM Developers
Oneiric
High
Canonical ARM Developers
gcc-4.6 (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

fftw3 version 3.2.2-1 failed to build on armel
Link to failed build: https://launchpad.net/ubuntu/+archive/test-rebuild-20110819/+build/2723658

Direct link to the build log: https://launchpad.net/ubuntu/+archive/test-rebuild-20110819/+build/2723658/+files/buildlog_ubuntu-oneiric-armel.fftw3_3.2.2-1_FAILEDTOBUILD.txt.gz

This log snippet might be of interest, since it triggered the matcher 'Purging chroot-autobuild'.
Excerpt 4225 lines into the build log:

/tmp/ccw9Lj5U.s:2867: Error: invalid constant (1000) after fixup
make[6]: *** [r2cf_64.lo] Error 1
make[6]: Leaving directory `/build/buildd/fftw3-3.2.2/rdft/scalar/r2cf'
make[5]: *** [all] Error 2
make[5]: Leaving directory `/build/buildd/fftw3-3.2.2/rdft/scalar/r2cf'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/build/buildd/fftw3-3.2.2/rdft/scalar'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/build/buildd/fftw3-3.2.2/rdft'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/build/buildd/fftw3-3.2.2'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/build/buildd/fftw3-3.2.2'
make: *** [build-arch] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
******************************************************************************
Build finished at 20110821-0036
FAILED [dpkg-buildpackage died]
Purging chroot-autobuild/build/buildd/fftw3-3.2.2

Ricardo Salveti (rsalveti) wrote :

Log:
/bin/bash ../../../libtool --tag=CC --mode=compile gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I../../.. -I../../../kernel -I../../../rdft -I../../../rdft/scalar -g -Wall -O2 -pthread -MT r2cf_32.lo -MD -MP -MF .deps/r2cf_32.Tpo -c -o r2cf_32.lo r2cf_32.c
libtool: compile: gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I../../.. -I../../../kernel -I../../../rdft -I../../../rdft/scalar -g -Wall -O2 -pthread -MT r2cf_32.lo -MD -MP -MF .deps/r2cf_32.Tpo -c r2cf_32.c -fPIC -DPIC -o .libs/r2cf_32.o
libtool: compile: gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I../../.. -I../../../kernel -I../../../rdft -I../../../rdft/scalar -g -Wall -O2 -pthread -MT r2cf_32.lo -MD -MP -MF .deps/r2cf_32.Tpo -c r2cf_32.c -o r2cf_32.o >/dev/null 2>&1
mv -f .deps/r2cf_32.Tpo .deps/r2cf_32.Plo
/bin/bash ../../../libtool --tag=CC --mode=compile gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I../../.. -I../../../kernel -I../../../rdft -I../../../rdft/scalar -g -Wall -O2 -pthread -MT r2cf_64.lo -MD -MP -MF .deps/r2cf_64.Tpo -c -o r2cf_64.lo r2cf_64.c
libtool: compile: gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I../../.. -I../../../kernel -I../../../rdft -I../../../rdft/scalar -g -Wall -O2 -pthread -MT r2cf_64.lo -MD -MP -MF .deps/r2cf_64.Tpo -c r2cf_64.c -fPIC -DPIC -o .libs/r2cf_64.o
/tmp/ccw9Lj5U.s: Assembler messages:
/tmp/ccw9Lj5U.s:2867: Error: invalid constant (1000) after fixup

Changed in fftw3 (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Matthias Klose (doko) on 2011-09-10
tags: added: oneiric
Changed in fftw3 (Ubuntu Oneiric):
milestone: none → ubuntu-11.10-beta-2
assignee: nobody → Canonical ARM Developers (canonical-arm-dev)
Matthias Klose (doko) wrote :

works with -g -O1 -fPIC, fails with -g -O2 -fPIC

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fftw3 - 3.2.2-1ubuntu2

---------------
fftw3 (3.2.2-1ubuntu2) oneiric; urgency=low

  * Work around FTBFS on armel, build some files with -O1. LP: #841437.
 -- Matthias Klose <email address hidden> Sat, 10 Sep 2011 16:18:43 +0200

Changed in fftw3 (Ubuntu Oneiric):
status: Confirmed → Fix Released
Matthias Klose (doko) on 2011-09-10
Changed in fftw3 (Ubuntu Oneiric):
status: Fix Released → Confirmed
Michael Hope (michaelh1) wrote :

Thank you for the bug report. I can't reproduce this with gcc-linaro-4.6-2011.08 on Natty:

michaelh@ursa2:~/linaro/bugs$ /tools/toolchains/arch/armv7l/gcc-linaro-4.6-2011.08-armv7l-natty-cbuild162-ursa1-cortexa9r1/bin/gcc -g -O2 -fPIC -std=gnu99 -c r2cf_64.i

I've tried to reproduce the fault with and without the following options:
 * With and without -fstack-protector
 * With -mfpu=vfpv3-d16 vs -mfpu=neon
 * With and without -g
 * At -O1, -O2, -O3

Fortify shouldn't matter as this is preprocessed source.

I've also tried with:
 * gcc-4.5.3
 * gcc-4.6.1
 * gcc-4.7~svn178624
 * gcc-csl-2011.03-42
 * gcc-linaro-4.5-2011.08
 * gcc-linaro-4.6-2011.08
 * binutils_2.21.53.20110810-0ubuntu2 from oneiric

Could you investigate further please?

Changed in gcc-linaro:
status: New → Incomplete
Matthias Klose (doko) wrote :

did you check with -fPIC?

Michael Hope (michaelh1) wrote :

Yip, the command line is listed in the comment:

michaelh@ursa2:~/linaro/bugs$ /tools/toolchains/arch/armv7l/gcc-linaro-4.6-2011.08-armv7l-natty-cbuild162-ursa1-cortexa9r1/bin/gcc -g -O2 -fPIC -std=gnu99 -c r2cf_64.i

It includes -g, -O2, and -fPIC.

tags: added: rls-mgr-o-tracking
tags: removed: rls-mgr-o-tracking
Dave Walker (davewalker) on 2011-09-23
Changed in fftw3 (Ubuntu):
milestone: ubuntu-11.10-beta-2 → ubuntu-11.10
Matthias Klose (doko) wrote :

won't fix in oneiric

Changed in fftw3 (Ubuntu Oneiric):
milestone: ubuntu-11.10 → none
status: Confirmed → Won't Fix
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fftw3 - 3.2.2-1ubuntu3

---------------
fftw3 (3.2.2-1ubuntu3) precise; urgency=low

  * Revert the armel work-around. LP: #841437.
 -- Matthias Klose <email address hidden> Sat, 03 Dec 2011 19:23:51 +0100

Changed in fftw3 (Ubuntu):
status: Confirmed → Fix Released
Matthias Klose (doko) wrote :

not reproducible with gcc-4.6 in precise

Changed in gcc-4.6 (Ubuntu):
status: New → Invalid
Changed in gcc-4.6 (Ubuntu Oneiric):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers