[patch] maverick ffmpeg "Unknown input format: 'x11grab'"

Bug #631103 reported by Alan Pope 🍺🐧🐱 🦄 on 2010-09-05
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
ffmpeg (Debian)
Fix Released
Unknown
ffmpeg (Ubuntu)
Undecided
Unassigned
Nominated for Maverick by zzz

Bug Description

Binary package hint: ffmpeg

ffmpeg has an option '-x11grab' which enables it to record the desktop to a video file. This is commonly used by the community making screencasts on Ubuntu as it produces high quality video files with little computational overhead.

ffmpeg is compiled with the --enable-x11grab option enabled, but there appears to be a missing dependency on libxfixes-dev (in main) (see comment 3, below). As a result this feature which is compiled in is broken. It worked fine in Lucid, so this feature has regressed.

Adding the necessary dependency and rebuilding ffmpeg fixes the issue completely.

alan@hactar:~$ ffmpeg -f x11grab -r 25 -s 1392x1040 -i :0.0 -vcodec huffyuv -sameq
FFmpeg version 0.6-4:0.6-2ubuntu2, Copyright (c) 2000-2010 the FFmpeg developers
  built on Jul 12 2010 01:02:19 with gcc 4.4.4
  configuration: --extra-version=4:0.6-2ubuntu2 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-vaapi --enable-pthreads --enable-zlib --enable-libvpx --disable-stripping --enable-runtime-cpudetect --enable-gpl --enable-postproc --enable-x11grab --enable-libdc1394 --enable-shared --disable-static
  WARNING: library configuration mismatch
  libavutil configuration: --extra-version=4:0.6-2ubuntu1 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libdirac --enable-libgsm --enable-libopenjpeg --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-vaapi --enable-pthreads --enable-zlib --enable-libvpx --disable-stripping --enable-runtime-cpudetect --enable-libmp3lame --enable-gpl --enable-postproc --enable-x11grab --enable-libfaad --enable-libxvid --enable-libx264 --enable-librtmp --enable-libdc1394 --shlibdir=/usr/lib/i686/cmov --cpu=i686 --enable-shared --disable-static --disable-ffmpeg --disable-ffplay
  libavcodec configuration: --extra-version=4:0.6-2ubuntu1 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libdirac --enable-libgsm --enable-libopenjpeg --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-vaapi --enable-pthreads --enable-zlib --enable-libvpx --disable-stripping --enable-runtime-cpudetect --enable-libmp3lame --enable-gpl --enable-postproc --enable-x11grab --enable-libfaad --enable-libxvid --enable-libx264 --enable-librtmp --enable-libdc1394 --shlibdir=/usr/lib/i686/cmov --cpu=i686 --enable-shared --disable-static --disable-ffmpeg --disable-ffplay
  libavformat configuration: --extra-version=4:0.6-2ubuntu1 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libdirac --enable-libgsm --enable-libopenjpeg --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-vaapi --enable-pthreads --enable-zlib --enable-libvpx --disable-stripping --enable-runtime-cpudetect --enable-libmp3lame --enable-gpl --enable-postproc --enable-x11grab --enable-libfaad --enable-libxvid --enable-libx264 --enable-librtmp --enable-libdc1394 --shlibdir=/usr/lib/i686/cmov --cpu=i686 --enable-shared --disable-static --disable-ffmpeg --disable-ffplay
  libavdevice configuration: --extra-version=4:0.6-2ubuntu2 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-vaapi --enable-pthreads --enable-zlib --enable-libvpx --disable-stripping --enable-runtime-cpudetect --enable-gpl --enable-postproc --enable-x11grab --enable-libdc1394 --shlibdir=/usr/lib/i686/cmov --cpu=i686 --enable-shared --disable-static --disable-ffmpeg --disable-ffplay
  libavfilter configuration: --extra-version=4:0.6-2ubuntu2 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-vaapi --enable-pthreads --enable-zlib --enable-libvpx --disable-stripping --enable-runtime-cpudetect --enable-gpl --enable-postproc --enable-x11grab --enable-libdc1394 --shlibdir=/usr/lib/i686/cmov --cpu=i686 --enable-shared --disable-static --disable-ffmpeg --disable-ffplay
  libswscale configuration: --extra-version=4:0.6-2ubuntu1 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libdirac --enable-libgsm --enable-libopenjpeg --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-vaapi --enable-pthreads --enable-zlib --enable-libvpx --disable-stripping --enable-runtime-cpudetect --enable-libmp3lame --enable-gpl --enable-postproc --enable-x11grab --enable-libfaad --enable-libxvid --enable-libx264 --enable-librtmp --enable-libdc1394 --shlibdir=/usr/lib/i686/cmov --cpu=i686 --enable-shared --disable-static --disable-ffmpeg --disable-ffplay
  libpostproc configuration: --extra-version=4:0.6-2ubuntu1 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libdirac --enable-libgsm --enable-libopenjpeg --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-vaapi --enable-pthreads --enable-zlib --enable-libvpx --disable-stripping --enable-runtime-cpudetect --enable-libmp3lame --enable-gpl --enable-postproc --enable-x11grab --enable-libfaad --enable-libxvid --enable-libx264 --enable-librtmp --enable-libdc1394 --shlibdir=/usr/lib/i686/cmov --cpu=i686 --enable-shared --disable-static --disable-ffmpeg --disable-ffplay
  libavutil 50.15. 1 / 50.15. 1
  libavcodec 52.72. 2 / 52.72. 2
  libavformat 52.64. 2 / 52.64. 2
  libavdevice 52. 2. 0 / 52. 2. 0
  libavfilter 1.19. 0 / 1.19. 0
  libswscale 0.11. 0 / 0.11. 0
  libpostproc 51. 2. 0 / 51. 2. 0
Unknown input format: 'x11grab'

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: ffmpeg 4:0.6-2ubuntu2
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic i686
Architecture: i386
Date: Sun Sep 5 21:16:55 2010
EcryptfsInUse: Yes
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: ffmpeg

Andrew (and471) on 2010-09-06
Changed in ffmpeg (Ubuntu):
status: New → Confirmed
zzz (oldman-deactivatedaccount) wrote :

This is trivially fixed by adding the missing Build-Depends for libxfixes-dev to ffmpeg's debian/control

summary: - maverick ffmpeg "Unknown input format: 'x11grab'"
+ [patch] maverick ffmpeg "Unknown input format: 'x11grab'"
description: updated
tags: added: regression-potential
StefanPotyra (sistpoty) wrote :

ACK. (side note: we don't use non maintainer uploads, so you can just make it a ubuntu3 version instead of ubuntu2.1).

StefanPotyra (sistpoty) wrote :

ok, uploading as well. I've changed the version number and removed "Non-maintainer upload" from changelog, hope that's ok with you :).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ffmpeg - 4:0.6-2ubuntu3

---------------
ffmpeg (4:0.6-2ubuntu3) maverick; urgency=low

  * add libxfixes-dev to build-depends, LP: #631103
 -- Dominic Evans <email address hidden> Fri, 10 Sep 2010 14:21:23 +0100

Changed in ffmpeg (Ubuntu):
status: Confirmed → Fix Released
Merelin (merelin) wrote :

Fix wasn't released for lib*-extra* packages - they haven't been updated yet from 4:0.6-2ubuntu1.

StefanPotyra (sistpoty) wrote :

Good catch, thanks. I'll upload a fix for ffmpeg-extra in a minute.

Changed in ffmpeg (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.