ffmpeg should be installable from apt with x264/h264 support without users needing to recompile it

Bug #627976 reported by Rory McCann

This bug report was converted into a question: question #123613: ffmpeg should be installable from apt with x264/h264 support without users needing to recompile it.

This bug affects 1 person
Affects Status Importance Assigned to Milestone
ffmpeg (Ubuntu)
x264 (Ubuntu)

Bug Description

Binary package hint: ffmpeg

I believe the current version of ffmpeg and x264 in apt are missing a feature. Users are frequently advised to recompile ffmpeg & x264 from source if they want some features. There is even a popular guide on ubuntu forums for recompiling the software (http://ubuntuforums.org/showthread.php?t=786095). Users on the ffmpeg mailing list are pointed to this. The ubuntu wiki contains guides on how to 'fix' ffmpeg (https://help.ubuntu.com/community/iPodVideoEncoding#Fixing ffmpeg on Ubuntu)

If a guide starts with "First remove the packages from apt, then recompile", then there is something wrong with the packages in apt.

Both ffmpeg and x264 are packaged in ubuntu (http://packages.ubuntu.com/search?keywords=x264 and http://packages.ubuntu.com/search?keywords=ffmpeg). Is there not some way to make a package that users can install instead of requiring them to recompile software?

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: ffmpeg 4:0.5.1-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-24.41-generic
Uname: Linux 2.6.32-24-generic i686
Architecture: i386
Date: Wed Sep 1 11:20:47 2010
 PATH=(custom, user)
SourcePackage: ffmpeg

Revision history for this message
Rory McCann (rorymcc) wrote :
Revision history for this message
Reinhard Tartler (siretart) wrote :

the correct fix is to install the package 'ubuntu-restricted-extras', which will install 'libavcodec-extra-52' as dependency. This package is linked against libx264 and therefore capable to encode to h264.

Changed in x264 (Ubuntu):
status: New → Invalid
Changed in ffmpeg (Ubuntu):
status: New → Invalid
Revision history for this message
Rory McCann (rorymcc) wrote :

I installed the ubuntu-restricted-extras package, as you suggested, and I still have the same problem. I followed the ubuntu forums guide to recompile ffmpeg & x264 and that worked.

For the record the command I am trying to do:

ffmpeg -i './file.vob' -f mpegts -acodec libmp3lame -ar 48000 -ab 64000 -vcodec x264 -b 800000 -flags +loop -cmp +chroma -subq 5 -trellis 1 -refs 1 -coder 0 -me_range 16 -keyint_min 25 -sc_threshold 40 -i_qfactor 0.71 -bt 200k -maxrate 800000 -bufsize 800000 -rc_eq 'blurCplx^(1-qComp)' -qcomp 0.6 -qmin 10 -qmax 51 -qdiff 4 -level 30 -aspect 320:240 -g 30 -async 2 test.ts

and the (failing) output is:

FFmpeg version SVN-r24342, Copyright (c) 2000-2010 the FFmpeg developers
  built on Jul 20 2010 09:23:37 with gcc 4.4.1
  configuration: --prefix=/usr --enable-pthreads --enable-shared --extra-cflags=-fPIC --enable-gpl
  libavutil 50.22. 0 / 50.22. 0
  libavcodec 52.84. 0 / 52.84. 0
  libavformat 52.75. 0 / 52.75. 0
  libavdevice 52. 2. 0 / 52. 2. 0
  libavfilter 1.25. 1 / 1.25. 1
  libswscale 0.11. 0 / 0.11. 0
Input #0, mpeg, from './Lucozade - Dawn of the De-ad.vob':
  Duration: 00:00:39.53, start: 137.786967, bitrate: 8491 kb/s
    Stream #0.0[0x1e0]: Video: mpeg2video, yuv420p, 720x480 [PAR 8:9 DAR 4:3], 7000 kb/s, 29.97 fps, 29.97 tbr, 90k tbn, 59.94 tbc
    Stream #0.1[0xa0]: Audio: pcm_s16be, 48000 Hz, 2 channels, s16, 1536 kb/s
Unknown encoder 'x264'

I have tried the above command with "-vcodec libx264", "-vcodec h264" and "-vcodec libh264", all give the same error.

I am trying to make some files for HTTP Streaming as suggested here: http://www.ioncannon.net/programming/452/iphone-http-streaming-with-ffmpeg-and-an-open-source-segmenter/

In other words, installing ubuntu-restricted-extras does not fix the problem, removing the package and recompiling does fix the problem

Revision history for this message
Rory McCann (rorymcc) wrote :

The version of libavcodec-extra-52 is "4:0.5+svn20090706-2ubuntu3". I reported this bug on my lucid desktop (so I could use ubuntu-bug), however the server doing the encoding is karmic. ('ubuntu-restricted-extra' is at version 36).

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.