No audio in wmv-files: Cannot find codec for audio format 0x161

Bug #567913 reported by Vidar Hoel on 2010-04-21
94
This bug affects 19 people
Affects Status Importance Assigned to Milestone
ffmpeg (Ubuntu)
High
Marc Deslauriers

Bug Description

Binary package hint: ffmpeg

sitron@zero:/tmp$ lsb_release -rd
Description: Ubuntu 9.10
Release: 9.10

sitron@zero:/tmp$ uname -a
Linux zero 2.6.31-20-generic #58-Ubuntu SMP Fri Mar 12 04:38:19 UTC 2010 x86_64 GNU/Linux

I had the following packages installed:
ii libavcodec52 4:0.5+svn20090706-2ubuntu2
ii libavformat52 4:0.5+svn20090706-2ubuntu2

I could stream "mms://mms-icanal-odc.online.no/norsk-ripub/autodistribusjon/Himmelbl__11_04_10_600_627669_20100411_200800.wmv" and watch "http://samples.mplayerhq.hu/A-codecs/WMA2/nintendothemesacappellax.wmv" without problems and with sound.

Mplayer said:
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, s16le, 96.0 kbit/6.25% (ratio: 12000->192000)
Selected audio codec: [ffwmav2] afm: ffmpeg (DivX audio v2 (FFmpeg))
==========================================================================

I did a "sudo apt-get upgrade" and got the new files:
ii libavformat52 4:0.5+svn20090706-2ubuntu2.1
ii libavcodec52 4:0.5+svn20090706-2ubuntu2.1

Using the same two files mplayer will not play the sound:
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
[wmav2 @ 0x7f1ca512ca80]codec type or id mismatches
Could not open codec.
ADecoder init failed :(
ADecoder init failed :(
Requested audio codec family [wmadmo] (afm=dmo) not available.
Enable it at compilation.
Requested audio codec family [divx] (afm=acm) not available.
Enable it at compilation.
Cannot find codec for audio format 0x161.
Read DOCS/HTML/en/codecs.html!
Audio: no sound

The following packages was upgraded between it working and not:
libavcodec52 libavformat52 libavutil49 libdvdcss2 libpostproc51 libswscale0

Phong Pham (ptphong) wrote :

I also got into the exact same problem. mplayer could no longer played audio for wmv files after updates. Force downgrade to libavcodec52 4:0.5+svn20090706-2ubuntu2 and libavformat52 4:0.5+svn20090706-2ubuntu2 fixed it.

Igor Zemsky (izemsky) wrote :

The solution posted by Phong Pham works for me.

Marc Deslauriers (mdeslaur) wrote :

I can confirm the security update introduced this regression. I will release updates to fix this issue shortly.

Changed in ffmpeg (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Marc Deslauriers (mdeslaur)
ilf (ilf) wrote :

Any updates on "shortly"?

Also, shouldn't #567913 and #567682 be dupes of #567159? :)

Marc Deslauriers (mdeslaur) wrote :

I'll build packages today, and should be releasing them monday.

I marked the bugs in the "mplayer" package as dupes of the bug opened in the "ffmpeg" package.

HousieMousie2 (housiemousie2) wrote :

Prior to the "upgrade" I had used this code to convert MP4 to MP3:

ffmpeg -i Some-File.MP4 -vn -ar 44100 -ac 2 -ab 192 -f mp3 Some-File.mp3

And it worked perfectly, zero complaints.

Today, after last night's upgrade of only ffmpeg packages, it no longer works... I tried it again on the same file it had successfully converted yesterday... no joy.

This is the output (along with an empty file):

FFmpeg version SVN-rUNKNOWN, Copyright (c) 2000-2007 Fabrice Bellard, et al.
  configuration: --enable-gpl --enable-pp --enable-swscaler --enable-pthreads --enable-libvorbis --enable-libtheora --enable-libogg --enable-libgsm --enable-dc1394 --disable-debug --enable-shared --prefix=/usr
  libavutil version: 1d.49.3.0
  libavcodec version: 1d.51.38.0
  libavformat version: 1d.51.10.0
  built on Apr 8 2010 20:06:58, gcc: 4.2.4 (Ubuntu 4.2.4-1ubuntu3)
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'Some-File.MP4':
  Duration: 00:03:43.2, start: 0.000000, bitrate: 409 kb/s
  Stream #0.0(und): Audio: mp4a / 0x6134706D, 44100 Hz, stereo
  Stream #0.1(und): Video: h264, yuv420p, 320x240, 23.98 fps(r)
Output #0, mp3, to 'Some-File.mp3':
  Stream #0.0: Audio: 0x0000, 44100 Hz, stereo, 0 kb/s
Stream mapping:
  Stream #0.0 -> #0.0
Unsupported codec for output stream #0.0

Could this be related?

Hardy Heron, Kubuntu (KDE 3)

anuszka (ochab) wrote :

Same problem, no sound when streaming wmv video. It was OK a few days ago.

---------------------------------------

$ totem-xine mms://blabla.com/1.wmv

** (totem-xine:15927): WARNING **: Failed to create dbus proxy for org.gnome.SettingsDaemon: Could not get owner of name 'org.gnome.SettingsDaemon': no such name
[wmav2 @ 0xb509c6e8]codec type or id mismatches

----------------------------------------

$ vlc mms://blabla.com/1.wmv

VLC media player 0.8.6e Janus
[00000298] ts demuxer error: cannot peek
[00000345] access_mms access: selecting stream[0x1] audio (50 kb/s)
[00000345] access_mms access: selecting stream[0x2] video (397 kb/s)
[00000345] access_mms access: ignoring stream[0x3] video (201 kb/s)
[00000345] access_mms access: connection successful
[00000349] ffmpeg decoder error: cannot open codec (Windows Media Audio 2)
[00000349] main decoder error: no suitable decoder module for fourcc `wma2'.
VLC probably does not support this sound or video format.

----------------------------------------

$ lsb_release -rd
Description: Ubuntu 8.04.4 LTS
Release: 8.04

----------------------------------------

$ uname -a
Linux my_computer 2.6.24-27-generic #1 SMP Fri Mar 12 01:10:31 UTC 2010 i686 GNU/Linux

----------------------------------------

$ dpkg -l | grep ffmpeg
ii ffmpeg 3:0.cvs20070307-5ubuntu7.4 multimedia player, server and encoder
ii gstreamer0.10-ffmpeg 0.10.3-6 FFmpeg plugin for GStreamer
ii libavcodec1d 3:0.cvs20070307-5ubuntu7.4 ffmpeg codec library
ii libavformat1d 3:0.cvs20070307-5ubuntu7.4 ffmpeg file format library
ii libavutil1d 3:0.cvs20070307-5ubuntu7.4 ffmpeg utility library
ii libpostproc1d 3:0.cvs20070307-5ubuntu7.4 ffmpeg video postprocessing library
ii libswscale1d 3:0.cvs20070307-5ubuntu7.4 ffmpeg video scaling library
ii libxine1-ffmpeg 1.1.11.1-1ubuntu3.4 MPEG-related plugins for libxine1

----------------------------------------

$ dpkg -l | grep libav
ii libavc1394-0 0.5.3-1build1 control IEEE 1394 audio/video devices
ii libavcodec1d 3:0.cvs20070307-5ubuntu7.4 ffmpeg codec library
ii libavformat1d 3:0.cvs20070307-5ubuntu7.4 ffmpeg file format library
ii libavutil1d 3:0.cvs20070307-5ubuntu7.4 ffmpeg utility library

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ffmpeg - 4:0.5+svn20090706-2ubuntu2.2

---------------
ffmpeg (4:0.5+svn20090706-2ubuntu2.2) karmic-security; urgency=low

  * debian/patches/CVE-2009-46XX/security-issue22.patch: removed this
    patch as it was causing a regression. (LP: #567913)
 -- Marc Deslauriers <email address hidden> Fri, 23 Apr 2010 08:11:04 -0400

Changed in ffmpeg (Ubuntu):
status: Confirmed → Fix Released
Phil42 (pwl42) wrote :

how should an end user install this package in 64bit hardy ?

Phil42 (pwl42) wrote :

apt-get update; apt-get install libavcodec1d seems to have worked

anuszka (ochab) wrote :

It works after the update. Thanks a lot!

PetrB (petr-bug) wrote :

Marc Deslauriers: It is better to have a secure system than a compromised system with WMV+sound. In general reverting a security fix because of functionality regression is insane.
I trust you had some reason, for example:
- the original CVE-2009-46XX/security-issue22.patch in fact did not fix security bug (or any bug) or
- the security bug is unlikely to be exploitable or
- the bug is not exploitable if patches 01 to 21 remain applied or
- the code is exploitable but it runs in sandbox therefore no real harm is done

I suggest putting a rationale in an update next time.

For those interested the patch is
http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/karmic/ffmpeg/karmic-security/revision/39
(Launchpad unfortunately does not link commits to bugs.)

Marc Deslauriers (mdeslaur) wrote :

@PetrB:

This patch was removed as it shouldn't have been included in the first place. Upstream had never applied those commits to the 0.5.x branch, and the issue couldn't be reproduced.

I have personally tried the example multimedia file that demonstrated the original issue on the ffmpeg 0.5.x branch, and could not reproduce the issue either, therefore this patch was unnecessary, didn't affect security, and simply introduced the regression.

Changed in ffmpeg (Ubuntu):
assignee: Marc Deslauriers (mdeslaur) → kyawswarwai (kyawswarwai)
Changed in ffmpeg (Ubuntu):
assignee: kyawswarwai (kyawswarwai) → Marc Deslauriers (mdeslaur)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers