avcodec.c in libavcodec-dev doesn't working.

Bug #557319 reported by benoît tuduri on 2010-04-07
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ffmpeg (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: libavcodec-dev

My distibution is a karmic koala x86 version.

I tried to compile the apiexample.c bundled with libavcodec-dev package but i doesn't work due to an incorrect source inclusion. Moreover, the api avcodec_decode_avi seems replaced by avcodec_codec_audio2.
You will can found a patch for it in attachment.
The recent version of ffmpeg solved this bugs but not in git.debian.org snapshot.

Sincerly,

Benoît

Related branches

benoît tuduri (benoit2009) wrote :
Reinhard Tartler (siretart) wrote :

close, we need to backport svn revisions r18176 and r20176

Changed in ffmpeg (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ffmpeg - 4:0.6-1ubuntu1

---------------
ffmpeg (4:0.6-1ubuntu1) maverick; urgency=low

  * merge from debian/experimental. remaining changes:
    - don't disable encoders
    - don't build against libfaad, libdirac and libopenjpeg (all in universe)
  * new upstream release
    - internal vorbis encoder is disabled. LP: #585330
    - includes native AMR-NB decoder, LP: #93849
    - api-example is fixed: LP: #557319

ffmpeg (4:0.6-1) experimental; urgency=low

  * new upstream release
    - adds VP8 support via libvpx, Closes: #582274
  * depend on libavfilter-extra-1 instead of -0, Closes: #583728
  * add conflicts to the ffprobe package, it has been merged upstream now
 -- Reinhard Tartler <email address hidden> Wed, 16 Jun 2010 12:53:24 +0200

Changed in ffmpeg (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers