Comment 1 for bug 522812

Reinhard Tartler (siretart) wrote :

this bug as such is invalid, as I have theora material on my laptop that plays just fine with ubuntu's ffplay.

as for avcodec_decode_video2, yes, it was added by this commit:

------------------------------------------------------------------------
r18351 | rbultje | 2009-04-07 17:59:50 +0200 (Di, 07. Apr 2009) | 9 Zeilen

Implement avcodec_decode_video2(), _audio3() and _subtitle2() which takes an
AVPacket argument rather than a const uint8_t *buf + int buf_size. This allows
passing of packet-specific flags from demuxer to decoder, such as the keyframe
flag, which appears necessary to playback corePNG P-frames.

Patch by Thilo Borgmann thilo.borgmann googlemail com, see also the thread
"Google Summer of Code participation" on the mailinglist.
-----------------------------------------------------------------------

it will be included in ffmpeg 0.6, but lucid will got with ffmpeg 0.5.

as ffplay does work just fine, I'm marking this bug as invalid for ubuntu. It might be valid for upstream, though. Please discuss it there, this issue should be fixed there (e.g. in the 0.5 release branch) anyways.