Unable to play video from "Youtube plugin" results

Bug #459423 reported by Jean-Philippe Fleury on 2009-10-23
596
This bug affects 128 people
Affects Status Importance Assigned to Milestone
GStreamer
Unknown
Unknown
Totem
Fix Released
High
ffmpeg (Ubuntu)
Medium
Unassigned
Jaunty
Undecided
Unassigned
Karmic
Wishlist
Unassigned
totem (Ubuntu)
Medium
allan ottley
Jaunty
Undecided
Unassigned
Karmic
Medium
Unassigned

Bug Description

Binary package hint: totem

With Totem 2.28.1, GStreamer 0.10.25 and Ubuntu 9.10, I'm not able to play video from Youtube plugin results. I can search and see results thumbnails, but if I click on a thumbnail to play the corresponding video, Totem displays an error:

>Une erreur est survenue
>GStreamer a rencontré une erreur générale de bibliothèque de prise en charge.

ProblemType: Bug
Architecture: i386
Date: Fri Oct 23 17:16:55 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/totem
Package: totem 2.28.1-0ubuntu4
ProcEnviron:
 LANGUAGE=fr_CA.UTF-8
 LANG=fr_CA.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.46-generic
SourcePackage: totem
Uname: Linux 2.6.31-14-generic i686

Jean-Philippe Fleury (jpfle) wrote :
Jason Brooks (jasonbrooks) wrote :

I can confirm this bug. On my ubuntu 9.10 x86-64 machine (in english) the error is: GStreamer encountered a general supporting library error.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

affects: totem (Ubuntu) → gstreamer0.10 (Ubuntu)
Changed in gstreamer0.10 (Ubuntu):
importance: Undecided → Medium
Sebastien Bacher (seb128) wrote :

the bug seems similar to bug #438203

manzur (sl-solaris) wrote :

They seems similar, but Please fix them, we aare almos final release

Arc "warthog" Riley (arcriley) wrote :

To stderr:

** Message: Error: GStreamer encountered a general supporting library error.
gstffmpegdemux.c(1243): gst_ffmpegdemux_open (): /GstPlayBin2:play/GstURIDecodeBin:uridecodebin0/GstDecodeBin2:decodebin20/ffdemux_swf:ffdemux_swf0:
Input/output error

Sebastien Bacher (seb128) wrote :

The issue seems a popular one, Robert could you have a look?

Changed in gstreamer0.10 (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
Robert Ancell (robert-ancell) wrote :

Confirmed, haven't found any clues yet though

Kai Jauch (kaijauch) wrote :

According to the output of totem --gst-debug=2, it tries to use ffmpeg to decode the video file (youtube (now?) uses compressed swf). ffmpeg apparently doesn't support compressed swf files directly, they first have to be decompressed by cws2fws.

The think can be more trivial.

** (totem:28137): WARNING **: Couldn't find the t param of entry (null) or its FLV URI.

see: https://bugs.launchpad.net/ubuntu/+source/totem/+bug/416359/comments/8
and: https://bugs.launchpad.net/ubuntu/+source/totem/+bug/323649/comments/10

but that patch does not work because youtube plugin is now il C.

Robert Ancell (robert-ancell) wrote :

Confirming, it is ffmpeg that cannot decode compressed flash video:
http://git.ffmpeg.org/?p=ffmpeg;a=blob;f=libavformat/swfdec.c

affects: gstreamer0.10 (Ubuntu) → ffmpeg (Ubuntu)
Changed in totem (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Samuel (samuel-user) wrote :

I have some problem too.

Samuel (samuel-user) wrote :

I have the same problem.
I am sorry I do not speak English ;)

Brian O'Keefe (okeefe) wrote :

Same problem on Ubuntu 9.10 x86-64

walross (blender-walross) wrote :

same problem in german:
Internet GStreamer-Fehler: Problem mit der Unterstützungsbibliothek. Bitte schicken Sie einen Fehlerbericht.

Kendrick Eastes (keastes) wrote :

errors state that this is a problem in gstreamer, i have fmpeg installed on my system (ubuntu 9.10 i386) and totem does not use it goes to search for suitable plugins and gstreamer0.10-ffmpeg is all that is found. at this point all i can think of is to find a way to force totem to use ffmpg and not gstreamer and see if that fixes it. one moment and i will attach screen shots

Kendrick Eastes (keastes) wrote :

cant get totem to open find plugin dialog box will get that next reboot.

Samuel (samuel-user) wrote :

totem.log

Nicola Jelmorini (jelmorini) wrote :

Same problem here. Ubuntu 9.10 32 bit

Message in the terminal:

romeo@romeo-laptop:~$ totem
** Message: Error: GStreamer ha incontrato un errore generale nelle librerie di supporto.
gstffmpegdemux.c(1243): gst_ffmpegdemux_open (): /GstPlayBin2:play/GstURIDecodeBin:uridecodebin0/GstDecodeBin2:decodebin20/ffdemux_swf:ffdemux_swf0:
Input/output error

Changed in ffmpeg (Ubuntu):
status: New → In Progress
Robert Ancell (robert-ancell) wrote :

Testing in Ubuntu 9.04 shows the same problem - it appears that YouTube has changed their API.

Robert Ancell (robert-ancell) wrote :

Not a gstreamer bug - gstreamer is correctly passing the data to ffmpeg which says it can handle this type of file and then returns an error when it tries to decode it. Unfortunately the error between ffmpeg and gstreamer is very vague.

Changed in gstreamer:
status: New → Invalid

Mexico here, the same problem
gstffmpegdemux.c(1243): gst_ffmpegdemux_open (): /GstPlayBin2:play/GstURIDecodeBin:uridecodebin0/GstDecodeBin2:decodebin20/ffdemux_swf:ffdemux_swf0:
Input/output error

Ans my FF it dosen't play flash T_T

If youre Firefox does not play flash it means there's probably no flash
plugin installed. Please check install software this bug is particular
to movie player.

On Mon, 2009-11-02 at 14:16 +0000, mauricio288 wrote:
> Mexico here, the same problem
> gstffmpegdemux.c(1243): gst_ffmpegdemux_open (): /GstPlayBin2:play/GstURIDecodeBin:uridecodebin0/GstDecodeBin2:decodebin20/ffdemux_swf:ffdemux_swf0:
> Input/output error
>
> Ans my FF it dosen't play flash T_T
>

Jim Braux-Zin (j-brauxzin) wrote :

I can confirm this issue on my up to date 9.10. It seems to me that it would be better not to ship this feature if it is broken. I am not expecting the default video player to allow me to search and play videos on Youtube and I don't think a lot of people would miss this feature. On the other hand, seeing this feature in Totem makes you willing to try and then makes you frustrated and upset.

Sebastien Bacher (seb128) wrote :

> It seems to me that it would be better not to ship this feature if it is broken.

right but the feature was working before the server side changed and it took a while to notice the change and that the issue was due to a server change

Krešo Kunjas (deresh) wrote :

there is a fix in upstream git master commited today. i have patched ubuntu totem with it and now it works. more details on upstream bugzilla.

Brian O'Keefe (okeefe) wrote :

How do I get and apply the patch?

Mark Cariaga (mzc) wrote :

I assume the fix would be available through update manager when its ready...

Kendrick Eastes (keastes) wrote :

as i understand it, it needs to be marked as stable,

@Krešo Kunjas where is the patch?

deader69 (deader69) wrote :

Also just noticed that videos now don't play in YouTube, after two rounds of codec downloads for Totem.
Don't know how to create a new bug thread (1st day using Ubuntu!).

Sorry, can someone help me post that to the appropriate thread?
Totem drivers possibly break Flash plugin for Firefox.

Will reboot, reinstall Flash plugin.

Changed in ffmpeg (Ubuntu):
status: In Progress → Invalid
assignee: Robert Ancell (robert-ancell) → nobody
Krešo Kunjas (deresh) wrote :

@Kendrick Eastes:

http://git.gnome.org/cgit/totem/commit/?id=95b56216aee80c7e95d0e7d033ff8e1a63852813

i have tried to build a patched totem version in my ppa and misserable failed ( i dont have any experience with ppa ), but i can post a link to patched totem-plugins package if you would like ( i have only amd64 build)

Brian O'Keefe (okeefe) wrote :

Please do post the link

Martin-Éric Racine (q-funk) wrote :

Added the above patch and uploaded to my PPA. Please test it and report whether this fixes the issue for you or not.

2 comments hidden view all 114 comments
Sebastien Bacher (seb128) wrote :
Changed in totem (Ubuntu Karmic):
assignee: nobody → Robert Ancell (robert-ancell)
importance: Undecided → Medium
status: New → Fix Committed
hjthernandez (hjthernandez) wrote :

i'm getting the same issue with the you tube plugin in totem, pls update on how to resolve the issue

tia!

Santi (santiblanco) wrote :

@Martin-Éric Racine:

There is no i386 build in your PPA, if you build it I will try if it works.

hjthernandez (hjthernandez) wrote :

tested the PPA but to no avail. totem hangs for a few seconds then error popped up:

GStreamer encountered a general supporting library error

Changed in ffmpeg (Ubuntu Karmic):
importance: Undecided → Wishlist
status: New → Invalid
Martin Pitt (pitti) on 2009-11-05
Changed in totem (Ubuntu):
status: Triaged → Fix Committed
tags: added: verification-needed
Changed in totem (Ubuntu Karmic):
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2009-11-05
Changed in totem (Ubuntu):
status: Fix Committed → Fix Released
Changed in totem (Ubuntu Karmic):
status: Fix Released → Fix Committed
Martin Pitt (pitti) on 2009-11-05
tags: added: verification-done
removed: verification-needed
robert (raweinstein) on 2009-11-05
Changed in totem (Ubuntu Karmic):
status: Fix Committed → Fix Released
Changed in totem:
importance: Unknown → Undecided
status: Unknown → New
status: New → Fix Released
robert (raweinstein) on 2009-11-05
Changed in totem (Ubuntu):
status: Fix Released → Fix Committed
Martin Pitt (pitti) on 2009-11-05
Changed in totem (Ubuntu Karmic):
status: Fix Released → Fix Committed
Changed in totem (Ubuntu):
status: Fix Committed → Fix Released
Changed in totem:
status: Fix Released → In Progress
Changed in totem (Ubuntu):
status: Fix Released → Fix Committed
John Dong (jdong) on 2009-11-08
Changed in ffmpeg (Ubuntu Jaunty):
status: New → Invalid
Martin Pitt (pitti) on 2009-11-09
Changed in totem (Ubuntu Jaunty):
status: New → In Progress
Martin Pitt (pitti) on 2009-11-11
Changed in totem (Ubuntu Jaunty):
status: In Progress → Fix Committed
tags: added: verification-needed
Shafeeq.mp (saffeeqmp) on 2009-11-12
Changed in totem (Ubuntu):
status: Fix Committed → In Progress
Changed in totem (Ubuntu):
status: In Progress → Fix Committed
34 comments hidden view all 114 comments
Saivann Carignan (oxmosys) wrote :

Isn't there anyone else to test the jaunty fix?

Jean Levasseur : Can you always reproduce this issue? And if yes, do you have some steps for us so we can verify if this bug has been introduced by my patch or not? In my case, the fix worked correctly each time I tried it.

Mark Cariaga (mzc) wrote :

Youtube results can now be view but errors appear on some results, see snapshot.

I just tested 2.28.2 from karmic-proposed

Adi Roiban (adiroiban) wrote :

I have tested the karmic-proposed and I got the same error as mzc .

After closing all the error windows, I was able to play the first movie, but that was all.
Further videos are not opened

Saïvann Carignan: Totem is crashing with segfault whenever I double-click on a Youtube result. As well, Trying to open an .ISO (movie) file makes totem crash with segfault as well. As said previously, I don't have access to debugging symbols so having a useful traceback is not quite possible, but for me the -proposed version does not work at all at the moment.

Changed in totem (Ubuntu Karmic):
status: Fix Committed → Confirmed
status: Confirmed → Incomplete
Changed in totem (Ubuntu Karmic):
status: Incomplete → Fix Committed
Gigi (gigi33) wrote :

I've got the same problem as Jean Levasseur (#74).

Segfault on trying to play a video. Sometimes when trying to search, totem segfaults too.

Package: totem
Architecture: amd64
Version: 2.28.2-0ubuntu3
lsb-release: karmic

Saivann Carignan (oxmosys) wrote :

I was able to reproduce the problem reported by Gigi and Jean Levasseur with totem up-to-date and totem-common not updated. The problem goes away when updating totem-common. Therefore, is it possible to have your feedback again with totem and totem-common up to date?

Also all tests were done on the karmic package only, isn't there anyone to test the jaunty fix? I confirm that in my case, the jaunty fix works great here, no matter what video I try to play. However, I'm not playing youtube videos very often.

Martin-Éric Racine (q-funk) wrote :

This seems to indicate that Totem components need to have versioned depends, to ensure that they always pull the latest totem-common.

Saivann Carignan (oxmosys) wrote :

Indeed! Reported as bug 483380. Thanks.

Gigi (gigi33) wrote :

After updating totem and totem-common to 2.28.2-0ubuntu3, totem freezes after start. It goes dark when I click anywhere in totem (see screenshots). After quite a long time, totem goes bright again but does not respond. It goes dark again as soon as I click.

I don't get any debug output in the console. Running totem with --debug does not change anything.

Package: totem, totem-common
Architecture: i386
Version: 2.28.2-0ubuntu3
lsb-release: karmic

(I'm on a different system now [ASUS EEE 1000h])

taka khumbartha (scar) wrote :

i tested the fix on jaunty 9.04 by enabling jaunty-proposed in the software sources. there were 28 updates available but i only updated five totem* packages. i can now watch you tube videos in totem.

Martin Pitt (pitti) on 2009-11-17
tags: removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package totem - 2.26.1-0ubuntu5.1

---------------
totem (2.26.1-0ubuntu5.1) jaunty-proposed; urgency=low

  * debian/patches/06_youtube_regex.patch:
    - Update regex to make youtube plugin work again. (LP: #459423)
 -- Saivann Carignan <email address hidden> Sat, 07 Nov 2009 22:56:45 -0500

Changed in totem (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package totem - 2.28.2-0ubuntu3

---------------
totem (2.28.2-0ubuntu3) karmic-proposed; urgency=low

  * debian/patches/07_disable_web_browser_midi.patch:
    - Disable MIDI support in totem web browser plugin as Karmic's gstreamer
      doesn't support streaming MIDI files over HTTP (LP: #463102)

totem (2.28.2-0ubuntu2) karmic-proposed; urgency=low

  * debian/patches/05_youtube_regex.patch:
    - Fix YouTube plugin (LP: #459423)
  * debian/patches/06_playlist.patch:
    - Start from beginning when switching to next video in playlist
      (LP: #466620)

totem (2.28.2-0ubuntu1) karmic-proposed; urgency=low

  * New upstream release: (LP: #463102)
    - Movie Player:
      - Fix possible crash on exit when using Python plugins
      - Fix warning when displaying file tooltip in the playlist
      - Fix help links not showing up in error messages (LP: #452510)
      - Fix "disabling screensaver when audio is playing" checkbox
        never turning off (or on)
      - Fix play order when removing currently playing song
    - Web browser plugin:
      - Fix screensaver not being stopped when playing movies (LP: #358297)
        (LP: #381116)
      - Fix parsing of playlist files when using WebKit
      - Add support for midi files
    - GStreamer backend:
      - Fix possible hang on startup
      - Fix DVB channels file not being detected properly
      - Fix warning when creating a screenshot
      - Use cubic volumes when PulseAudio is used
      - Fix intermittent pixel-aspect-ratio warnings
  * debian/patches/03_screensaver_preferences.patch:
  * debian/patches/71_totem_python_gil.patch:
  * debian/patches/91_git_change_fix_dvb_issue.patch:
    - Applied upstream
 -- Robert Ancell <email address hidden> Wed, 11 Nov 2009 09:47:30 +0100

Changed in totem (Ubuntu Karmic):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

copied to lucid

Changed in totem (Ubuntu):
status: Fix Committed → Fix Released
gbachot (geert-bachot) wrote :

After enabling jaunty-proposed in the software sources, it works here, too. After two apt-get update/upgrades, that is. But I cannot tell if it is by the fix, or by the enabled sources. Anyhow, if it works, it works.

vijay1218 (vijay1218) on 2009-11-19
Changed in totem (Ubuntu):
assignee: nobody → vijay1218 (vijay1218)
status: Fix Released → Fix Committed
Steve Langasek (vorlon) on 2009-11-19
Changed in totem (Ubuntu):
assignee: vijay1218 (vijay1218) → nobody
status: Fix Committed → Fix Released
Jean-Philippe Fleury (jpfle) wrote :

I updated Totem on Karmic with proposed repository, but I still have a bug with search. If my search string has only ascii characters, it's ok (I see results and I can display videos), but if my search string contains non-ascii characters, the search seems to loop infinitely and I never see results.

To reproduce the bug, make this search in the Youtube plugin search field:

chaplin la ruée vers l'or

We never see any results. Now change the search string to:

chaplin la ruee vers l'or

and we immediately see results.

Saivann Carignan (oxmosys) wrote :

I confirm Jean-Philippe comment, however this issue is not caused by the recent fix, therefore it should be reported as a seperate bug report.

Jean-Philippe Fleury (jpfle) wrote :

Saïvann Carignan wrote:
> I confirm Jean-Philippe comment, however this issue is not caused by
> the recent fix, therefore it should be reported as a seperate bug report.

Done: https://bugzilla.gnome.org/show_bug.cgi?id=602497

Saivann Carignan (oxmosys) wrote :

Thanks for reporting the bug!

Changed in totem:
importance: Undecided → Unknown
status: In Progress → Unknown
Changed in totem (Ubuntu Karmic):
assignee: Robert Ancell (robert-ancell) → nobody
loiqs (quachsyloi) on 2010-04-04
Changed in gstreamer:
status: Invalid → Fix Released
SimonP (peeters-simon) wrote :

ok, it might be stupid but the bug is back: (but not for all video's)

ubuntu 10.4 beta1 (up-to date)
gstreamer0.10-ffmpeg-0.10.10-1
totem-2.30.0-ubuntu2
totem-plugins-2.30.0-ubuntu2

details:

totem --gst-debug=2

go to youtube
search: "the matrix soundtrack"
open one of the video's
most of the video's result in a

0:25:40.687357120 19325 0xb4709340 ERROR ffmpeg :0:: Compressed SWF format not supported

while some others play (via qtdemux instead of ffmpeg?) according to

0:25:54.883486039 19325 0x957d8d8 WARN qtdemux qtdemux_types.c:170:qtdemux_type_get: unknown QuickTime node type iods

would be nice if this could be fixed before the release (then i can continue convincing people of installing ubuntu)

simon

SimonP (peeters-simon) wrote :

found out the difference between the video's

the working video's have a video uri in the form of:
   http://www.youtube.com/get_video?video_id=NNaPidghdzM&t=vjVQa1PpcFOa3F2uNEZhSQxx8dl1YNsF1IrqJuip_X8%3D&fmt=18
while the broken ones have one like this:
   http://www.youtube.com/v/BNvjXx1hl60?f=videos&c=ytapi-GNOME-Totem-444fubtt-1&d=Aa_GPZt8t1WjXJl-QnyunkwO88HsQjpE1a8d1GxQnGDm&app=youtube_gdata

the first one results in a normal video file being returned
while the second one results in the youtube media player (swf file) being returned

unfortunatly
   http://www.youtube.com/get_video?video_id=BNvjXx1hl60&t=Aa_GPZt8t1WjXJl-QnyunkwO88HsQjpE1a8d1GxQnGDm&fmt=18
does not work

one last note youtube-dl was able to download the file but opening the link probided by youtube-dl -g in chrome did result in a 403

SimonP (peeters-simon) wrote :

some more research done:

according to http://gdata.youtube.com/feeds/api/videos/BNvjXx1hl60

the correct video url's are:

rtsp://v7.cache6.c.youtube.com/CiILENy73wIaGQmtl2EdX-PbBBMYDSANFEgGUgZ2aWRlb3MM/0/0/0/video.3gp
rtsp://v8.cache8.c.youtube.com/CiILENy73wIaGQmtl2EdX-PbBBMYESARFEgGUgZ2aWRlb3MM/0/0/0/video.3gp

which both play without any problems in totem so it's neither gstreamer, ffmpeg or totem(base) but totem-plugins which does not use the youtube/gdata api correctly

Brian O'Keefe (okeefe) wrote :

I tried the rtsp url's and get this error:

No supported stream was found. You might be missing the right GStreamer RTSP extension plugin.

I installed anything that referred to RTSP when i first got the error and retried. Same error.

Guys I have uninstalled UBUNTU cos I was fed up with your
troubleshooting and your attitude. SO please STOP sending emails.
Continue your troubleshooting LOL.... Ubuntu is like.. U guys keep on
digging for treasure and what that comes out is a rat. You guys
release OS in every six months. And if we talk about changes in the
osyou have changed the login screen, added 2 wallpapers, replaced the
close button from right to left.. pathetic... LOL...
Goodbye..

On Mon, Apr 5, 2010 at 11:55 PM, Brian O'Keefe <email address hidden> wrote:
> I tried the rtsp url's and get this error:
>
> No supported stream was found. You might be missing the right GStreamer
> RTSP extension plugin.
>
> I installed anything that referred to RTSP when i first got the error
> and retried. Same error.
>
> --
> Unable to play video from "Youtube plugin" results
> https://bugs.launchpad.net/bugs/459423
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in The GStreamer Multimedia Framework: Fix Released
> Status in Totem Movie Player: Unknown
> Status in “ffmpeg” package in Ubuntu: Invalid
> Status in “totem” package in Ubuntu: Fix Released
> Status in “ffmpeg” source package in Jaunty: Invalid
> Status in “totem” source package in Jaunty: Fix Released
> Status in “ffmpeg” source package in Karmic: Invalid
> Status in “totem” source package in Karmic: Fix Released
>
> Bug description:
> Binary package hint: totem
>
> With Totem 2.28.1, GStreamer 0.10.25 and Ubuntu 9.10, I'm not able to play video from Youtube plugin results. I can search and see results thumbnails, but if I click on a thumbnail to play the corresponding video, Totem displays an error:
>
>>Une erreur est survenue
>>GStreamer a rencontré une erreur générale de bibliothèque de prise en charge.
>
> ProblemType: Bug
> Architecture: i386
> Date: Fri Oct 23 17:16:55 2009
> DistroRelease: Ubuntu 9.10
> ExecutablePath: /usr/bin/totem
> Package: totem 2.28.1-0ubuntu4
> ProcEnviron:
>  LANGUAGE=fr_CA.UTF-8
>  LANG=fr_CA.UTF-8
>  SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.31-14.46-generic
> SourcePackage: totem
> Uname: Linux 2.6.31-14-generic i686
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/gstreamer/+bug/459423/+subscribe
>

--
Warm regards,

Jimmy Matthew
+91-9048052718

Even if Christ comes on my way, I will shoot him right on his torso

Saivann Carignan (oxmosys) wrote :

mrJimmymathew : Nobody sends you email, you subscribed to this bug report by yourself. Just unsubscribe if you don't want to get updates on this bug report. https://bugs.edge.launchpad.net/ubuntu/+source/ffmpeg/+bug/459423

If you don't like ubuntu, just feel free to quit it, nobody is going to force you to like it, but there is no need to tell the community that they're pathetic, it seems evident that you have no knowledge or interest of the numerous changes that come with each ubuntu releases (and actually you don't need to know ubuntu at all if that's no what you want), but in that case, don't act like you does.

1 comments hidden view all 114 comments
robert (raweinstein) wrote :

This bug was originally fixed several months back. I think the problem was the A.P.I. from youtube was changed. Everything has worked fine until recently, I really haven't played any you-tube videos on movie player but now that I do the error message: GStreamer encountered a general supporting library error. I am currently running 9.04 please fix and send out. thanking you in advance.

mrJimmymathew (mrjimmymathew) wrote :
Download full text (3.3 KiB)

Saïvann Carignan; I felt free that was the reason I quit using and
uninstalled the damn thing from my computer. The performance of my
computer is much better now, if you must know. Nobody can force
someone to like or dislike things. Thats okay Saïvann you can keep
yourself and your ubuntu mates cool. The reason for your frustration
is cos of your complex that you guys are way to inferior to Microsoft
and everyone knows that. And with the attitude like this Ubuntu is no
way getting even closer to Microsoft. When you said I dont have
knowledge you sound ironic. You call Ubuntu simple and user friendly
(laughing out loud). I dont know any changes that come in Ubuntu. Very
true. Can u tell me some changes in the new releases. Oh yes they have
added 2 themes in 10.04. One of the major changes is login screen is
different. Oh wait a sec the breaking news- Windows close button is
moved from right to left. Wow thats so amazing!!!! An average user
wants to save his data, wants a hassle free OS, Jus want to watch
movies, listen some music. For this an average user has to undergo so
many scripts and libs and other nonsense. Keep your OS among
yourself..
BYE

2010/4/6 Saïvann Carignan <email address hidden>:
> mrJimmymathew : Nobody sends you email, you subscribed to this bug
> report by yourself. Just unsubscribe if you don't want to get updates on
> this bug report.
> https://bugs.edge.launchpad.net/ubuntu/+source/ffmpeg/+bug/459423
>
> If you don't like ubuntu, just feel free to quit it, nobody is going to
> force you to like it, but there is no need to tell the community that
> they're pathetic, it seems evident that you have no knowledge or
> interest of the numerous changes that come with each ubuntu releases
> (and actually you don't need to know ubuntu at all if that's no what you
> want), but in that case, don't act like you does.
>
> --
> Unable to play video from "Youtube plugin" results
> https://bugs.launchpad.net/bugs/459423
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in The GStreamer Multimedia Framework: Fix Released
> Status in Totem Movie Player: Unknown
> Status in “ffmpeg” package in Ubuntu: Invalid
> Status in “totem” package in Ubuntu: Fix Released
> Status in “ffmpeg” source package in Jaunty: Invalid
> Status in “totem” source package in Jaunty: Fix Released
> Status in “ffmpeg” source package in Karmic: Invalid
> Status in “totem” source package in Karmic: Fix Released
>
> Bug description:
> Binary package hint: totem
>
> With Totem 2.28.1, GStreamer 0.10.25 and Ubuntu 9.10, I'm not able to play video from Youtube plugin results. I can search and see results thumbnails, but if I click on a thumbnail to play the corresponding video, Totem displays an error:
>
>>Une erreur est survenue
>>GStreamer a rencontré une erreur générale de bibliothèque de prise en charge.
>
> ProblemType: Bug
> Architecture: i386
> Date: Fri Oct 23 17:16:55 2009
> DistroRelease: Ubuntu 9.10
> ExecutablePath: /usr/bin/totem
> Package: totem 2.28.1-0ubuntu4
> ProcEnviron:
>  LANGUAGE=fr_CA.UTF-8
>  LANG=fr_CA.UTF-8
>  SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.31-14.46-generic
> SourcePacka...

Read more...

Uri Shabtay (uri.shabtay) wrote :

bug resurrected probably, as the folks above me reported, due to the new design of the Youtube site..

affective in Karmic fully updated

Confirmed, the bug is back. Karmic, fully updated.

Sebastien Bacher (seb128) wrote :

don't comment on closed bugs, the bug described there was fixed but it seems they changed their website again so a new bug should be opened

Yes, Sir! I see the Ubuntu community is getting lovelier by the day. Oh, and by the way, instead of giving orders and educating people on bug reports, you could have been done it yourself, if you found the time to describe the whole procedure. But you're right, I don't see Mark Shuttleworth commenting that it should be fixed as soon as possible, so I guess no one will jump on his seat and fix it for the next release. In the end, it's not my distro. I merely use it. Maybe your main goal is not to fix bugs, as long as there are buttons to move around, I don't know. Keep your buggy software, man, I'll use the browser next time I want to watch a video on YouTube. Thanks anyway.

Sebastien Bacher (seb128) wrote :

> so I guess no one will jump on his seat and fix it for the next release

not sure what you are speaking about but the said bug has already been fixed in lucid, it's just that most people are busy on getting lucid stable now and nobody found the time to work on a karmic update yet

robert (raweinstein) wrote :

What is the scheduled release date for this update? and will it be compatible with 9.04??
Thanking you in Advance, and yes the previous bug was originally fixed sometime last year. So this is in essence a new bug..

mmm, bad i think to change to windows cuz anything in ubuntu is well T_T somebody know's how can i see youtube videos?

please talk me to "<email address hidden>"

Augustin, unless you update to the latest release, or your request involves smart things like moving window controls around and then invent a solution to a problem that didn't exist before so you can implement a useless feature of the likes of "windicators" just to fill in the void, well, I guess you will have to wait until... hum... Ubuntu Zigzaggy Zebra is released, before seeing the bugs bugging you fixed, somehow. Good luck!

kao_chen (kaochen2) wrote :

The bug is back on lucid,I think, it will be present each time Youtube will change the path.
Can we imagine the plugin using a simple text file in order to find the path? or maybe a Ubuntu web page.
We just need a simple way to change the path access quickly without disturb devs.
Find and update the good link can be handle by the community.

** Message: Error: "http://www.youtube.com/get_video?video_id=jji3AQh7bao&t=vjVQa1PpcFNwLsyJJVT7RmB6xnjmY8nRhmIFSQ91V74%3D&fmt=18": Not Found
gstsouphttpsrc.c(1096): gst_soup_http_src_parse_status (): /GstPlayBin2:play/GstURIDecodeBin:uridecodebin0/GstSoupHTTPSrc:source:
404 Not Found

Changed in totem:
importance: Unknown → High
status: Unknown → Fix Released
Bartek Celary (karaphka) wrote :

Happened again...

** Message: Error: GStreamer napotkał ogólny błąd biblioteki wspierającej.
gstffmpegdemux.c(1255): gst_ffmpegdemux_open (): /GstPlayBin2:play/GstURIDecodeBin:uridecodebin0/GstDecodeBin2:decodebin20/ffdemux_swf:ffdemux_swf0:
Input/output error

Martin-Éric Racine (q-funk) wrote :

This issue is back in Natty:

$ totem
** Message: pygobject_register_sinkfunc is deprecated (GstObject)
libgdata-Message: Unhandled XML in GDataYouTubeVideo: <gd:comments><gd:feedLink href="http://gdata.youtube.com/feeds/api/videos/LAAl5bsTsXQ/comments" countHint="274"/></gd:comments>
libgdata-Message: Unhandled XML in GDataYouTubeVideo: <yt:rating numDislikes="10" numLikes="415"/>
libgdata-Message: Unhandled XML in GDataYouTubeVideo: <gd:comments><gd:feedLink href="http://gdata.youtube.com/feeds/api/videos/Y0ACSbsV3y8/comments" countHint="78"/></gd:comments>
libgdata-Message: Unhandled XML in GDataYouTubeVideo: <yt:rating numDislikes="5" numLikes="254"/>
libgdata-Message: Unhandled XML in GDataYouTubeVideo: <gd:comments><gd:feedLink href="http://gdata.youtube.com/feeds/api/videos/wIJzWvaLZ9o/comments" countHint="105"/></gd:comments>
libgdata-Message: Unhandled XML in GDataYouTubeVideo: <yt:rating numDislikes="0" numLikes="85"/>
libgdata-Message: Unhandled XML in GDataYouTubeVideo: <gd:comments><gd:feedLink href="http://gdata.youtube.com/feeds/api/videos/Qi0RsbORU3o/comments" countHint="5"/></gd:comments>
libgdata-Message: Unhandled XML in GDataYouTubeVideo: <yt:rating numDislikes="0" numLikes="9"/>
libgdata-Message: Unhandled XML in GDataYouTubeVideo: <gd:comments><gd:feedLink href="http://gdata.youtube.com/feeds/api/videos/HtOxHgjg814/comments" countHint="24"/></gd:comments>
libgdata-Message: Unhandled XML in GDataYouTubeVideo: <yt:rating numDislikes="0" numLikes="10"/>
libgdata-Message: Unhandled XML in GDataYouTubeVideo: <gd:comments><gd:feedLink href="http://gdata.youtube.com/feeds/api/videos/dMqLwMJU22U/comments" countHint="10"/></gd:comments>
libgdata-Message: Unhandled XML in GDataYouTubeVideo: <yt:rating numDislikes="1" numLikes="9"/>
libgdata-Message: Unhandled XML in GDataYouTubeVideo: <gd:comments><gd:feedLink href="http://gdata.youtube.com/feeds/api/videos/cudHuj1MWkk/comments" countHint="4"/></gd:comments>
libgdata-Message: Unhandled XML in GDataYouTubeVideo: <yt:rating numDislikes="0" numLikes="6"/>
libgdata-Message: Unhandled XML in GDataYouTubeVideo: <gd:comments><gd:feedLink href="http://gdata.youtube.com/feeds/api/videos/yVcSZyyNAFY/comments" countHint="1"/></gd:comments>
libgdata-Message: Unhandled XML in GDataYouTubeVideo: <yt:rating numDislikes="0" numLikes="3"/>
libgdata-Message: Unhandled XML in GDataYouTubeVideo: <gd:comments><gd:feedLink href="http://gdata.youtube.com/feeds/api/videos/ffksSAAp3mo/comments" countHint="12"/></gd:comments>
libgdata-Message: Unhandled XML in GDataYouTubeVideo: <yt:rating numDislikes="3" numLikes="1"/>
libgdata-Message: Unhandled XML in GDataYouTubeVideo: <gd:comments><gd:feedLink href="http://gdata.youtube.com/feeds/api/videos/aH38PGxIA9Y/comments" countHint="11"/></gd:comments>
libgdata-Message: Unhandled XML in GDataYouTubeVideo: <yt:rating numDislikes="1" numLikes="5"/>
** Message: Error: GStreamer kohtasi virheen yleisessä tukikirjastossa.
gstffmpegdemux.c(1255): gst_ffmpegdemux_open (): /GstPlayBin2:play/GstURIDecodeBin:uridecodebin0/GstDecodeBin2:decodebin20/ffdemux_swf:ffdemux_swf0:
Input/output error

Changed in gstreamer:
importance: Undecided → Unknown
status: Fix Released → Unknown
demilord (demilord) wrote :

Still happening in Maverick Meerkat 10.10 with all the latest updates...

allan ottley (awottley) on 2012-01-05
Changed in totem (Ubuntu):
assignee: nobody → allan ottley (awottley)
Displaying first 40 and last 40 comments. View all 114 comments or add a comment.