ffmpeg crashed in ffmpeg.c:632, audio sync method related

Bug #457106 reported by Xavi on 2009-10-21
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ffmpeg (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: ffmpeg

crashed when attempting to convert a mpeg video (from dvb-t) to flv
using pyTube

using karmic beta

ProblemType: Crash
Architecture: i386
Date: Wed Oct 21 13:13:08 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/ffmpeg
NonfreeKernelModules: nvidia wl
Package: ffmpeg 4:0.5+svn20090706-2ubuntu2
ProcCmdline: /usr/bin/ffmpeg -y -i /home/username/Vídeos/tdt/Notícies\ 324\ -\ 324\ -\ dc\ 21\ oct\ 2009\ 11:25:02\ CEST.mpeg -ar 22050 -b 200000 /home/username/Notícies\ 324\ -\ 324\ -\ dc\ 21\ oct\ 2009\ 11:25:02\ CEST.flv
ProcEnviron:
 LANG=ca_ES.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
Signal: 8
SourcePackage: ffmpeg
StacktraceTop:
 ?? ()
 ?? ()
 ?? () from /lib/tls/i686/cmov/libc.so.6
Title: ffmpeg crashed with SIGFPE
Uname: Linux 2.6.31-14-generic i686
UserGroups: adm admin audio cdrom dialout dip fax fuse lpadmin netdev plugdev sambashare video

Xavi (xavidp) wrote :
Xavi (xavidp) wrote :

this is a shortened version of the file, which is 1Gb
Anyway, he crash happenend at the very beginning (after 1 min or so)

--------------
I can't upload it. I've done:

 dd if=Noticies_prova.mpeg of=Noticies_prova_sm
aller.mpeg bs=1024 count=1000
1000+0 registres llegits
1000+0 registres escrits
1024000 octets (1,0 MB) copiats, 0,10412 s, 9,8 MB/s

but the file seems to be empty to lauchpad, and in loca, totem complains that "it's not possible tp determine the flux type" (translated from my local language)
Using the big mpeg file, totem attempts to look for a codec for private dvb-t streams, but anyways, it displays the video...

Don't know how to provide more details...

StacktraceTop:do_audio_out (s=<value optimized out>, ost=0x8e5b310,
output_packet (ist=<value optimized out>,
av_encode (nb_output_files=<value optimized out>,
main (argc=9, argv=0xbfd81014)

Changed in ffmpeg (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace

this might be indeed an valid bug. by looking at the source, you might be able to avoid the crash by using a different sync method (option -async) for ffmpeg.

still, in order to actually do something about this bug, we absolutely need a sample with which we can reproduce this issue. please investigate further why you cannot upload your sample to launchpad.

visibility: private → public
summary: - ffmpeg crashed with SIGFPE
+ ffmpeg crashed in ffmpeg.c:632, audio sync method related
Changed in ffmpeg (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ffmpeg - 4:0.6~svn20100505-1ubuntu1

---------------
ffmpeg (4:0.6~svn20100505-1ubuntu1) maverick; urgency=low

  * merge from debian/experimental. remaining changes:
    - don't disable encoders
    - don't build against libfaad, libdirac and libopenjpeg (all in universe)

ffmpeg (4:0.6~svn20100505-1) experimental; urgency=low

  * update to new upstream. Closes: #569727
    - fixes various segfaults and other minor feature improvements
      Closes: #374931, #522449, #501891, #559712, #420231, #369127, #538082,
              #298095, #294422, #561553, #525385, #495274, #420230
      LP: #305286, #457106, #529200, #301723, #305315, #336479, #420230,
          #412063, #428912, #432181, #440591, #453732, #453732, #453732,
      #514259, #515243, #521472, #530186, #530186, #197842, #483317,
     #483317, #539407, #280098, #331255, #566107, #569823, #570305,
     #573190
  * Fixup lintian overrides for new upstream snapshot
  * Bump Standards-Version to 3.8.4
  * Many upstream changes, see upstream Changelog for details
 -- Reinhard Tartler <email address hidden> Wed, 26 May 2010 00:01:17 +0200

Changed in ffmpeg (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers