Ubuntu

[karmic] missing aac encoder

Reported by Wes Garner on 2009-08-11
172
This bug affects 40 people
Affects Status Importance Assigned to Milestone
Baltix
Undecided
Unassigned
ffmpeg (Ubuntu)
Low
Unassigned
ffmpeg-extra (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: ffmpeg

FFmpeg version SVN-r19134-4:0.5+svn20090609-1ubuntu3, Copyright (c) 2000-2009 Fabrice Bellard, et al.
  configuration: --disable-encoder=h263 --disable-encoder=h263p --disable-encoder=mpeg2video --disable-encoder=mpeg4
--disable-encoder=msmpeg4v1 --disable-encoder=msmpeg4v2 --disable-encoder=msmpeg4v3
--extra-version=4:0.5+svn20090609-1ubuntu3 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-bzlib
--enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-pthreads
--enable-zlib --disable-stripping --disable-vhook --enable-gpl --enable-postproc --enable-swscale --enable-x11grab
--enable-libdc1394 --enable-shared --disable-static
  libavutil 49.15. 0 / 49.15. 0
  libavcodec 52.20. 0 / 52.20. 0
  libavformat 52.31. 0 / 52.31. 0
  libavdevice 52. 1. 0 / 52. 1. 0
  libavfilter 0. 4. 0 / 0. 4. 0
  libswscale 0. 7. 1 / 0. 7. 1
  libpostproc 51. 2. 0 / 51. 2. 0
  built on Jul 25 2009 08:34:10, gcc: 4.4.1
[NULL @ 0x1018e80]Invalid and inefficient vfw-avi packed B frames detected
Input #0, avi, from 'Skins.S03E02.WS.PDTV.XviD-river.avi':
  Duration: 00:47:00.96, start: 0.000000, bitrate: 1035 kb/s
    Stream #0.0: Video: h264, yuv420p, 640x352 [PAR 1:1 DAR 20:11], 25 tbr, 25 tbn, 25 tbc
    Stream #0.1: Audio: mp3, 48000 Hz, stereo, s16, 160 kb/s
File 'Skins.S03E02.WS.PDTV.XviD-river.avi.mp4' already exists. Overwrite ? [y/N] y
Output #0, mp4, to 'Skins.S03E02.WS.PDTV.XviD-river.avi.mp4':
    Stream #0.0: Video: mpeg4, yuv420p, 640x402 [PAR 201:176 DAR 20:11], q=2-31, pass 1, 480 kb/s, 90k tbn, 25 tbc
    Stream #0.1: Audio: 0x0000, 48000 Hz, stereo, s16, 96 kb/s
Stream mapping:
  Stream #0.0 -> #0.0
  Stream #0.1 -> #0.1
Unsupported codec for output stream #0.1

Wes Garner (wesgarner) wrote :

Not expected to work without Medibuntu Packages, but it is not working even with them (w64codecs plus all listed unstripped codecs installed)

Changed in ffmpeg (Ubuntu):
assignee: nobody → Medibuntu Bugs (medibuntu-bugs)

support for libfaac was removed, as upstream considers libfaac as
non-free. We are currently trying to contact upstream on this, for
details see #374900.

Perhaps it could help if users would also prod upstream about this
issue.

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Changed in ffmpeg (Ubuntu):
assignee: Medibuntu Bugs (medibuntu-bugs) → nobody

Just posted a fairly useless comment on bug 374900
Any other ideas to help get them to take a look?

summary: - [karmic] ffmpeg unsupported codec aac using medibuntu unstripped codecs
+ [karmic] missing aac encoder
Changed in ffmpeg (Ubuntu):
status: New → Confirmed
Changed in ffmpeg (Ubuntu):
importance: Undecided → Low
Doug McMahon (mc3man) wrote :

While I must apologize for the duplicate of this bug ( the reason for removing libfaac (non-free) should have been obvious to me, it still begs the question of what is the position on native aac encoding that was enabled in ffmpeg, just 2 days later than the current source in karmic.
enabled since ffmpeg -r 19375, released on 07/08

My inclination is there may be an update to ffmpeg in karmic, if so some consideration should be given to using a newr -r ( r-19777 would be a very good choice

Doug McMahon <email address hidden> writes:

> My inclination is there may be an update to ffmpeg in karmic, if so some
> consideration should be given to using a newr -r ( r-19777 would be a
> very good choice

Updating ffmpeg is out of question as the potential for regressions it
to high. Patches that backport features from trunk however is something
that I'm inclined to consider for review...

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Alex Converse (ajc30) wrote :

A backport isn't going to help much. The code currently in FFmpeg SVN is low quality buggy in regard to multichannel. The code in my tree is slow but high quality for mono but still sub-par for stereo and multichannel is still broken.

Changed in ffmpeg-extra (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Soos Gergely (sogerc1) wrote :

I'm really not happy that this bug has been marked Low importance because ever since I upgraded to karmic I can't convert movies to the format my phone supports (mpeg4+aac in mp4)

Paul Gevers (paul-climbing) wrote :

Soos Gergely wrote:
> I'm really not happy that this bug has been marked Low importance
> because ever since I upgraded to karmic I can't convert movies to the
> format my phone supports (mpeg4+aac in mp4)

Thank you for being so constructive. As bug 374900 is really blocking
this issue and that is not a technical bug, you could pull it on your
own shoulders to help that bug to be solved. Keep bugging upstream of
libfaac to clarify the license issue and ffmpeg can include faac again.

Paul

llogan (loul) wrote :

A few weeks ago Medibuntu released a version of libavcodec-extra-52 for Karmic that can be used to encode to AAC via FFmpeg/libfaac:

https://bugs.launchpad.net/medibuntu/+bug/490227

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ffmpeg - 4:0.6~svn20100505-1ubuntu1

---------------
ffmpeg (4:0.6~svn20100505-1ubuntu1) maverick; urgency=low

  * merge from debian/experimental. remaining changes:
    - don't disable encoders
    - don't build against libfaad, libdirac and libopenjpeg (all in universe)

ffmpeg (4:0.6~svn20100505-1) experimental; urgency=low

  * update to new upstream. Closes: #569727
    - fixes various segfaults and other minor feature improvements
      Closes: #374931, #522449, #501891, #559712, #420231, #369127, #538082,
              #298095, #294422, #561553, #525385, #495274, #420230
      LP: #305286, #457106, #529200, #301723, #305315, #336479, #420230,
          #412063, #428912, #432181, #440591, #453732, #453732, #453732,
      #514259, #515243, #521472, #530186, #530186, #197842, #483317,
     #483317, #539407, #280098, #331255, #566107, #569823, #570305,
     #573190
  * Fixup lintian overrides for new upstream snapshot
  * Bump Standards-Version to 3.8.4
  * Many upstream changes, see upstream Changelog for details
 -- Reinhard Tartler <email address hidden> Wed, 26 May 2010 00:01:17 +0200

Changed in ffmpeg (Ubuntu):
status: Confirmed → Fix Released
Reinhard Tartler (siretart) wrote :

status update: AFAIUI this bug requests ffmpeg-extra to be compiled against libfaac. this step is blocked by the outcome of bug #374900

Changed in ffmpeg-extra (Ubuntu):
status: Confirmed → Triaged
Reinhard Tartler (siretart) wrote :

there is no ffmpeg-extra package anymore in Ubuntu, thus closing this bugtask.

Changed in ffmpeg-extra (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers