libavfilter-extra-1 is empty (except /usr/share/doc)

Bug #587424 reported by Anders Kaseorg on 2010-05-30
78
This bug affects 12 people
Affects Status Importance Assigned to Milestone
ffmpeg-extra (Ubuntu)
High
Reinhard Tartler

Bug Description

$ dpkg-query -W libavutil-extra-49
libavutil-extra-49 4:0.6~svn20100505-1ubuntu3
$ dpkg -L libavutil-extra-49
/.
/usr
/usr/share
/usr/share/doc
/usr/share/doc/libavutil-extra-49
/usr/share/doc/libavutil-extra-49/README.Debian.gz
/usr/share/doc/libavutil-extra-49/MAINTAINERS.gz
/usr/share/doc/libavutil-extra-49/copyright
/usr/share/doc/libavutil-extra-49/changelog.gz
/usr/share/doc/libavutil-extra-49/CREDITS
/usr/share/doc/libavutil-extra-49/TODO
/usr/share/doc/libavutil-extra-49/optimization.txt.gz
/usr/share/doc/libavutil-extra-49/changelog.Debian.gz
$ mplayer
mplayer: error while loading shared libraries: libavutil.so.49: cannot open shared object file: No such file or directory

Anders Kaseorg (andersk) wrote :

Upon further inspection, all of the other binary packages from ffmpeg-extra are empty, too. This is … what you might have expected to happen when you delete the dh_install line from debian/rules.

Anders Kaseorg (andersk) wrote :

Here’s a better debdiff that corrects some additional mistakes in the 0.6 merge (rename libavutil-extra-49 to libavutil-extra-50, and rename debian/libavfilter-extra-0.install to debian/libavfilter-extra-1.install).

Anders Kaseorg (andersk) on 2010-05-30
Changed in ffmpeg-extra (Ubuntu):
status: New → Confirmed
Reinhard Tartler (siretart) wrote :

thanks, I clearly botched the merge. I'll handle this

Changed in ffmpeg-extra (Ubuntu):
assignee: nobody → Reinhard Tartler (siretart)
importance: Undecided → High
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ffmpeg-extra - 4:0.6~svn20100505-1ubuntu4

---------------
ffmpeg-extra (4:0.6~svn20100505-1ubuntu4) maverick; urgency=low

  * bump soname for package libavutil49->libavutil50
  * fix installation rule, LP: #587424
 -- Reinhard Tartler <email address hidden> Thu, 03 Jun 2010 11:42:48 +0200

Changed in ffmpeg-extra (Ubuntu):
status: Triaged → Fix Released
Anders Kaseorg (andersk) wrote :

You didn’t look at my debdiff, did you? libavfilter-extra-1 0.6~svn20100505-1ubuntu4 is still empty. You need to rename debian/libavfilter-extra-0.install to debian/libavfilter-extra-1.install.

Changed in ffmpeg-extra (Ubuntu):
status: Fix Released → New
Anders Kaseorg (andersk) wrote :
summary: - libavutil-extra-49 is empty (except /usr/share/doc)
+ libavfilter-extra-1 is empty (except /usr/share/doc)

No suitable decoder module:
VLC does not support the audio or video format "XVID". Unfortunately there is no way for you to fix this.

$ apt-cache policy libavutil50
libavutil50:
  Installed: 4:0.6~svn20100505-1ubuntu1
  Candidate: 4:0.6~svn20100505-1ubuntu1
  Version table:
 *** 4:0.6~svn20100505-1ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ maverick/main Packages

Anders Kaseorg (andersk) wrote :

BUGabundo, that sounds like a different bug. libavutil50 is from the ffmpeg source package, not the ffmpeg-extra source package (perhaps you meant to install libavutil-extra-50?). Anyway, if you can’t get it to work, file another bug report.

On Do, Jun 03, 2010 at 20:40:08 (CEST), Anders Kaseorg wrote:

> You didn’t look at my debdiff, did you? libavfilter-extra-1
> 0.6~svn20100505-1ubuntu4 is still empty. You need to rename debian
> /libavfilter-extra-0.install to debian/libavfilter-extra-1.install.

I missed that part, sorry. this upload should fix that.

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ffmpeg-extra - 4:0.6~svn20100505-1ubuntu5

---------------
ffmpeg-extra (4:0.6~svn20100505-1ubuntu5) maverick; urgency=low

  * install files into libavfilter-extra-1.install. LP: #587424
 -- Reinhard Tartler <email address hidden> Thu, 03 Jun 2010 22:07:30 +0200

Changed in ffmpeg-extra (Ubuntu):
status: New → Fix Released

Were AMD64 packages uploaded? 15+ hours later, I still see only -ubuntu3 in the main and US repos.

I tried to use Package Search (http://packages.ubuntu.com/), but it seems to be misconfigured and does not work for anything once you choose Maverick.

nm.. I think https://launchpad.net/ubuntu/+source/ffmpeg-extra/4:0.6~svn20100505-1ubuntu5/+build/1771574 is telling me that despite the status, the fixed packages are still 8 hours away from being built and released yet.

Hmmm... now it says it's 10 hours away from being built. It makes me wonder if something isn't wrong with the prioritization when a broken package that has so many dependant applications (VLC, Amarok, XVidcap, etc.) is pushed down in the queue over 24 hours past when it was submitted. :\

Maybe that's the way it's always been, and I'm just a noob. In the meantime, I'd expect more people to submit dupes for this, since it won't show in default searches with it's status being "fix released".

Rickard Närström (riccetn) wrote :

@3vi1 The status is "Fix released" as soon as the *source* package is accepted into the archive.
The build system put low priory on ffmpeg-extra as it is in multiverse, packages uploaded to other components can push it back in the queue. See: https://help.launchpad.net/Packaging/BuildScores . It will be built eventually just be patient and wait it out.

Yes, I read the buildscores page before posting earlier. It seems to me that the "Time in Queue" isn't weighted high enough (nothing from multiverse will ever be built before even the newest submission in the other regions) and that PPA's really shouldn't have such high priority.

But, this isn't the place for that discussion, so 'll try to turn the whining off. Now only 7 more hours until it's built! (grinning, ducking, and running).

Benjamin Drung (bdrung) wrote :

@3vi1: maverick is currently in development. So you have to expect breakage. Due to the development status, you don't have to expect a quick build.

Blender, kdenlive, openshot, vlc, xvidcap, etc. are still broken to some extent because they depend on libavutil-extra-49.... which I can now see was not in the fixed packages.

What's the proper course of action? Get libavutil-extra-49 rebuilt too, or file bugs against all the broken packages to move to -50?

Rickard Närström (riccetn) wrote :

@3vi1: Those packages should be rebuilt against the new libavutil. You may open bug reports for each of the packages if you want, personally I wouldn't bother and just wait for new versions to be uploaded.

Coolio - Thx for the info Rickard!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers