festival: can't open /dev/dsp

Bug #662630 reported by Zoubidoo on 2010-10-18
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
festival (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: festival

When running festival from the command line it has trouble accessing the sound device reporting "can't open /dev/dsp"

After troubleshooting I found that this problem has been around since Dapper and still occurs in Lucid. But the workaround is very easy:

Create ~/.festivalrc with the following content

;use ALSA
(Parameter.set 'Audio_Method 'Audio_Command)
(Parameter.set 'Audio_Command "aplay -q -c 1 -t raw -f s16 -r $SR $FILE")

Perhaps we could update the festival package so that no troubleshooting or workaround is necessary.

$ festival
Festival Speech Synthesis System 1.96:beta July 2004
Copyright (C) University of Edinburgh, 1996-2004. All rights reserved.
For details type `(festival_warranty)'
festival> (SayText "hello")
Linux: can't open /dev/dsp
#<Utterance 0xb6a83aa8>
festival>

The solution comes from this thread: http://ubuntuforums.org/showthread.php?t=171182

festival 1.96~beta-10ubuntu1
Description: Ubuntu 10.04.1 LTS
Release: 10.04
Linux machine 2.6.32-24-generic #43-Ubuntu SMP Thu Sep 16 14:17:33 UTC 2010 i686 GNU/Linux

Related branches

Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here.

This file must also be created in Natty Narwhal.

Thanks for taking the time to make Ubuntu better!

Changed in festival (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
tags: added: a11y
Charlie Kravetz (charlie-tca) wrote :

Maybe confirmed this too fast. It may in fact be a duplicate of bug 209900. The descriptions are different, but perhaps fixing that bug would fix this bug also?

Changed in festival (Ubuntu):
status: Triaged → Incomplete
Jarno Suni (jarnos) wrote :

Or maybe the workaround of this bug would work in bug 209900, too. That does not require pulseaudio.

Jarno Suni (jarnos) wrote :

Charlie, this is more general bug than bug 209900. Fixing this would fix festival in e.g. Lubuntu which does not use pulseaudio.

Charlie Kravetz (charlie-tca) wrote :

pulseaudio has nothing to do with this issue. Whether or not it is installed or activated, this bug is still present. Please don't confuse issues. If you have issues with pulseaudio, this workaround will not fix them.

Changed in festival (Ubuntu):
status: Incomplete → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package festival - 1:2.0.95~beta-5.1ubuntu2

---------------
festival (1:2.0.95~beta-5.1ubuntu2) natty; urgency=low

  * No longer depend on alsa-oss and oss-compat (LP: #612751)
  * Add festival.scm for default audio setting (LP: #662630, #209900)
 -- Andreas Moog <email address hidden> Wed, 02 Mar 2011 07:39:07 +0100

Changed in festival (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers