fdroid signatures: 1 positional argument but 2 were given

Bug #1786111 reported by Andreas Schildbach on 2018-08-08
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
fdroidserver (Ubuntu)
Undecided
Unassigned

Bug Description

On 1.0.9 (bionic-proposed, possibly also cosmic), './fdroid signatures' or './fdroid signatures blabla.apk' yields:
'TypeError: extract() takes 1 positional argument but 2 were given.'
This renders the command useless; it appears to be broken.

This is/was the upstream issue: https://gitlab.com/fdroid/fdroidserver/issues/536
The issue is fixed via this commit: https://gitlab.com/fdroid/fdroidserver/commit/d76c5dc859e2bfd7de9cbecd81bb68738858ed42

description: updated

This was fixed in 1.0.10, which is available in bionic-updates, cosmic, and disco. And the PPA: https://launchpad.net/~fdroid/+archive/ubuntu/fdroidserver

Changed in fdroidserver (Ubuntu):
status: New → Fix Released

Oops, that was a mistake. 1.0.10 is only available in disco and the PPA. But it seems I don't have the perms to reopen this issue

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers