Impossible to select SOGOU pinyin in LUBUNTU 14.04

Bug #1309841 reported by sulliwane on 2014-04-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
fcitx (Ubuntu)
Undecided
Unassigned

Bug Description

After installing FCITX from PPA-daily-build, installing SOGOU 32bits (from sogou for linux website) and launching FCITX, I have this OUTPUT in the terminal, and impossible to select SOGOU PINYIN :

gumeiren@gumeiren-N128:~$ fcitx-qimpanel
gumeiren@gumeiren-N128:~$ MainController::init()
QMetaObject::connectSlotsByName: No matching signal for on_checkBox_tab3_FontSize_toggled(bool)
(WARN-1798 /build/buildd/fcitx-4.2.8.3+1907+201403101923~ubuntu14.04.1/src/lib/fcitx-config/fcitx-config.c:922) Invalid Entry: line 150 missing '='
(WARN-1798 /build/buildd/fcitx-4.2.8.3+1907+201403101923~ubuntu14.04.1/src/lib/fcitx-config/fcitx-config.c:922) Invalid Entry: line 152 missing '='
(WARN-1798 /build/buildd/fcitx-4.2.8.3+1907+201403101923~ubuntu14.04.1/src/lib/fcitx-config/fcitx-config.c:922) Invalid Entry: line 150 missing '='
(WARN-1798 /build/buildd/fcitx-4.2.8.3+1907+201403101923~ubuntu14.04.1/src/lib/fcitx-config/fcitx-config.c:922) Invalid Entry: line 148 missing '='
(WARN-1798 /build/buildd/fcitx-4.2.8.3+1907+201403101923~ubuntu14.04.1/src/lib/fcitx-config/fcitx-config.c:922) Invalid Entry: line 152 missing '='
(WARN-1798 /build/buildd/fcitx-4.2.8.3+1907+201403101923~ubuntu14.04.1/src/lib/fcitx-config/fcitx-config.c:922) Invalid Entry: line 150 missing '='
(WARN-1798 /build/buildd/fcitx-4.2.8.3+1907+201403101923~ubuntu14.04.1/src/lib/fcitx-config/fcitx-config.c:922) Invalid Entry: line 152 missing '='
(WARN-1798 /build/buildd/fcitx-4.2.8.3+1907+201403101923~ubuntu14.04.1/src/lib/fcitx-config/fcitx-config.c:922) Invalid Entry: line 150 missing '='
(WARN-1798 /build/buildd/fcitx-4.2.8.3+1907+201403101923~ubuntu14.04.1/src/lib/fcitx-config/fcitx-config.c:922) Invalid Entry: line 152 missing '='
(WARN-1798 /build/buildd/fcitx-4.2.8.3+1907+201403101923~ubuntu14.04.1/src/lib/fcitx-config/fcitx-config.c:922) Invalid Entry: line 154 missing '='
(WARN-1798 /build/buildd/fcitx-4.2.8.3+1907+201403101923~ubuntu14.04.1/src/lib/fcitx-config/fcitx-config.c:922) Invalid Entry: line 152 missing '='
"1.0.0.0011"
"系统词频: 20110527"
"组词数据: 20110307"
"20101217"
"编译时间: Apr 17 2014 07:25:54"
void SystemTrayMenu::init()
gumeiren@gumeiren-N128:~$ (WARN-1798 /build/buildd/fcitx-4.2.8.3+1907+201403101923~ubuntu14.04.1/src/lib/fcitx-config/fcitx-config.c:922) Invalid Entry: line 150 missing '='
(WARN-1798 /build/buildd/fcitx-4.2.8.3+1907+201403101923~ubuntu14.04.1/src/lib/fcitx-config/fcitx-config.c:922) Invalid Entry: line 150 missing '='
(WARN-1798 /build/buildd/fcitx-4.2.8.3+1907+201403101923~ubuntu14.04.1/src/lib/fcitx-config/fcitx-config.c:922) Invalid Entry: line 150 missing '='
(WARN-1798 /build/buildd/fcitx-4.2.8.3+1907+201403101923~ubuntu14.04.1/src/lib/fcitx-config/fcitx-config.c:922) Invalid Entry: line 150 missing '='
(WARN-1798 /build/buildd/fcitx-4.2.8.3+1907+201403101923~ubuntu14.04.1/src/lib/fcitx-config/fcitx-config.c:922) Invalid Entry: line 150 missing '='
(WARN-1798 /build/buildd/fcitx-4.2.8.3+1907+201403101923~ubuntu14.04.1/src/lib/fcitx-config/fcitx-config.c:922) Invalid Entry: line 150 missing '='

I posted a subject on askubuntu : http://askubuntu.com/questions/450255/sogou-linux-for-lubuntu-14-04

I'm not sure if it's a bug though.

Aron Xu (happyaron) wrote :

Not a bug in fcitx package that's in Ubuntu archive, thus marking as Invalid here.

You may want to report this problem to Sogou's bbs at http://pinyin.sogou.com/bbs/forum.php?gid=114

The PPA that's advised to be added is ppa:fcitx-team/nightly, not the daily-master one, though.

Changed in fcitx (Ubuntu):
status: New → Invalid
sulliwane (sulliwane) wrote :

Thank you for your feedback.

 I added the daily-build PPA because my LUBUNTU is 14.04 and the nightly PPA has no version of FCITX for 14.04.

I will post on sogou forum then, thanks for the advice.

Aron Xu (happyaron) wrote :

In 14.04, the version of Fcitx is exactly the version sogoupinyin requires, only older releases need to add PPA to install the back ported Fcitx from 14.04, :)

sulliwane (sulliwane) wrote :

Yes that's what happened with my Ubuntu 14.04, no need to add the PPA (and works GREAT, I was so happy to finally enjoy sogou pinyin on linux)

But on LUBUNTU 14.04, I installed the sogou.deb from their website, but even it seems to install in the end, I had errors thrown in the middle, somehting like : "dependecies not installed : fcitx"

sulliwane (sulliwane) wrote :

Just for info, here is the error from the terminal, when trying to install sogou_pinyin_1.0 i386 on LUBUNTU 14.04 (after removing the PPA and FCItX)

root@gumeiren-N128:/home/gumeiren/Downloads# dpkg -i sogou_pinyin_linux_1.0.0.0011_i386\(1\).deb

Selecting previously unselected package sogoupinyin.
(Reading database ... 122544 files and directories currently installed.)
Preparing to unpack sogou_pinyin_linux_1.0.0.0011_i386(1).deb ...
Unpacking sogoupinyin (1.0.0.0011) ...
dpkg: dependency problems prevent configuration of sogoupinyin:
 sogoupinyin depends on fcitx (>= 1:4.2.8.3-3~); however:
  Package fcitx is not installed.
 sogoupinyin depends on fcitx-bin; however:
  Package fcitx-bin is not installed.
 sogoupinyin depends on fcitx-module-dbus (>= 1:4.2.8); however:
  Package fcitx-module-dbus is not installed.
 sogoupinyin depends on fcitx-modules; however:
  Package fcitx-modules is not installed.
 sogoupinyin depends on fcitx-libs (>= 4.2.7); however:
  Package fcitx-libs:i386 is not installed.
 sogoupinyin depends on fcitx-libs-qt (>= 4.2.7); however:
  Package fcitx-libs-qt:i386 is not installed.

dpkg: error processing package sogoupinyin (--install):
 dependency problems - leaving unconfigured
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for shared-mime-info (1.2-0ubuntu3) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for mime-support (3.54ubuntu1) ...
Errors were encountered while processing:
 sogoupinyin

sulliwane (sulliwane) wrote :

OK ! I removed the PPA, uninstalled/reinstalled sogou_pinyin_1 as seen before (with the error), run apt-get install -f, Restarted, run fcitx , then run fcitx-qimpanel and BAM ! Sogou pinyin is now working.

I just have a small black rectangle on the screen, but it works ! (attached)

Thank you for you support, and for for this greet input method. Almost the last thing that I missed on Linux.

Aron Xu (happyaron) wrote :

Good to know that it's working for you!

I believe the black rectangle is caused by lacking of compositing support in the window manager, i.e. openbox in lxde. Can you try to install and configure a compositing window manager for openbox to see if the black rectangle gets disappeared.

sulliwane (sulliwane) wrote :

THANK YOU !

I installed compton in Lubuntu, disabled shadow and it works PERFECTLY ! (i mean, no black square anymore)

Here is the detailed explanations : http://askubuntu.com/questions/451095/lubuntu-14-04-and-fcitx-qimpanel-how-to-remove-this-black-square/451285#451285

thanks again for your support ! cheers.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers