[SRU] Add Fcitx input method framework's Qt5 IM Module

Bug #1178309 reported by Aron Xu on 2013-05-09
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
fcitx-qt5 (Ubuntu)
Undecided
Unassigned
Raring
Undecided
Unassigned

Bug Description

[Impact]
In Raring, there is quite some applications that use Qt5, and Fcitx's Qt5 support isn't included in the release. This makes Fcitx's users not being able to input in those applications because Qt5 does not have traditional XIM support.

[Test Case]
After installing and configuring fcitx and fcitx's qt5 IM Module properly, user should be able to input in applications like Friends.

[Regression Potential]
Since the package isn't in the archive before, it shouldn't make things worse.

Version fcitx-qt5/0.1.1-1 of the package can be synced from Debian experimental. This is the initial upload to Debian.

Aron Xu (happyaron) on 2013-05-09
Changed in ubuntu:
assignee: nobody → Aron Xu (happyaron)

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1178309/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Aron Xu (happyaron) on 2013-05-29
description: updated
Aron Xu (happyaron) wrote :

Subscribing ubuntu-sponsors team. It would be appreciated if the package can be synced to saucy as well, do I need to file another request?

Jeremy Bicha (jbicha) wrote :

Synced to Saucy's new queue.

In the future, you can run requestsync from the ubuntu-dev-tools package to make this type of bug report easier.

If you want this backported to Raring, you can run requestbackport after it has built successfully on Saucy. See https://wiki.ubuntu.com/UbuntuBackports for more information.

Changed in ubuntu:
status: Confirmed → In Progress
Jeremy Bicha (jbicha) on 2013-06-06
affects: ubuntu → fcitx-qt5 (Ubuntu)
Changed in fcitx-qt5 (Ubuntu):
assignee: Aron Xu (happyaron) → nobody
status: In Progress → Fix Released
Aron Xu (happyaron) wrote :

@jbicha This is intended for SRU but not backports, even though it's a new package I believe it's important enough.

Aron Xu (happyaron) wrote :

Even backports is enabled by defaults, it fails to meet the point of
addressing certain important regressions (like this one) and some users may
disable it.

This update is quite important for people who use input method everyday
because without proper input support the system becomes partially useless
to them.

Scott Kitterman (kitterman) wrote :

Fair enough. Someone needs to upload it.

Jeremy Bicha (jbicha) wrote :

Aron, currently nothing depends on fcitx-qt5 so it's still a regression whether it's in -updates or -backports, Raring or Saucy.

Aron Xu (happyaron) wrote :

It's not a dependency of something, because input method aren't pulled in by any application/library. Technically speaking it's an optional component of the input method framework, which anyway requires the user to install something (or pulled by language-selector, or language-specific meta package). Without having this package in the archive, users are asked to update to upstream's PPA to make it working. Even upstream PPA is maintained by me, I don't think it's the case that I should ask everyone to install package from it.

Jeremy Bicha (jbicha) wrote :

OK, since Backports are installed by default, I think the Backports process will be much faster and easier than the SRU process.

As an example of how it works, scratch (a children's programming app from MIT) is only in Backports in Ubuntu 12.04 LTS but sudo apt-get install scratch (or however you use to install software) works fine.

Scott Kitterman (kitterman) wrote :

I'm willing to make an exception to the usual SRU policy for this if someone
uploads it to -proposed.

Aron Xu (happyaron) wrote :

I don't think -backports is good for such kind of stuff, for me as an example, I always disable -backports once installation is complete to get rid of the possibility of installing any package that is not supported by accident.

In my understanding backports is for packages that are nice-to-have or version-not-supported, but we are dealing with regression and it shows that is (community) supported through the release's life time.

Rolf Leggewie (r0lf) wrote :

raring has seen the end of its life and is no longer receiving any updates. Marking the raring task for this ticket as "Won't Fix".

Changed in fcitx-qt5 (Ubuntu Raring):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers