md5sum: /lib/udev/devices/core: Operation not permitted

Bug #47408 reported by Munzir Taha (منذر طه) on 2006-05-30
38
This bug affects 3 people
Affects Status Importance Assigned to Milestone
fcheck (Ubuntu)
Medium
François Marier
Nominated for Dapper by Ali Ross
Declined for Gutsy by Luca Falavigna
Nominated for Hardy by Ali Ross
Nominated for Intrepid by Ali Ross
Nominated for Jaunty by Ali Ross
Nominated for Karmic by Florian Reinheimer

Bug Description

Binary package hint: fcheck

$ sudo apt-get install fcheck
Password:
Reading package lists... Done
Building dependency tree... Done
fcheck is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
1 not fully installed or removed.
Need to get 0B of archives.
After unpacking 0B of additional disk space will be used.
Setting up fcheck (2.7.59-8) ...
Building fcheck database (may be some time).../usr/bin/md5sum: /lib/udev/devices/core: Operation not permitted
fcheck: /usr/bin/md5sum was unable to read /lib/udev/devices/core, or was unable to execute

terminating...

dpkg: error processing fcheck (--configure):
 subprocess post-installation script returned error exit status 2
Errors were encountered while processing:
 fcheck
E: Sub-process /usr/bin/dpkg returned an error code (1)

I just install the fcheck utility:
I got the extactly same messages.
System = Edgy
fcheck = 2.7.59-8

now, each time I install a package, apt tries to configure fcheck.
For example, (see the below copy/paste ), I installed the package yelp-dbgsym (first line below):
START OF COPY/PASTE:
Dépaquetage de yelp-dbgsym (à partir de .../yelp-dbgsym_2.16.1-0ubuntu3_i386.ddeb) ...
Paramétrage de fcheck (2.7.59-8) ...
Building fcheck database (may be some time).../usr/bin/md5sum: /lib/udev/devices/core: Opération non permise
fcheck: /usr/bin/md5sum was unable to read /lib/udev/devices/core, or was unable to execute

terminating...

dpkg : erreur de traitement de fcheck (--configure) :
 le sous-processus post-installation script a retourné une erreur de sortie d'état 2
Paramétrage de yelp-dbgsym (2.16.1-0ubuntu3) ...
Des erreurs ont été rencontrées pendant l'exécution :
 fcheck
E: Sub-process /usr/bin/dpkg returned an error code (1)
END OF COPY/PASTE

(On my Celeron / 800MHz / 256MB machine, this lasts about 5 minutes)

Richard Laager (rlaager) wrote :

To fix this bug, /etc/fcheck/fcheck.cfg needs to have this added with the other exclusions:
Exclusion = /lib/udev/devices/

Changed in fcheck:
status: Unconfirmed → Confirmed
JP Vossen (jp-jpsdomain) wrote :

Bump! This was first reported in 2006 and it's not fixed yet? When the fix is a simple one-line addition to the default config file?

I just had the same problem on an Ubuntu Hardy LAMP Server install. The fix was as above, "Exclusion = /lib/udev/devices/".
My symptom was that fcheck would never finish, but would hang at "PROGRESS: validating integrity of /lib/" and leave a ton of fcheck processing haing around (see via 'pgrep -l fcheck'). After a 'sudo kill -9 $(pgrep fcheck)' I'd get a bunch of fcheck ALERT emails telling me: "STATUS:Killed" followed by a bunch of cron messages saying the same thing.

Adding the exclude line per Richard Laager's comment above on 2007-05-08 solved the problem for me.

I'd report this upstream, but I do *not* have the same problem on Debian Etch (which has "/lib/udev/devices/" but the dir is empty)...

Stephan (stephan-fishycam) wrote :

Sorry to bump this back up, but this is a fairly major problem as it makes fcheck basically unusable until people either work out what's going on, or look it up on the Internet and find this page.

It would be great if someone could just add the exclusion in there, fcheck is a nice little package, easy to use and it would be a shame for people to be put off using it just because of this.

JP Vossen (jp-jpsdomain) wrote :

Yet more...

I just installed 8.04.2 64-bit, and fcheck is taking *forever* on the "Building fcheck database (may be some time)..." stage. It seems like its hanging but it's not, top says it's running at least 2 md5sum processes, which are consuming 95%+ of both cores… (Yeah, it's trying to hash my 320G disk. Which is encrypted.)-:

The installer auto-runs the DB build as part of the install, which is normally a Good Thing (and one reason why this is a great package) but in this case that's a problem since it's not obvious how to install it, add the line you need (as above), then re-run.

A work-around on that is to:

$ sudo aptitude install fcheck

Wait for it to hang on the "building…" line then log in to a different terminal, add the EXCLUDE line as above. Go back to the original terminal and hit CTRL-C, which will kill the current DB build, but it will re-try. If that still hangs for more than 10-20 mins, hit CTRL-C several times until you kill the entire install, then just run the install again.

This method worked for me just now.

PLEASE, someone on the MOTU-team just add the EXCLUDE line to the default config!!!

(It might be nice to add a "CFInclude = /etc/fcheck/fcheck-local.cfg" line or similar by default too, if that would not cause any problems. As you are probably aware many packages do things like that to avoid config file collisions. I will be happy to open a bug for that if anyone will actually do something about all of this...)

François Marier (fmarier) wrote :

I have fixed this bug in an upload to Debian unstable.

Changed in fcheck (Ubuntu):
assignee: nobody → François Marier (fmarier)
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fcheck - 2.7.59-10

---------------
fcheck (2.7.59-10) unstable; urgency=low

  * Set myself as maintainer with Maurizio's permission
  * Run the cronjob with nice and ionice
  * Add a note in README.Debian on using fcheck on a laptop
  * Add mailx to the dependencies (closes: #514373)
  * Fix typo in package description (closes: #432720)
  * Exclude two directories which cause problems (LP: #47408)
  * Switch default checksum utility to sha256sum
  * Add a logcheck rule (closes: #484162, LP: #236883)
  * Move the manpage to section 8

  * Bump Standards-Version to 3.8.3
  * Bump debhelper compatibility to 7
  * debian/copyright: cleanup copyright notice
  * debian/control: add homepage and git vcs fields
  * debian/control: cleanup dependencies
  * debian/rules: rewritten from scratch
  * Add watch file
  * Remove upstream INSTALL

 -- Fran?ois Marier <email address hidden> Mon, 05 Oct 2009 12:35:36 +0100

Changed in fcheck (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers