power-usage-report crashed with IndexError in powertop_report(): list index out of range

Bug #1265142 reported by Luke Faraone on 2013-12-31
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
fatrace (Ubuntu)
High
Unassigned

Bug Description

This occurs on running p-u-a on saucy on a Lenovo x220.

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: fatrace 0.5-1
ProcVersionSignature: Ubuntu 3.12.0-7.15-generic 3.12.4
Uname: Linux 3.12.0-7-generic x86_64
NonfreeKernelModules: openafs
ApportVersion: 2.12.7-0ubuntu3
Architecture: amd64
CrashCounter: 1
Date: Mon Dec 30 22:53:41 2013
ExecutablePath: /usr/sbin/power-usage-report
ExecutableTimestamp: 1367153628
InstallationDate: Installed on 2013-03-18 (288 days ago)
InstallationMedia: Ubuntu 12.04.2 LTS "Precise Pangolin" - Release amd64 (20130214)
InterpreterPath: /usr/bin/python3.3
ProcCmdline: /usr/bin/python3 /usr/sbin/power-usage-report
ProcCwd: /home/lfaraone
PythonArgs: ['/usr/sbin/power-usage-report']
SourcePackage: fatrace
Title: power-usage-report crashed with IndexError in powertop_report(): list index out of range
UpgradeStatus: Upgraded to trusty on 2013-11-23 (37 days ago)
UserGroups:

Luke Faraone (lfaraone) wrote :
information type: Private → Public
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fatrace (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) on 2014-01-07
Changed in fatrace (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

Fixed upstream in r52.

Changed in fatrace (Ubuntu):
assignee: Martin Pitt (pitti) → nobody
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fatrace - 0.6-1

---------------
fatrace (0.6-1) unstable; urgency=medium

  * New upstream release:
    - power-usage-report: Fix output parsing for PowerTOP 2.5. (LP: #1265142)
  * Add autopkgtests for fatrace and power-usage-report.
  * Bump Standards-Version to 3.9.5 (no changes necessary).

 -- Martin Pitt <email address hidden> Tue, 07 Jan 2014 15:19:58 +0100

Changed in fatrace (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers