fastqc doesn't generate report due to missing files

Bug #1443275 reported by Redmar on 2015-04-13
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
fastqc (Ubuntu)
Undecided
Unassigned

Bug Description

It appears the fastqc package lacks a number of files required, which means that it cannot display the analysis results, even though it does seem to perform the analysis. This occurs both for the terminal and graphical version of fastqc. I've attached the terminal output of the program since it gives more useful debugging info. I believe the first error (before the progress indicators) is regarding a data file required for some parts of the analysis. The second error is about not finding an image required for generating a report.

Please note: though it runs, this bug makes the fastqc program completely useless since it will not generate any output.

$ fastqc 102517-21_ACAGTG_R1.fastq.gz
java.io.FileNotFoundException: cannot find Confituration/adapter_list.txt
 at uk.ac.babraham.FastQC.Modules.AdapterContent.<init>(AdapterContent.java:79)
 at uk.ac.babraham.FastQC.Analysis.OfflineRunner.processFile(OfflineRunner.java:129)
 at uk.ac.babraham.FastQC.Analysis.OfflineRunner.<init>(OfflineRunner.java:95)
 at uk.ac.babraham.FastQC.FastQCApplication.main(FastQCApplication.java:308)
Started analysis of 102517-21_ACAGTG_R1.fastq.gz
Approx 5% complete for 102517-21_ACAGTG_R1.fastq.gz
Approx 10% complete for 102517-21_ACAGTG_R1.fastq.gz
Approx 15% complete for 102517-21_ACAGTG_R1.fastq.gz
Approx 20% complete for 102517-21_ACAGTG_R1.fastq.gz
Approx 25% complete for 102517-21_ACAGTG_R1.fastq.gz
Approx 30% complete for 102517-21_ACAGTG_R1.fastq.gz
Approx 35% complete for 102517-21_ACAGTG_R1.fastq.gz
Approx 40% complete for 102517-21_ACAGTG_R1.fastq.gz
Approx 45% complete for 102517-21_ACAGTG_R1.fastq.gz
Approx 50% complete for 102517-21_ACAGTG_R1.fastq.gz
Approx 55% complete for 102517-21_ACAGTG_R1.fastq.gz
Approx 60% complete for 102517-21_ACAGTG_R1.fastq.gz
Approx 65% complete for 102517-21_ACAGTG_R1.fastq.gz
Approx 70% complete for 102517-21_ACAGTG_R1.fastq.gz
Approx 75% complete for 102517-21_ACAGTG_R1.fastq.gz
Approx 80% complete for 102517-21_ACAGTG_R1.fastq.gz
Approx 85% complete for 102517-21_ACAGTG_R1.fastq.gz
Approx 90% complete for 102517-21_ACAGTG_R1.fastq.gz
Approx 95% complete for 102517-21_ACAGTG_R1.fastq.gz
Analysis complete for 102517-21_ACAGTG_R1.fastq.gz
Failed to process file 102517-21_ACAGTG_R1.fastq.gz
java.lang.IllegalArgumentException: input == null!
 at javax.imageio.ImageIO.read(ImageIO.java:1388)
 at uk.ac.babraham.FastQC.Report.HTMLReportArchive.base64ForIcon(HTMLReportArchive.java:377)
 at uk.ac.babraham.FastQC.Report.HTMLReportArchive.startDocument(HTMLReportArchive.java:301)
 at uk.ac.babraham.FastQC.Report.HTMLReportArchive.<init>(HTMLReportArchive.java:84)
 at uk.ac.babraham.FastQC.Analysis.OfflineRunner.analysisComplete(OfflineRunner.java:163)
 at uk.ac.babraham.FastQC.Analysis.AnalysisRunner.run(AnalysisRunner.java:110)
 at java.lang.Thread.run(Thread.java:745)

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: fastqc 0.11.2+dfsg-1
ProcVersionSignature: Ubuntu 3.16.0-34.45-generic 3.16.7-ckt8
Uname: Linux 3.16.0-34-generic x86_64
ApportVersion: 2.14.7-0ubuntu8.2
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Apr 13 08:20:29 2015
Dependencies:
 libcommons-math3-java 3.3-1
 libjbzip2-java 0.9.1-3
 libsam-java 1.113-1
InstallationDate: Installed on 2014-08-07 (248 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
PackageArchitecture: all
SourcePackage: fastqc
UpgradeStatus: Upgraded to utopic on 2014-10-27 (167 days ago)

Redmar (redmar) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fastqc (Ubuntu):
status: New → Confirmed

This also happens with FastQC version 0.11.4 on Ubuntu 16.04.1 LTS. The issue can be fixed by copying the contents of the Configuration directory in the source archive to /etc/fastqc.

Dylan Aïssi (daissi) wrote :
Changed in fastqc (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments