[Jaunty Regression] FUSA no longer changes Pidgin's status

Bug #324020 reported by Mackenzie Morgan on 2009-02-01
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
fast-user-switch-applet (Ubuntu)
Medium
Chris Coulson

Bug Description

Binary package hint: fast-user-switch-applet

In Jaunty, choosing a status in the FUSA while Pidgin is running does not update Pidgin's status anymore. Changing the status in Pidgin does update the FUSA, however.

pidgin:
  Installed: 1:2.5.3-0ubuntu2

fast-user-switch-applet:
  Installed: 2.24.0-0ubuntu7

Chris Coulson (chrisccoulson) wrote :

Confirming here. This is because Pidgin changed its DBus interface to require an int32 rather than a uint32 for several methods:

method call sender=:1.53 -> dest=:1.68 serial=27 path=/im/pidgin/purple/PurpleObject; interface=im.pidgin.purple.PurpleInterface; member=PurpleSavedstatusFindTransientByTypeAndMessage
   uint32 5
   string ""
error sender=:1.68 -> dest=:1.53 error_name=org.freedesktop.DBus.Error.InvalidArgs reply_serial=27
   string "Argument 0 is specified to be of type "int32", but is actually of type "uint32"
"
method call sender=:1.53 -> dest=:1.68 serial=28 path=/im/pidgin/purple/PurpleObject; interface=im.pidgin.purple.PurpleInterface; member=PurpleSavedstatusNew
   string ""
   uint32 5
error sender=:1.68 -> dest=:1.53 error_name=org.freedesktop.DBus.Error.InvalidArgs reply_serial=28
   string "Argument 1 is specified to be of type "int32", but is actually of type "uint32"
"
method call sender=:1.53 -> dest=:1.68 serial=29 path=/im/pidgin/purple/PurpleObject; interface=im.pidgin.purple.PurpleInterface; member=PurpleSavedstatusGetCurrent
method return sender=:1.68 -> dest=:1.53 reply_serial=29
   int32 61
method call sender=:1.53 -> dest=:1.68 serial=30 path=/im/pidgin/purple/PurpleObject; interface=im.pidgin.purple.PurpleInterface; member=PurpleSavedstatusGetType
   int32 61
method return sender=:1.68 -> dest=:1.53 reply_serial=30
   int32 2
signal sender=:1.68 -> dest=(null destination) serial=243 path=/im/pidgin/purple/PurpleObject; interface=im.pidgin.purple.PurpleInterface; member=BuddyIconChanged
   int32 8920

Changed in fast-user-switch-applet:
importance: Undecided → Medium
status: New → Triaged
Chris Coulson (chrisccoulson) wrote :

I'm looking at some other FUSA bugs, so I'll take a look at this one too. It should be trivial to fix

Changed in fast-user-switch-applet:
assignee: nobody → chrisccoulson
status: Triaged → In Progress
benste (benste) wrote :

Why did someone link my bug as duplicate of this one even if my one was posted more than one week earlyier?
But it doesn't mater let's take care of this bug

Chris Coulson (chrisccoulson) wrote :

benste - I marked your report as a duplicate of this one. The fact you reported yours earlier is irrelevant - I didscovered this report before yours and this one contains some useful information about the problem. It would have been wasted effort to mark this as a duplicate of yours as it would mean copying the information across in to the master.

benste (benste) wrote :

No prob.
I just thought something like this would be the reason.

- I don't know enough about those things so it's nice to see that you've got the same problem and know what is working wring :-)

Ted Gould (ted) wrote :

The reason for this bug is that Pidgin changed their interfaces from using INTs to UINTs in the latest version. This was a bug that they had, but now has been fixed breaking everyone else :)
I'd be happy to help you find it and fix it, it should be simple changes in the Pidgin interface.

Chris Coulson (chrisccoulson) wrote :

Ted,

I've attached a (quite extensive) patch to bug 282403 that fixes this and some other bugs. It would be great if you could review it :)

Thanks

On Wed, 2009-02-18 at 18:02 +0000, Chris Coulson wrote:
> I've attached a (quite extensive) patch to bug 282403 that fixes this
> and some other bugs. It would be great if you could review it :)

Yes, sorry. seb128 kicked me for not realizing that this morning :)
I'll review it by the end of the weekend.

Chris Coulson (chrisccoulson) wrote :

Thanks Ted. If you have any questions or need me to do anything else, you can catch me in #ubuntu-desktop most evenings

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fast-user-switch-applet - 2.24.0-0ubuntu8

---------------
fast-user-switch-applet (2.24.0-0ubuntu8) jaunty; urgency=low

  * 84_session_management.patch:
    - Use ConsoleKit for shutdown and restart action.
    - Support authenticating with PolicyKit for shutdown and
      restart actions (LP: #282403).
    - Don't hide shutdown and restart actions when gnome-power-manager
      is not running, as they don't depend on it (LP: #298811). Shutdown
      and Restart will be hidden if the system policy doesn't let anybody
      execute these actions from the current console.
    - Pass LIBGNOMEUI_MODULE to gnome_program_init (instead of
      LIBGNOME_MODULE). Without this, gnome_master_client returns NULL
      now, which stops the logout action from working.
  * 90_status_management.patch:
    - Update because the Pidgin DBus interface changed slightly,
      making it impossible to control the status of Pidgin from the
      FUSA (LP: #324020).
  * Updated patches:
    - 91_ltsp_new_features.patch
    - 92_autotools.patch
  * debian/control:
    - Build-depends on libpolkit-gnome-dev and libgnomeui-dev.
      libgnomeui-dev was needed before, but it needs to be explicitly
      defined now, as it no longer gets installed as a dependency of the
      other build-depends.

 -- Chris Coulson <email address hidden> Sun, 15 Feb 2009 19:29:22 +0000

Changed in fast-user-switch-applet:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers