FUSA is missing "Hibernate", "Suspend", "Shut-down" and "Restart" entries

Bug #298811 reported by UbuntuCleric on 2008-11-16
22
This bug affects 1 person
Affects Status Importance Assigned to Milestone
fast-user-switch-applet (Ubuntu)
Low
Chris Coulson

Bug Description

Binary package hint: fast-user-switch-applet

Hi:

I had recently discovered a problem where FUSA (which I love by the way) was missing the entries mentioned in the summary. I eventually discovered the reason it was missing those entries was because gnome-power-manager was not running (I had disabled it from starting up via Sessions). To reproduce this problem, take the following steps:

1) Remove FUSA from your panel
2) Kill gnome-power-manager
3) Add FUSA back to your panel

At this point, you should only see three entries: "Guest session", "Lock screen" and "Log out". I can understand why "Hibernate" and "Suspend" would be missing because the power manager is not running, but its a bug to also remove "Shut-down" and "Restart".

In my humble opinion, FUSA entries should never be removed. For example, if the user clicks on "Hibernate" - and it requires gnome-power-manager which is not running - then either:

1) the power manager should silently start in the background, and then the computer should go into hibernation
OR
2) a dialog box should pop up giving the user the chance to start the power manager, and then have the computer go into hibernation

I think silently disappearing entries can confuse users, as it did me.

Cheers,
UbuntuCleric

Osmo Laitinen (osmo-laitinen) wrote :

I can confirm this. And it was a bit confusing first and later very annoying to shutdown the computer.
Luckily I found this bug and re-enabled gnome-power-manager in sessions.

AndyOsi (andres-osinski) wrote :

I can reproduce it here. I had this appear suddenly and have no idea on how to fix it.

UbuntuCleric (ubuntucleric) wrote :

Looks like it is, although in that bug report, only the "Suspend" and "Hibernate" options were missing. It could be argued that the behaviour described in the report is correct, but I re-iterate my position that entries should not silently disappear as it really confuses a user.

Oddly enough, that bug report made no mention of missing entries for "Shut-down" and "Restart". Could it be he didn't notice it (which seems a little unlikely), or that his fix introduced another problem?

Stéphane Marguet (stemp) wrote :

Same problem here.
No shutdown(s) options on startup, but these options show up after using the updates applet.
Oddly it doesn't work with gksudo from the terminal or by using Synaptic from the menu.

fast-user-switch-applet : 2.24.0-0ubuntu6.1

Changed in fast-user-switch-applet:
status: New → Confirmed
Stéphane Marguet (stemp) wrote :

Updates : it's not only the update applet it's in fact the update manager.
You have to launch it and do a verify or an update, when it ask the password just cancel, and the options are shown.

AndyOsi (andres-osinski) wrote :

Killing gnome-phone-manager solves the issue for me. Very strange bug.

tanktarta (tanktarta) wrote :

Same here, killing gnome-phone-manager fixes it for me.

AndyOsi (andres-osinski) wrote :

Any updates from the gnome-phone-manager or the fusa team?

Chris Coulson (chrisccoulson) wrote :

I'm looking at some other bug fixes for the FUSA applet, and this will be fixed as a side-effect of the changes I'm making (if accepted)

Changed in fast-user-switch-applet:
importance: Undecided → Low
status: Confirmed → In Progress
Changed in fast-user-switch-applet:
assignee: nobody → chrisccoulson
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fast-user-switch-applet - 2.24.0-0ubuntu8

---------------
fast-user-switch-applet (2.24.0-0ubuntu8) jaunty; urgency=low

  * 84_session_management.patch:
    - Use ConsoleKit for shutdown and restart action.
    - Support authenticating with PolicyKit for shutdown and
      restart actions (LP: #282403).
    - Don't hide shutdown and restart actions when gnome-power-manager
      is not running, as they don't depend on it (LP: #298811). Shutdown
      and Restart will be hidden if the system policy doesn't let anybody
      execute these actions from the current console.
    - Pass LIBGNOMEUI_MODULE to gnome_program_init (instead of
      LIBGNOME_MODULE). Without this, gnome_master_client returns NULL
      now, which stops the logout action from working.
  * 90_status_management.patch:
    - Update because the Pidgin DBus interface changed slightly,
      making it impossible to control the status of Pidgin from the
      FUSA (LP: #324020).
  * Updated patches:
    - 91_ltsp_new_features.patch
    - 92_autotools.patch
  * debian/control:
    - Build-depends on libpolkit-gnome-dev and libgnomeui-dev.
      libgnomeui-dev was needed before, but it needs to be explicitly
      defined now, as it no longer gets installed as a dependency of the
      other build-depends.

 -- Chris Coulson <email address hidden> Sun, 15 Feb 2009 19:29:22 +0000

Changed in fast-user-switch-applet:
status: In Progress → Fix Released

Thanks to all those involved in the fix. My computing has just got happier
:-) .

UbuntuCleric (ubuntucleric) wrote :

Yeah, I would like to add my thanks for this too.

Chris Coulson (chrisccoulson) wrote :

There is an error in my patch for this, which means that shutdown and restart still get hidden when g-p-m is not available.

Changed in fast-user-switch-applet:
status: Fix Released → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fast-user-switch-applet - 2.24.0-0ubuntu9

---------------
fast-user-switch-applet (2.24.0-0ubuntu9) jaunty; urgency=low

  [ Chris Coulson ]
  * 84_session_management.patch:
    - Really don't hide shutdown and restart options when
      gnome-power-manager is not available (LP: #298811).

  [ Ted Gould ]
  * 84_session_management.patch:
    * Show dialogs when loging out, shutting down or restarting the
      system to confirm that's what the user wants to do.
      (LP: #283095)
  * 88_status_icons.patch:
    * Adding icons for the dialogs (above). Some themes do not have
      all of the icons required, so these are backup. Taken from the
      GNOME icon theme.
  * Update other patches for line nums, etc.
  * 92_autotools.patch: Regen for changes.

 -- Ted Gould <email address hidden> Wed, 04 Mar 2009 21:01:24 -0600

Changed in fast-user-switch-applet:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers