Please merge fakeroot 1.14.4-1 (main) from Debian testing (main).

Bug #481066 reported by Bhavani Shankar on 2009-11-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
fakeroot (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: fakeroot

Debian changelog

 fakeroot (1.14.4-1) unstable; urgency=low

   * Switch to 3.0 (quilt) source format.
   * Adapt prebuild to preroll for upstream separation.
   * Rename changelog to changelog.Debian.
   * communicate.h: patch from Bernhard Reutner-Fischer to enable LFS
     builds against uClibc. closes: #556257.

 -- Clint Adams <email address hidden> Sat, 14 Nov 2009 22:05:51 -0500

 fakeroot (1.14.3) unstable; urgency=low

   * Apply patch (tweaked) from VMware: "Make sure STAT64_SUPPORT is
     defined on Mac OS, and wrap versioned symbols."
   * Apply patch (tweaked) from VMware: "Wrap *getattrlist() functions
     (Mac OS-specific, used on HFS+ filesystems)."
   * Apply patch (guarded, tweaked) from VMware: "Add debug support."
   * Conditionally build MacOS X symbol-versioned wrappers.

 -- Clint Adams <email address hidden> Tue, 27 Oct 2009 21:55:29 -0400
fakeroot (1.14.2) unstable; urgency=low

   * Apply (tweaked) patch from VMware: "Fix places which were
     incorrectly not using the INT_* macros. This gets rid of a bunch
     of STAT64_SUPPORT checks."
   * Apply patch from VMware: "Move the _STAT_VER argument of all INT_*
     macros from the call site to the definition of the macros."
   * Incorporate fts_children wrapper fixes from VMware version.
   * Apply VMware patch: "Remove the unused 'done' variable in
     load_library_symbols(): the function can only be called once, so
     there is no need for the variable anyway."
   * Apply VMware patch: "Remove from wrapfunc.inp the function which are
     not actually wrapped in libfakeroot.c."

 -- Clint Adams <email address hidden> Tue, 27 Oct 2009 01:16:22 -0400
fakeroot (1.14.1) unstable; urgency=low

   * Apply patch from VMware: "Get rid of a bunch of STUPID_ALPHA_HACK
     checks by always passing 3 arguments to INT_SEND_STAT."
   * Apply patch from VMware: "Get rid of all remaining STUPID_ALPHA_HACK
     checks (except one at the top) by abstracting the difference of
     number of parameters into new SEND_STAT* and SEND_GET_STAT* macros."

 -- Clint Adams <email address hidden> Mon, 26 Oct 2009 23:48:26 -0400
fakeroot (1.14) unstable; urgency=low

   * Wrap fts_children.
   * Bump to Standards-Version 3.8.3.

 -- Clint Adams <email address hidden> Fri, 09 Oct 2009 00:19:14 -0400
fakeroot (1.13.2) unstable; urgency=low

   * Apply patch from Stuart Prescott to rename TEMP variable.
     closes: #550215.
   * Rename PREFIX and BINDIR variables.

 -- Clint Adams <email address hidden> Thu, 08 Oct 2009 23:12:19 -0400
fakeroot (1.13.1) unstable; urgency=low

   * Apply patch from U.V. Ravindra to use native htonll()/ntohll() on Solaris.
   * Apply patch from U.V. Ravindra to properly typecast uid_t/gid_t
     assignments.

 -- Clint Adams <email address hidden> Mon, 28 Sep 2009 21:19:21 -0400
fakeroot (1.13) unstable; urgency=low

   * libfakeroot.c: apply fix from lorenz schori to properly deal with
     STAT64_SUPPORT in fts_read. closes: #541335.

 -- Clint Adams <email address hidden> Thu, 13 Aug 2009 15:25:28 -0400
fakeroot (1.12.5) unstable; urgency=low

   * Disable biarch support on amd64. closes: #538037.
   * Bump to Standards-Version 3.8.2.

 -- Clint Adams <email address hidden> Sat, 01 Aug 2009 01:47:39 -0400

Related branches

Bhavani Shankar (bhavi) wrote :
Changed in fakeroot (Ubuntu):
status: New → Confirmed
Daniel Holbach (dholbach) wrote :

Is this change really still necessary?
 - does this have anything to do with http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=538037 ?
 - there's no libc6-dev-i386 in the archive any more.
 - where do you set BIARCH_LIB_DIR?

Bhavani Shankar (bhavi) wrote :

Daniel

Hmm looked at the above bug and that since debian has disabled BIARCH support and they have placed a conflict on older version of libc6-dev-i386 which is not there in the repos I thought that change has to be carried..

Colin Watson (cjwatson) wrote :

Daniel, you're mistaken:

libc6-dev-i386 | 2.10.2-2ubuntu1 | lucid | amd64

(Maybe you just checked 'apt-cache show' on an i386 system, or something like that?)

Daniel Holbach (dholbach) wrote :

Colin: you're obviously right. Bhavani: can you update the merge to the new version in Debian?

Bhavani Shankar (bhavi) wrote :

Sure daniel

On it now

Sorry for the delay as I was away due to exams and my project

Regards

Changed in fakeroot (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Bhavani Shankar (bhavi)
Bhavani Shankar (bhavi) wrote :

Done daniel

Attached is the updated diff

Regards

Changed in fakeroot (Ubuntu):
status: In Progress → Confirmed
assignee: Bhavani Shankar (bhavi) → nobody
summary: - Please merge fakeroot 1.14.3 (main) from Debian testing (main).
+ Please merge fakeroot 1.14.4-1 (main) from Debian testing (main).
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fakeroot - 1.14.4-1ubuntu1

---------------
fakeroot (1.14.4-1ubuntu1) lucid; urgency=low

  * Merge from debian testing. Remaining changes: LP: #481066
    - drop Conflict with older libc6-dev-i386 packages needed by debian because
      of the BIARCH_LIB_DIR change, we don't need it.

fakeroot (1.14.4-1) unstable; urgency=low

  * Switch to 3.0 (quilt) source format.
  * Adapt prebuild to preroll for upstream separation.
  * Rename changelog to changelog.Debian.
  * communicate.h: patch from Bernhard Reutner-Fischer to enable LFS
    builds against uClibc. closes: #556257.

fakeroot (1.14.3) unstable; urgency=low

  * Apply patch (tweaked) from VMware: "Make sure STAT64_SUPPORT is
    defined on Mac OS, and wrap versioned symbols."
  * Apply patch (tweaked) from VMware: "Wrap *getattrlist() functions
    (Mac OS-specific, used on HFS+ filesystems)."
  * Apply patch (guarded, tweaked) from VMware: "Add debug support."
  * Conditionally build MacOS X symbol-versioned wrappers.

fakeroot (1.14.2) unstable; urgency=low

  * Apply (tweaked) patch from VMware: "Fix places which were
    incorrectly not using the INT_* macros. This gets rid of a bunch
    of STAT64_SUPPORT checks."
  * Apply patch from VMware: "Move the _STAT_VER argument of all INT_*
    macros from the call site to the definition of the macros."
  * Incorporate fts_children wrapper fixes from VMware version.
  * Apply VMware patch: "Remove the unused 'done' variable in
    load_library_symbols(): the function can only be called once, so
    there is no need for the variable anyway."
  * Apply VMware patch: "Remove from wrapfunc.inp the function which are
    not actually wrapped in libfakeroot.c."

fakeroot (1.14.1) unstable; urgency=low

  * Apply patch from VMware: "Get rid of a bunch of STUPID_ALPHA_HACK
    checks by always passing 3 arguments to INT_SEND_STAT."
  * Apply patch from VMware: "Get rid of all remaining STUPID_ALPHA_HACK
    checks (except one at the top) by abstracting the difference of
    number of parameters into new SEND_STAT* and SEND_GET_STAT* macros."

fakeroot (1.14) unstable; urgency=low

  * Wrap fts_children.
  * Bump to Standards-Version 3.8.3.

fakeroot (1.13.2) unstable; urgency=low

  * Apply patch from Stuart Prescott to rename TEMP variable.
    closes: #550215.
  * Rename PREFIX and BINDIR variables.

fakeroot (1.13.1) unstable; urgency=low

  * Apply patch from U.V. Ravindra to use native htonll()/ntohll() on Solaris.
  * Apply patch from U.V. Ravindra to properly typecast uid_t/gid_t
    assignments.

fakeroot (1.13) unstable; urgency=low

  * libfakeroot.c: apply fix from lorenz schori to properly deal with
    STAT64_SUPPORT in fts_read. closes: #541335.

fakeroot (1.12.5) unstable; urgency=low

  * Disable biarch support on amd64. closes: #538037.
  * Bump to Standards-Version 3.8.2.
 -- Bhavani Shankar <email address hidden> Fri, 08 Jan 2010 12:47:39 +0530

Changed in fakeroot (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.