natty fai: debootstrap doesn't install aptitude in nfsroot

Bug #714570 reported by Andreas Sindermann on 2011-02-07
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
fai (Ubuntu)
Undecided
Unassigned

Bug Description

root@faisrv:~# lsb_release -rd
Description: Ubuntu natty (development branch)
Release: 11.04

The FAI /usr/sbin/make-fai-nfsroot script creates a chroot environment ('nfsroot') using the debootstrap command.

At least with Ubuntu 11.04 Alpha 2 the debootstrap command no longer installs the 'aptitude' package by default in this
nfsroot environment. As 'aptitude' is missing, the nfsroot environment stays incomplete and cannot be used for the further installation process.

To resolve this issue, the natty fai-server package needs to be modified this way:

In /etc/apt/make-fai-nfsroot.conf the last line should be changed to:

FAI_DEBOOTSTRAP_OPTS="--exclude=info --include=aptitude"

Andreas

Related branches

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fai - 3.4.7ubuntu2

---------------
fai (3.4.7ubuntu2) natty; urgency=low

  * Changes for Ubuntu:
    + /etc/fai/make-fai-nfsroot.conf:
      - add "--include=aptitude" to FAI_DEBOOTSTRAP_OPTS because
        aptitude changed from Priority: important to optional,
        therefore debootstrap won't install it by default anymore.
        (LP: #714570)
      - add "dhcp-client" to "--exclude" options for FAI_DEBOOTSTRAP_OPTS
    + bin/fai-cd:
      - Fixed missing grub-common package (LP: #710311)
 -- Stephan Adig <email address hidden> Tue, 08 Feb 2011 07:05:15 +0000

Changed in fai (Ubuntu):
status: New → Fix Released
lenios (lenios) wrote :

I can confirm the exact same issue on maverick fai, fresh install and fully updated:

# fai --help
fai FAI 3.4.3ubuntu1, 05 Oct 2010. Copyright (C) 1999-2009 Thomas Lange

# lsb_release -rd
Description: Ubuntu 10.10
Release: 10.10

workaround in /etc/apt/make-fai-nfsroot.conf with the following resolves this:
FAI_DEBOOTSTRAP_OPTS="--exclude=info --include=aptitude"

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers