Sync fai-kernels from Debian

Bug #36991 reported by Guillaume Desmottes
28
Affects Status Importance Assigned to Milestone
fai-kernels (Ubuntu)
High
Reinhard Tartler

Bug Description

This package was removed since Warty but is still very useful.
If we want than FAI be easily usable on Dapper, we should get this package back.

See https://lists.ubuntu.com/archives/ubuntu-devel/2006-March/016475.html
and
https://lists.ubuntu.com/archives/ubuntu-devel/2006-March/016620.html
for more informations.

Changed in fai-kernels:
assignee: nobody → motu-uvf
Revision history for this message
Sebastian Dröge (slomo) wrote :

AFAIK we decided to not have any kernels in universe... but I could be wrong

Revision history for this message
Reinhard Tartler (siretart) wrote :

yeah, but this is a special case. we are talking here about kernels, which are for installation only. So we could make here an exception.

Guillaume: Do you happen to know if these fai-kernels were derived from the debian kernel source or from vanilla kernels?

In either way, we should ask fabbionne for advice. If we decide against having ANY kernel in ubuntu, we NEED a special kernel repository for FAI kernels.

Revision history for this message
Henning Sprang (henning) wrote :

As a developer of FAI, I can confirm this. The package fai-server only lacks a hard dependency against fai-kernels because for experts it is possible to use fai-server without fai-kernels. They can build their own and use it, and we don't want to force them installing a big package as fai-kernels. not so fai-literate users will need the fai-kernels package to get started easily.

Changed in fai-kernels:
status: Unconfirmed → Confirmed
Revision history for this message
Reinhard Tartler (siretart) wrote :

Henning, where are the fai-kernels derived from? debian linux source or mainline linux source?

Do we need to consider to build them against the ubuntu linux source?

Revision history for this message
Henning Sprang (henning) wrote :

Sorry, forgot to say: fai-kernels are made from debian kernel sources. As Reinhard already said, these Kernels are not for installation in running systems, actually, if you install the package fai-kernels, what you get is having 2 Kernel packages in /usr/lib/fai/kernels/ which only get installed in the FAI nfsroot, the system that runs on a client as nfs mounted root installation system.

Revision history for this message
Reinhard Tartler (siretart) wrote :

Henning: it seems to me that it would make more sense to derive fai-kernels in ubuntu from the ubuntu kernel source rather than from the debian kernel source, or did I miss an important fact?

BenC, fabbione? How do you think about this issue?

Revision history for this message
Henning Sprang (henning) wrote :

If Ubuntu doesn't have debian kernel sources, this might be the only possible way. If you have debian kernel sources available, I think the simplest and fastest solution is to use the debian kernels.
Fai-kernels is a separate package from fai, and It's unlikely that the fai-kernels maintainer will have time and possibilities to test and patch fai-kernels to build from Ubuntu Kernel sources in a short timeframe.

Why do you think the Ubuntu kernel is needed?

Revision history for this message
Reinhard Tartler (siretart) wrote :

in ubuntu, we decided to ship no other kernel sources than the 'official' ubuntu kernel sources, so we don't have debian kernel sources in ubuntu.

Revision history for this message
Henning Sprang (henning) wrote :

O.K., I think that's a problem.

I'll try to talk to the fai-kernels maintainer and see what he has to say about this, and how the fai team thinks about the not very usable fai package in ubuntu.

Revision history for this message
Reinhard Tartler (siretart) wrote :

thanks for your effords, henning.

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

I'd say that there's no need for fai, since the preseeding functionality of debian-installer is IMHO superior to fai. I've been using d-i for automated installations for a year now, and fai would be out of the question because of its reliance on NFS.

Revision history for this message
Henning Sprang (henning) wrote : Re: [Bug 36991] Re: Sync fai-kernels from Debian

Timo Aaltonen wrote:
> I'd say that there's no need for fai, since the preseeding functionality
> of debian-installer is IMHO superior to fai. I've been using d-i for
> automated installations for a year now, and fai would be out of the
> question because of its reliance on NFS.
>

What do you want to say with this?
1) FAI doesn't need NFS - you can make a fai-cd

2) Just because you don't need FAI doesn't mean nobody else does. I
won't start a discussion here about the pro's and con's of FAI vs. d-i,
cause I think it's pointless - there are definitely people who want and
need FAI, on Debian AND Ubuntu, and they have their reasons.

3) This bug isn't the right place for this discussion. If you have
nothing to say about the specific bug we are talking about here, please
don't post to the bug.

4) You can mail me personally, or the FAI Mailing list for a deeper
discussion about FAI vs. d-i.

5) I respect the people using d-i - so I would never tell somebody he
can throw d-i away because I have FAI.

Thanks,
Henning

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

I've responded to Henning privately and apologized for my somewhat harsh words.

Revision history for this message
Reinhard Tartler (siretart) wrote :

I have talked with Henning and Thomas at Linuxtag, and will see if we can build a 'fai-kernels' package based on the ubuntu kernel source (2.6 only). Assigning this to me, will look into this shortly

Changed in fai-kernels:
assignee: motu-uvf → siretart
Revision history for this message
Reinhard Tartler (siretart) wrote :

status update about this:
syncing wouldn't work anyway, because the package assumes a debian kernel tree (as in linux-tree-2.6.16) in the archive, which we don't have anyway.
I'm currently working on adapting the source package to ubuntu kernels package, which is the only way anyway, as far as I can see that.

Revision history for this message
Reinhard Tartler (siretart) wrote : old powerpc config

I don't have a powerpc around, could please someone look at this old powerpc kernel configuration, and adapt it to the ubuntu kernel config? I'm on it on amd64 and i386.

Revision history for this message
Reinhard Tartler (siretart) wrote :

fai-kernels are available now in the archive. I expect the powerpc image to be broken, though, but thats another bug

Changed in fai-kernels:
status: Confirmed → Fix Released
Revision history for this message
Andreas Sindermann (sinder) wrote :

This is great news!! I'd like to ask to add support for the
forcedeth driver as the widespread nforce4 chipset based
gigabit ethernet interface is currently not working with the Ubuntu fai-kernels package.

I.e. in the config file change

# CONFIG_FORCEDETH is not set

to

CONFIG_FORCEDETH=y

And a second (minor) issue: As I see the Ubuntu kernel
package currently is alread at version 2.6.15.7 where as
the Ubuntu fai-kernels version still is 2.6.15.6. Do you want
to make sure that they always are synchronized or is this
not that important?

Again thanks for providing fai-kernels again with the Ubuntu
release...

Revision history for this message
Reinhard Tartler (siretart) wrote :

thanks for notifying me, will prepare another upload shortly.

btw, please open another bug next time ;)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers