Activity log for bug #1173265

Date Who What changed Old value New value Message
2013-04-26 16:03:55 Robie Basak bug added bug
2013-05-02 16:21:18 Robie Basak bug added subscriber Ubuntu Sponsors Team
2013-05-02 16:22:45 Robie Basak attachment added debian.debdiff https://bugs.launchpad.net/ubuntu/+source/facter/+bug/1173265/+attachment/3662794/+files/debian.debdiff
2013-05-10 16:39:13 Andres Rodriguez nominated for series Ubuntu Precise
2013-05-10 16:39:13 Andres Rodriguez bug task added facter (Ubuntu Precise)
2013-05-10 16:39:13 Andres Rodriguez nominated for series Ubuntu Quantal
2013-05-10 16:39:13 Andres Rodriguez bug task added facter (Ubuntu Quantal)
2013-05-15 07:53:57 Adam Conrad nominated for series Ubuntu Raring
2013-05-15 07:53:57 Adam Conrad bug task added facter (Ubuntu Raring)
2013-05-17 12:20:32 Robie Basak facter (Ubuntu Precise): status New Invalid
2013-05-20 15:21:09 Robie Basak description If I rebuild 1.6.9-2ubuntu1 in a raring chroot, then when I attempt to run facter I get an error: $ sudo dpkg -i facter_1.6.9-2ubuntu1_all.deb (Reading database ... 77464 files and directories currently installed.) Preparing to replace facter 1.6.9-2ubuntu1 (using facter_1.6.9-2ubuntu1_all.deb) ... Unpacking replacement facter ... Setting up facter (1.6.9-2ubuntu1) ... Processing triggers for man-db ... ubuntu@raring-test:~$ facter -bash: /usr/bin/facter: /usr/bin/ruby1.9.1: bad interpreter: No such file or directory The problem is that /usr/bin/facter gets a shebang of #!/usr/bin/ruby1.9.1 after the rebuild, rather than the #!/usr/bin/ruby1.8 shebang in the binary in the archive. It looks like this might have happened after the ruby metapackage was updated to 4.9 which changed the default ruby to 1.9 from 1.8, causing the facter package build to turn out differently. It also looks like Debian's facter 1.6.10-1 rejigged some of the ruby versioning, so I suspect that the problem can be fixed in Saucy with a simple merge. But I suspect that an attempted SRU to Quantal or Raring will cause a regression unless this bug is fixed there. [Impact] SRUs and security updates are impossible without breaking the package. [Development Fix] My merge of facter 1.7 drops most of the Ubuntu delta that is now no longer necessary. This eliminates the problem. [Stable Fix] Build-Depend on ruby1.8 specifically, instead of the ruby virtual package. The Quantal and Raring binaries in the archive were originally built against ruby1.8 anyway, as this is what the ruby virtual package brought in at the time of the build. With this minimal fix, the build doesn't change to pulling in 1.9.1 instead and thus causing breakage. [Test Case] A dep8 smoke test has been added. If the problem is fixed, the dep8 test should pass. Failing this, just run "facter". If you get a bunch of facts printed out, then the problem is fixed. Note that to test this properly, you should start by not having ruby1.9.1 installed. The two failure possibilities are: # facter /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot load such file -- facter/application (LoadError) from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require' from /usr/bin/facter:58:in `<main>' # facter bash: /usr/bin/facter: /usr/bin/ruby1.9.1: bad interpreter: No such file or directory [Regression Potential] The build could have accidentally changed other things apart from the original Ruby 1.8 dependency since the original build. But since "facter" on its own prints all known facts, it is easy to confidently verify that factor's fact-detection behaviour has not changed unexpectedly after an update. [Original Description] If I rebuild 1.6.9-2ubuntu1 in a raring chroot, then when I attempt to run facter I get an error: $ sudo dpkg -i facter_1.6.9-2ubuntu1_all.deb (Reading database ... 77464 files and directories currently installed.) Preparing to replace facter 1.6.9-2ubuntu1 (using facter_1.6.9-2ubuntu1_all.deb) ... Unpacking replacement facter ... Setting up facter (1.6.9-2ubuntu1) ... Processing triggers for man-db ... ubuntu@raring-test:~$ facter -bash: /usr/bin/facter: /usr/bin/ruby1.9.1: bad interpreter: No such file or directory The problem is that /usr/bin/facter gets a shebang of #!/usr/bin/ruby1.9.1 after the rebuild, rather than the #!/usr/bin/ruby1.8 shebang in the binary in the archive. It looks like this might have happened after the ruby metapackage was updated to 4.9 which changed the default ruby to 1.9 from 1.8, causing the facter package build to turn out differently. It also looks like Debian's facter 1.6.10-1 rejigged some of the ruby versioning, so I suspect that the problem can be fixed in Saucy with a simple merge. But I suspect that an attempted SRU to Quantal or Raring will cause a regression unless this bug is fixed there.
2013-05-20 15:36:40 Robie Basak attachment added precise.debdiff https://bugs.launchpad.net/ubuntu/+source/facter/+bug/1173265/+attachment/3682152/+files/precise.debdiff
2013-05-20 15:37:01 Robie Basak attachment added quantal.debdiff https://bugs.launchpad.net/ubuntu/+source/facter/+bug/1173265/+attachment/3682153/+files/quantal.debdiff
2013-05-20 15:37:23 Robie Basak attachment added raring.debdiff https://bugs.launchpad.net/ubuntu/+source/facter/+bug/1173265/+attachment/3682154/+files/raring.debdiff
2013-05-20 15:38:11 Robie Basak attachment added saucy-v2.debdiff https://bugs.launchpad.net/ubuntu/+source/facter/+bug/1173265/+attachment/3682156/+files/saucy-v2.debdiff
2013-05-21 08:47:50 Robie Basak facter (Ubuntu Quantal): status New Triaged
2013-05-21 08:47:53 Robie Basak facter (Ubuntu Raring): status New Triaged
2013-05-24 16:09:13 Launchpad Janitor facter (Ubuntu): status Triaged Fix Released
2013-05-30 19:16:39 Brian Murray removed subscriber Ubuntu Sponsors Team
2013-06-06 16:58:23 Brian Murray facter (Ubuntu Quantal): status Triaged Fix Committed
2013-06-06 16:58:26 Brian Murray bug added subscriber Ubuntu Stable Release Updates Team
2013-06-06 16:58:28 Brian Murray bug added subscriber SRU Verification
2013-06-06 16:58:35 Brian Murray tags verification-needed
2013-06-06 16:59:58 Brian Murray facter (Ubuntu Raring): status Triaged Fix Committed
2013-09-05 19:30:58 Ubuntu Foundations Team Bug Bot tags verification-needed removal-candidate verification-needed
2013-09-19 08:33:01 Robie Basak tags removal-candidate verification-needed removal-candidate verification-done
2013-09-19 09:56:03 Launchpad Janitor facter (Ubuntu Quantal): status Fix Committed Fix Released
2013-09-19 09:56:13 Colin Watson removed subscriber Ubuntu Stable Release Updates Team
2013-09-19 09:56:28 Launchpad Janitor facter (Ubuntu Raring): status Fix Committed Fix Released