Ubuntu

mpeg4ip incompatibility

Reported by Fabio Di Bernardini on 2006-06-02
10
Affects Status Importance Assigned to Milestone
faac (Ubuntu)
Low
MOTU Media Team

Bug Description

I'm trying to compile mpeg4ip 1.4.1.

When I start the configuration script (bootstrap) it give me an incompatibility warning and stop.

Here the message of ./bootstrap --help

dir: .
SDL appears to be installed
Error - we have detected a version of faac that has libmp4v2 support
and no copy of mpeg4ip-config. This means faac was built with
faad2 and the libraries will be incompatible.
Please reinstall faac without mp4v2 support

Sebastian Dröge (slomo) wrote :

Yes that's right... but if we don't compile faac without the mp4 libs we can't create mp4 files... as the only mp4 lib we currently have is the one from faad we have to use that.
Packaging mpeg4ip might be a problem because of patent reasons but we should take a closer look at this for edgy probably

Someone of motumedia wants to do it maybe? ;)

Changed in faac:
assignee: nobody → motumedia
status: Unconfirmed → Confirmed
Sebastian Dröge (slomo) wrote :

ok, mpeg4ip was uploaded to edgy... only waiting in NEW now.

Changed in faac:
status: Confirmed → In Progress

Christian Marillat uploaded one week ago the new mpeg4ip (1.5.0.1) on Debian Multimedia. It would be nice to include it. It does not build on edgy without modification.

With a little modification (libavcodec-dev instead of libavcodeccvs51-dev which is part of debian-multimedia repository), the package build fine on Ubuntu Edgy.

Sebastian, is it possible to upload this in edgy ? Do you want me to upload the modified package somewhere ?

Precision: the modification is in the Build-Depends of the control file of 1.5.0.1 Marillat package.

Sebastian Dröge (slomo) wrote :

Thanks, I uploaded it a few minutes ago. It still needs to go through NEW before someone can use it...

Loïc Martin (loic-martin3) wrote :

Hello,

Is there any new about including mpeg4ip in Ubuntu? It's not in Feisty nor in Gutsy yet.

Thanks

John Dong (jdong) wrote :

I'm gonna work on doing that :)

John Dong (jdong) wrote :

Uploaded an in NEW in Hardy

Changed in faac:
status: In Progress → Fix Released
Loïc Martin (loic-martin3) wrote :

Thanks a lot John. Looking forward to Hardy!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers