f2fs-formatted USB drive is read-only after filesystem creation

Bug #1746793 reported by Brinstar on 2018-02-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
f2fs-tools (Ubuntu)
Undecided
Unassigned

Bug Description

Description of problem:
I have tried setting up a f2fs USB with various methods (including GNOME Disks, KDE Partition Manager, gparted and mkfs.f2fs and the outcome is always a read-only USB

Version-Release number of selected component (if applicable):
f2fs-tools 1.8.0 (also tried on 1.6.0 with the same result)

How reproducible:
Format a USB drive to f2fs filesystem type and then try to write any file to it.

Steps to Reproduce:
1. Create a filesystem type of f2fs on a USB drive with any program e.g. gparted
2. Remove USB drive safely after creation and re-insert (to make sure the system recognizes it normally)
3. Try to write a file to the drive

Actual results:
The USB is read-only

Expected results:
The USB can be written to with any file

Additional info:
I've been advised that this bug has something to do with how KDE Partition Manager/gparted are not running chown on the USB drive after creation of the f2fs partition.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: f2fs-tools 1.6.1-1
ProcVersionSignature: Ubuntu 4.13.0-32.35~16.04.1-generic 4.13.13
Uname: Linux 4.13.0-32-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia wl
ApportVersion: 2.20.1-0ubuntu2.15
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Feb 1 19:39:43 2018
EcryptfsInUse: Yes
InstallationDate: Installed on 2017-11-30 (63 days ago)
InstallationMedia: Ubuntu 16.04.3 LTS "Xenial Xerus" - Release amd64 (20170801)
SourcePackage: f2fs-tools
UpgradeStatus: No upgrade log present (probably fresh install)

Brinstar (brinstar) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers