0.3.2 crashes

Bug #81578 reported by Richard Kleeman on 2007-01-26
66
Affects Status Importance Assigned to Milestone
F-Spot
Fix Released
Critical
f-spot (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: f-spot

The following error occurs with nvidia proprietary graphics driver and 3d enabled:

An unhandled exception was thrown: GL

  at (wrapper managed-to-native) GdkGlx.Context:glXChooseVisual (intptr,int,int[])
  at GdkGlx.Context..ctor (Gdk.Screen screen, GdkGlx.Context share_list, System.Int32[] attr) [0x00000]
  at GdkGlx.Context..ctor (Gdk.Screen screen, System.Int32[] attr) [0x00000]
  at FSpot.PhotoImageView.HandleRealized (System.Object sender, System.EventArgs args) [0x00000]
  at FSpot.PhotoImageView..ctor (IBrowsableCollection query) [0x00000]
  at FSpot.PhotoView..ctor (IBrowsableCollection query) [0x00000]
  at MainWindow..ctor (.Db db) [0x00000]
  at FSpot.Core.get_MainWindow () [0x00000]
  at FSpot.Core.Organize () [0x00000]
  at FSpot.Driver.Main (System.String[] args) [0x00000]
.NET Version: 2.0.50727.42

Stu Hood (stuhood) wrote :

For me as well.

Same here, using the proprietary fglrx driver.

Aurelien Naldi (aurelien.naldi) wrote :

It is not a driver issue: the exception is a "System.DllNotFoundException" probably a missing lib, but I could not found any kind of "libgl-cil" or "libgtkglext1-cil" :/
Note: happens to me on PPC with the ati Xorg driver.
f-spot 0.31 or 0.32 introduces a new OpenGL view, the ubuntu package have probably not been updated for it. Either a depend is missing or some files have not been added to the package.

Aurelien Naldi (aurelien.naldi) wrote :

Oups, I should have read the upstream bug first.
adding <dllmap dll="GL" target="/usr/lib/libGL.so.1"/> to /usr/lib/f-spot/f-spot.exe.config solved it for me.

Yep, adding the the line solves the problem for me as well.

Changed in f-spot:
status: Unknown → Unconfirmed
Jonh Wendell (wendell) on 2007-01-26
Changed in f-spot:
importance: Undecided → Medium
status: Unconfirmed → Confirmed

ok I solved it too. tnx Aurelien.

Same for me: bug is still there, but adding the line solves the problem.

John Carr (johncarr) wrote :

Same for me; bug is there feisty / f-spot 0.32. Adding that line fixes problem.

a much better fix (taken from the same upstream bug report ) is to do

sudo apt-get install libgl1-mesa-dev

this fixed the issue for me on feisty. and its better to avoid editing files manually if possible.

mafix (mafix) wrote :

same hear...

installing the package libgl1-mesa-dev solves the problem too..

Alexander Jones (alex-weej) wrote :

Also experiencing this problem, and the libgl1-mesa-dev package does indeed fix it.

Andrew Mitchell (ajmitch) wrote :

This is a problem with an incorrect dllmap set in f-spot, which will be fixed in 0.3.3 (should be uploaded within a day or two)

Andrew Mitchell (ajmitch) wrote :

 f-spot (0.3.3-0ubuntu1) feisty; urgency=low
 .
   * New upstream release
     - Fix the insensitive editors problem.
   * Add libgl1-mesa-dev | libgl-dev to Build-Depends to be able to load
     libGL.so.1 at run time (LP: #81578)
   * Disable scrollkeeper usage in debian/ules

Changed in f-spot:
status: Confirmed → Fix Released
Changed in f-spot:
status: Unconfirmed → Fix Released
Loe Spee (lgespee) wrote :

I had this problem on Edgy with a backported F-Spot (v0.3.2).
#apt-get install nvidia-glx-dev
did the trick for me.

Pascal de Bruijn (pmjdebruijn) wrote :

This issue occurs because of the late binding in Mono. This in itself is a feature not a bug. Mono needs the -dev package/libraries to link at runtime. However the f-spot.exe.config file makes runtime linking without the -dev files possible, but it seems they forgot to define it for this release.

In the long run the f-spot.exe.config file should be fixed in the package.

However, in the short run user should just install the -dev package of your GLX provider be it nvidia, ati or mesa. Modifying a file which was installed with a package isn't a good solution and may cause issues when upgrading.

Andrew Conkling (andrewski) wrote :

On 2/11/07, Pascal de Bruijn <email address hidden> wrote:
> In the long run the f-spot.exe.config file should be fixed in the
> package.

This is already fixed in 0.3.3.

sam tygier (samtygier) wrote :

this is not fixed on powerpc
https://launchpad.net/+builds/+build/299511

the package failed to build

Changed in f-spot:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.